Download it now!
Bug 72276 - UI: View > Zoom... menu item with submenu incorrectly has ellipsis
Summary: UI: View > Zoom... menu item with submenu incorrectly has ellipsis
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: BSA target:4.3.0
Keywords:
: 74502 78643 81631 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-03 18:54 UTC by John Smith
Modified: 2014-07-22 06:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the menu text. (26.53 KB, image/png)
2013-12-03 18:54 UTC, John Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2013-12-03 18:54:37 UTC
Created attachment 90181 [details]
Screenshot showing the menu text.

Problem description: 
Click VIEW on the Menu Bar. The last item in the list is ZOOM. This text is followed by an ellipsis and it should not be. This menu item has an arrow correctly indicating that it has a sub-menu.
An ellipsis is used throughout the menus to indicate a clickable command which will bring up a dialogue box.

The ellipsis should be removed from this menu text.


              
Operating System: Windows XP
Version: 4.1.3.2 release
Comment 1 Julien Nabet 2013-12-03 19:44:28 UTC
On pc Debian x86-64 with master sources updated today, I reproduce this.

Stefan: one for you?
Comment 2 Adolfo Jayme 2014-02-05 05:23:47 UTC
*** Bug 74502 has been marked as a duplicate of this bug. ***
Comment 3 Stefan Knorr (astron) 2014-02-05 18:34:40 UTC
// Changing title to add the menu item in question, so I can find it again
// later when looking for things with "zoom" in them, again.
// Sorry for creating the duplicate.
Comment 4 Joel Madero 2014-02-27 23:03:31 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 5 Jorendc 2014-03-07 23:01:24 UTC
Patch submitted for review: https://gerrit.libreoffice.org/#/c/8503/
Comment 6 Commit Notification 2014-04-06 18:33:07 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7007e3952d6bb74bf8c6722df23ee746f773c72c

fdo#72276 introduce .uno:ZoomMenu so we can split the menu entries/labels



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Maxim Monastirsky 2014-05-25 15:04:07 UTC
*** Bug 78643 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2014-07-22 06:50:27 UTC
*** Bug 81631 has been marked as a duplicate of this bug. ***