Bug 72401 - UI: Slow preformance scrolling
Summary: UI: Slow preformance scrolling
Status: RESOLVED DUPLICATE of bug 68961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.2.0.0.beta2:Ubuntu NoRepro:...
Keywords: perf
Depends on:
Blocks:
 
Reported: 2013-12-06 15:29 UTC by Chris
Modified: 2015-12-15 11:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample spreadsheet (19.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-06 15:29 UTC, Chris
Details
screenshot_laggy (399.71 KB, image/png)
2013-12-19 21:43 UTC, Chris
Details
scrot_1_down (166.15 KB, image/png)
2013-12-19 23:37 UTC, Chris
Details
scrot_2_up (193.44 KB, image/png)
2013-12-19 23:37 UTC, Chris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2013-12-06 15:29:41 UTC
Created attachment 90366 [details]
sample spreadsheet

Problem description: 
Laggy scrolling all documents in Calc.

Steps to reproduce:
1. Open attached file.
2. Try to scroll... 
3. View become very laggy.

Reproduce this in LibreOffice 4.1. Scrooling perfect without lag. Significant regression.

 
Current behavior:
Scrolling very laggy. 

Expected behavior:
All documents run smooth and fast. 

Platform: LibreOffice 4.2 beta1 & beta2 -- Linux/Debian
Comment 1 Robinson Tryon (qubit) 2013-12-07 02:31:39 UTC
TESTING on LO 4.2.0.0.beta2 + Ubuntu 12.04.3

(In reply to comment #0)
> 
> Steps to reproduce:
> 1. Open attached file.
> 2. Try to scroll... 
> 3. View become very laggy.

NOREPRO -- scrolling works fine for me.


Chris - Do you have hardware acceleration enabled?

- Tools -> Options -> LibreOffice(Dev) -> View
- Graphics output: [x] Use hardware acceleration
Comment 2 Chris 2013-12-19 08:16:45 UTC
> NOREPRO -- scrolling works fine for me.
> 
> 
> Chris - Do you have hardware acceleration enabled?

Yes.


I checked on three different computers (Debian 7 & Ubuntu 13.10)

LibreOffice 4.2 RC1. No changes.
Comment 3 Robinson Tryon (qubit) 2013-12-19 09:39:20 UTC
(In reply to comment #2)
> I checked on three different computers (Debian 7 & Ubuntu 13.10)
> 
> LibreOffice 4.2 RC1. No changes.

Still NOREPRO for me on 4.2.0.1 + Ubuntu 12.04.3 x86-64.

I'll try to find someone w/Debian 7 or Ubuntu 13.10 to test.

Status: UNCONFIRMED
Comment 4 Stephan van den Akker 2013-12-19 20:39:24 UTC
Compared on Ubuntu 13.10 (x86-64):
- Version: 4.1.2.3, Build ID: 410m0(Build:3)
- Version: 4.2.0.0.beta2, Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d

Tried scrolling with arrow keys, Page Down key and with scrollbar. I don't notice much difference in speed between the compared versions: NOREPRO.
Comment 5 Robinson Tryon (qubit) 2013-12-19 21:25:34 UTC
Hi Chris,

Can you tell us more about your systems -- any particular configurations or unique customizations to the OS and/or LO that might be affecting the results?

It's really bizarre that you can repro on multiple systems, and we can't repro on any of ours...
Comment 6 Chris 2013-12-19 21:43:22 UTC
Created attachment 91006 [details]
screenshot_laggy
Comment 7 Chris 2013-12-19 21:52:44 UTC
Ok, check the screentshot during the scrolling up document: numbered list, lines 65-70 - incorrect refresh.

My distro is Crunchbang.
Comment 8 Robinson Tryon (qubit) 2013-12-19 23:06:01 UTC
(In reply to comment #7)
> Ok, check the screentshot during the scrolling up document: numbered list,
> lines 65-70 - incorrect refresh.
> 
> My distro is Crunchbang.

Hi Chris,

The example spreadsheet you uploaded does not look like the screenshot you provided -- looks like you uploaded a sanitized version of your original document. One change that stands out to me is that there are no visible column headers in attachment 90366 [details].  

Can you reproduce the slow performance with the test document (attachment 90366 [details])?
Comment 9 Chris 2013-12-19 23:37:12 UTC
Created attachment 91009 [details]
scrot_1_down
Comment 10 Chris 2013-12-19 23:37:45 UTC
Created attachment 91010 [details]
scrot_2_up
Comment 11 retired 2013-12-21 21:33:27 UTC
Never heard of Crunchbang distro. So far no one seems to be able to reproduce the problem and here on OS X your test file opens and scrolls pretty smooth. Do you have access to any Ubuntu distribution? I'd be curious to hear how that behaves for you.
Comment 12 retired 2014-01-08 10:52:56 UTC
*** Bug 73007 has been marked as a duplicate of this bug. ***
Comment 13 Jean-Baptiste Faure 2014-01-11 15:37:18 UTC
Closing this bug report as a duplicate of bug 68961.

Chris: please could you try a master build containing the fix for bug 68961?

Please, feel free to reopen if you disagree.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 68961 ***
Comment 14 Robinson Tryon (qubit) 2015-12-15 11:27:38 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]