Bug 73007 - Calc: Value in the last cell repeats when scrolling with scroll bar
Summary: Calc: Value in the last cell repeats when scrolling with scroll bar
Status: RESOLVED DUPLICATE of bug 68961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:Ubuntu
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-12-24 06:50 UTC by Kevin Suo
Modified: 2014-01-09 09:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2013-12-24 06:50:34 UTC
Steps to reproduce:

1. Start a new calc spreadsheet'
2. Input "1" in A1, drag and fill to "the last visible column cell of your screen" +1. (For example, on my screen column O is the last visible, so drag and fill to P1.) 
3. Scroll with your scroll bar to the right.

Current behaviour:
The value in the last visible cell was "repeating" when scrolling. When stop scrolling the correct value shows.

Expected:
The value shows what is should be.

Should be a regression against 4.1.4.2.
Comment 1 Robinson Tryon (qubit) 2013-12-24 06:59:48 UTC
CONFIRMED on Ubuntu 12.04.3 with
LibreOffice Version: 4.2.0.1

(In reply to comment #0)
> Steps to reproduce:
> 
> 1. Start a new calc spreadsheet'
> 2. Input "1" in A1, drag and fill to "the last visible column cell of your
> screen" +1. (For example, on my screen column O is the last visible, so drag
> and fill to P1.) 
> 3. Scroll with your scroll bar to the right.
> 
> Current behaviour:
> The value in the last visible cell was "repeating" when scrolling. When stop
> scrolling the correct value shows.

Confirmed.

> Expected:
> The value shows what is should be.
> 
> Should be a regression against 4.1.4.2.

I have LO Version: 4.1.2.2 and can confirm that this behavior does not exist in that version.

Status: NEW
Keywords: regression
Comment 2 m.a.riosv 2013-12-24 20:20:19 UTC
Confirmed.
Win7x64Ultimate
Version: 4.2.0.1 Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a
Comment 3 Chris 2013-12-29 19:52:21 UTC
Confirmed and I reported the same bug: 
https://bugs.freedesktop.org/show_bug.cgi?id=72401
Comment 4 Jan Holesovsky 2014-01-08 10:36:19 UTC
Would be great to have a bibisect for this one.
Comment 5 retired 2014-01-08 10:52:56 UTC
Dupe as of comment 3

*** This bug has been marked as a duplicate of bug 72401 ***
Comment 6 Terrence Enger 2014-01-08 15:41:23 UTC
Changing the duplicate bug number to 68961 because that seems to better match this problem.

Yes, this is a regression, but it is merely a briefly confusing display.  I question whether MAB status is appropriate.

*** This bug has been marked as a duplicate of bug 68961 ***
Comment 7 Jan Holesovsky 2014-01-09 09:16:45 UTC
When this became a duplicate, we need to add the other one to MAB :-)