Bug 72520 - FILESAVE : Embedded .xlsx file is not exported for chart (docx).
Summary: FILESAVE : Embedded .xlsx file is not exported for chart (docx).
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Sushil Shinde
URL:
Whiteboard: Confirmed:4.3.0.0a0+:OSX10.9 target:4...
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2013-12-09 13:44 UTC by Sushil Shinde
Modified: 2014-02-19 13:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original file. (23.52 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-09 13:44 UTC, Sushil Shinde
Details
Saved On LO. (8.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-12-09 13:45 UTC, Sushil Shinde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sushil Shinde 2013-12-09 13:44:48 UTC
Created attachment 90512 [details]
Original file.

Embedded .xlsx file is not exported after saving file on LO.

- Open attached file on LO.
- Save file on LO as docx file.
- Open saved file on MS Word.
- Right click on chart on MS and select "edit Data" option.
- After selecting "edit data" option on saved file nothing happens.
- But on slecting same option for original file it allows to edit chart by opening chart in word exel format.


Checked by extracting file, I found that .xlsx file is missing from embedded folder in word.

Expected behaviour is, chart should be editable on both files original and saved on LO in MS Word.
Comment 1 Sushil Shinde 2013-12-09 13:45:08 UTC
Created attachment 90513 [details]
Saved On LO.
Comment 2 retired 2013-12-17 10:06:36 UTC
Confirmed. Doing the same with the original file (opening in word then right click chart + select "edit data" does indeed open excel while the newly saved docx file from LO does not do that.

Setting to NEW.
Comment 3 Alexandr 2013-12-27 13:56:38 UTC
Still reproducible in LibreOffice 4.3.0.0.alpha0+
Build ID: fdc1b1fc174da27e3016370fdb603d6bbe49af4d
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-12-26_10:00:24
on Debian testing.


I think it is a duplicate of bug 72304. In both cases *.docx/word/embeddings/*.xlsx is lost after saving.

*** This bug has been marked as a duplicate of bug 72304 ***
Comment 4 Sushil Shinde 2013-12-28 04:59:07 UTC
(In reply to comment #3)
> Still reproducible in LibreOffice 4.3.0.0.alpha0+
> Build ID: fdc1b1fc174da27e3016370fdb603d6bbe49af4d
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2013-12-26_10:00:24
> on Debian testing.
> 
> 
> I think it is a duplicate of bug 72304. In both cases
> *.docx/word/embeddings/*.xlsx is lost after saving.
> 
> *** This bug has been marked as a duplicate of bug 72304 ***

@ Alexandr 

I dont think this issue is duplicate of 72304.
In issue 72304 data is missing from chart.xml file.
In this issue external embedded data file is missing. 
Yes currently *.docx/word/embeddings/*.xlsx is lost from all docx files which contains chart.
Comment 5 Sushil Shinde 2013-12-30 06:19:47 UTC
This issue is not duplicate of bug 72304.
In 72304 <c:dTable>.... <c:dTable/> tag was missing because of that
data table from chart was missing.
In this issue external embedded xlsx file is missing which is used by
microsoft office to edit chart data. Hence reopning this issue.
Comment 6 Commit Notification 2014-01-10 12:16:22 UTC
sushil_shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e114b9967ddfb490cd9865220520701004db7ab

fdo#72520 : Added embedded data of docx file to InteropGrabBag.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-10 12:21:47 UTC
sushil_shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a37043b8d1508b3a3a2844e9092e4af05d726f28

fdo#72520 : Exporting embedding data folder from grab bag.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 retired 2014-01-10 13:21:16 UTC
sushil can we set this to fixed already?
Comment 9 Sushil Shinde 2014-01-10 13:42:53 UTC
(In reply to comment #8)
> sushil can we set this to fixed already?

Foss, No.. there are three more changeset related to this issue are not yet merged to master.

https://gerrit.libreoffice.org/#/c/7212
https://gerrit.libreoffice.org/#/c/7214
https://gerrit.libreoffice.org/#/c/7215

these changes are pending for review.. once these changes get merged to master then we can mark it as fixed.
Comment 10 Commit Notification 2014-01-16 01:47:37 UTC
sushil_shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2054af83fefb955e20de2b40178a11726525057e

fdo#72520 : Added property to store external data path in chart.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-01-16 13:43:54 UTC
sushil_shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1e6269d1c0b312a2990324f0334527d2c04414a

fdo#72520 : Exporting sheet external data for chart for docx files.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-02-12 02:38:29 UTC
sushil_shinde committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5505cf4f1c7b27662b0e8c0a6db01fd8c52243c3

fdo#72520 : Preserving external data path in chart import.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.