Bug Hunting Session
Bug 72727 - Chart: Label on X axis are lost when copying from Calc to Writer, Impress and Draw
Summary: Chart: Label on X axis are lost when copying from Calc to Writer, Impress and...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:4.3.0.1 target:4.2.6
Keywords: regression
: 73931 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-15 09:52 UTC by sophie
Modified: 2014-12-12 21:38 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sophie 2013-12-15 09:52:35 UTC
This has been confirmed by this test
http://manual-test.libreoffice.org/results/case/1193/ 
Reproduced with Version: 4.2.0.0.beta2
Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d Ubuntu 13.10 64. 
Step to reproduce:
- Download the simple test example
- Copy the chart from Calc with Edit > Copy
- Open a Writer document
- Paste the chart with Edit > Paste --> x labels are missing
Sophie
Comment 1 Jacques Guilleron 2013-12-15 10:55:29 UTC
Hello Sophie,

The same on Windows 7 Home Premium. x labels are missing on Chart after copy.

Kind regards,

Jacques
Comment 2 tommy27 2014-01-26 09:20:55 UTC
*** Bug 73931 has been marked as a duplicate of this bug. ***
Comment 3 tommy27 2014-01-26 09:21:54 UTC
works fine with 4.1.4.2  --> regression
Comment 4 tommy27 2014-01-26 09:23:41 UTC
issue not limited to Writer.
same bug when you paste to Impress and Draw as well.
edited summary notes
Comment 5 Andras Timar 2014-03-25 06:48:06 UTC
b090cbdf82e0827234caf5969124f6631311ef35 is the first bad commit
commit b090cbdf82e0827234caf5969124f6631311ef35
Author: Lionel Elie Mamane <lionel@mamane.lu>
Date:   Fri Aug 30 18:00:21 2013 +0200

    fdo#68663 don't blindly force categories when there are none
Comment 6 Lionel Elie Mamane 2014-03-25 06:59:56 UTC
As a point of additional data, this commit was discussed in thread starting at
http://lists.freedesktop.org/archives/libreoffice/2013-August/055558.html
Comment 7 Markus Mohrhard 2014-04-14 16:32:15 UTC
(In reply to comment #6)
> As a point of additional data, this commit was discussed in thread starting
> at
> http://lists.freedesktop.org/archives/libreoffice/2013-August/055558.html

I'm not happy with the commit. It clearly breaks copy&paste and categories are not necessarily written out. I would vote to revert the patch and look for a proper fix without breaking chart2 in all other applications.
Comment 8 Lionel Elie Mamane 2014-04-24 11:12:08 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > As a point of additional data, this commit was discussed in thread starting
> > at
> > http://lists.freedesktop.org/archives/libreoffice/2013-August/055558.html
> 
> I'm not happy with the commit. It clearly breaks copy&paste and categories
> are not necessarily written out. I would vote to revert the patch and look
> for a proper fix without breaking chart2 in all other applications.

Who understands the principles of the charts code? When should categories be present and when not, and whose responsibility is it to add them / how can an application signal to the chart code it does not want categories?
Comment 9 Markus Mohrhard 2014-05-09 21:00:00 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > As a point of additional data, this commit was discussed in thread starting
> > > at
> > > http://lists.freedesktop.org/archives/libreoffice/2013-August/055558.html
> > 
> > I'm not happy with the commit. It clearly breaks copy&paste and categories
> > are not necessarily written out. I would vote to revert the patch and look
> > for a proper fix without breaking chart2 in all other applications.
> 
> Who understands the principles of the charts code? When should categories be
> present and when not, and whose responsibility is it to add them / how can
> an application signal to the chart code it does not want categories?

I think currently I'm the one knowing most about the chart code. I would need to explore why base is behaving different than calc, writer, impress but an initial look at the file shows that the data table has a slightly different form.

I still think we should revert this patch as it breaks copying charts and it is a regression.
Comment 10 Commit Notification 2014-06-05 19:04:41 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91ca3a92c54a08ad13497d7e8ac1916e7b68bbfd

fdo#72727: Revert "fdo#68663 don't blindly force categories when there are none"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-06-05 19:06:17 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f025f22e8dfd7fe03527604e0edee8a8a818cca&h=libreoffice-4-3

fdo#72727: Revert "fdo#68663 don't blindly force categories when there are none"


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Kohei Yoshida 2014-06-05 19:08:45 UTC
4.2 backport: https://gerrit.libreoffice.org/9658
Comment 13 Kohei Yoshida 2014-06-05 19:09:37 UTC
(In reply to comment #9)

> I still think we should revert this patch as it breaks copying charts and it
> is a regression.

Since nothing is happening, and the chart breakage is significant, I took this advice and reverted it.  Sorry.
Comment 14 Commit Notification 2014-06-05 19:18:17 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61d958f37ed2aad6be2eab7bb507e0fb77716eec

fdo#72727: Revert "-Werror=unused-but-set-variable second try"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-06-05 19:19:53 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84c8157b46e5b2feff48f8a9e8d5df2879c5a740&h=libreoffice-4-3

fdo#72727: Revert "-Werror=unused-but-set-variable second try"


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2014-06-06 01:11:00 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5a53dfa86a2b61154f4c2c7cb356d32a569aaf69&h=libreoffice-4-2

fdo#72727: Revert "fdo#68663 don't blindly force categories when there are"


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2014-06-06 01:11:16 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b959fb871a68f08a06850909abd16f71033aa3a&h=libreoffice-4-2

fdo#72727: Revert "-Werror=unused-but-set-variable second try"


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.