Bug 61805 - EDITING: Copy chart from Calc to any other component (Writer, Impress, Draw) lost axis formating
Summary: EDITING: Copy chart from Calc to any other component (Writer, Impress, Draw) ...
Status: RESOLVED DUPLICATE of bug 71767
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-04 17:34 UTC by IM
Modified: 2014-06-19 14:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Chart to Copy & Paste to See Error (14.86 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-22 13:58 UTC, Joel Madero
Details
pasting results into writer 4.0.3.3 (58.74 KB, application/vnd.oasis.opendocument.text)
2013-05-27 07:42 UTC, bugquestcontri
Details
pasting results into writer 3.6.6.2 (32.41 KB, application/vnd.oasis.opendocument.text)
2013-05-27 07:43 UTC, bugquestcontri
Details
sample chart which does not paste OK in writer, Outlook, etc. (13.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-03 08:31 UTC, Winfried Donkers (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description IM 2013-03-04 17:34:51 UTC
Problem description:  
Percentage values of chart changed to decimal after copying to document(.odt) 

Steps to reproduce:
1. Create any chart with dual y-axis where unit of axis in %.
2. Open any document using Libreoffice writer. 
3. Copy chart form calc to writer.

Current behavior:
% values change to decimal values.

Expected behavior:
% values.
              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Joel Madero 2013-03-04 19:26:55 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.0.0.alpha0+ (Build ID: 2bb13b83e40aec362964d26921a3fc1660a5da2)
 Date:   Thu Feb 28 20:17:25 2013 +0100 
Platform: Bodhi Linux 2.2 x64


Works ok:
Version 3.6.5.2 on Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal (can prevent high quality work)
High (regression so pushed it to high)

Keywords - Regression

Whiteboard Status - Bibisect40 (working on this now)

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2013-03-04 19:27:32 UTC
More notes -it's copy/paste to ANY component, not to writer only, when you copy, formatting is lost for Y axis
Comment 3 IM 2013-03-04 19:35:59 UTC
Hi Joel,

As you rightly pointed that the format get lost when copy paste to any, not only writer.

Regards

IM
Comment 4 Joel Madero 2013-03-04 19:37:58 UTC
Not sure how useful this bisect will be as I saw the entire bug regarding copy/paste chart being empty but this coincided with labels changing so:


9a5620ca6473969359f262802c76daf35cbcbb5d is the first bad commit
commit 9a5620ca6473969359f262802c76daf35cbcbb5d
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 01:59:31 2012 +0000

    source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
    
    commit ae4e4a11d4300f7448cb6bd170fcb034542caddc
    Author:     Rene Engelhard <rene@debian.org>
    AuthorDate: Tue Nov 6 21:24:32 2012 +0100
    Commit:     Rene Engelhard <rene@debian.org>
    CommitDate: Tue Nov 6 21:24:32 2012 +0100
    
        typo...
    
        Change-Id: I2c7968194afbcf74967cd16c639dce7de858a513

:100644 100644 c09b92a8ddf24b8738a7cd3a695ae1e4482d354c 6b13afd13f023cedac65a896318de4aa55dead27 M	autogen.log
:100644 100644 bcee1e11bd693642ca5a6330175b58082e5dcdd0 54d2377f5b3afd6ed668b3e24cb877c289119ec5 M	ccache.log
:100644 100644 75677cef16786d2cc95c0d8f301482278ca055c3 d18a6ebcd3b8537c3dd3dbc16e862fb6370ecb8a M	commitmsg
:100644 100644 83b4ecc0ecb3e031c804d49f45f854e95d5cc961 d482c00e5fff6081c6b87b637fd9ffaf3e1e2c6c M	dev-install.log
:100644 100644 91437b9974ffada7e049273419bb8c66c91c0539 abf45ab9609c77a5ab952aa310eafe8c2ffaf85c M	make.log
:040000 040000 45c0bab8b669778ab523c8f65a25e8c9afde604a f4bfa15b2f72d3df5675b07bcf32254a819b9d19 M	opt


# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 114fd3b76bcba890e6d702d00cef910f1493c262
# bad: [47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect bad 47498a36f7af8f54e6e3dda89cd4708802a409e6
# good: [f4e2d84db194943180f3e7ed4adce5f8e377d9bc] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good f4e2d84db194943180f3e7ed4adce5f8e377d9bc
# bad: [fb4214f9d134b556582a4a5280e5458de5f8eebd] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
git bisect bad fb4214f9d134b556582a4a5280e5458de5f8eebd
# good: [e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good e2e46267c18c2706de771a08472ebfce19f68520
# bad: [9a5620ca6473969359f262802c76daf35cbcbb5d] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
git bisect bad 9a5620ca6473969359f262802c76daf35cbcbb5d



@Markus & Kohei - might be a dupe of the other chart bug(s) but it seems a bit different, interested in looking into it?
Comment 5 Markus Mohrhard 2013-04-22 12:37:31 UTC
Can you please attach a test document? If I find some free time before the feature freeze I might look into it.
Comment 6 Joel Madero 2013-04-22 13:58:16 UTC
As requested, copy this chart into any other component and you'll see the issue.

Thanks Markus :)
Comment 7 Joel Madero 2013-04-22 13:58:35 UTC
Created attachment 78329 [details]
Chart to Copy & Paste to See Error
Comment 8 bugquestcontri 2013-05-27 07:40:03 UTC
Triggered by AskLibO http://ask.libreoffice.org/en/question/18111/transferring-graphs-from-calc-to-writer/?answer=18118#post-id-18118

I made tests:

Chart created in LibO 3.6.5 and updated in 3.6.6.2 as well as 4.0.3.3 
Copied into Writer 4.0.3.3 original template
pasting
1 - ctrl+v
2 - as Star Object
3 - as GDI file
resulted in the lost of the date format (x-axis)

See attached file

The same chart copied into Witer 3.6.6.2 
pasting 
1 - ctrl+v
2 - as Star Object
3 - as GDI file
resulted
1 & 2 are correct no problem observed
3 - the right border of the chart is not to be seen in Writer, rest is OK

See attached files.
Comment 9 bugquestcontri 2013-05-27 07:42:20 UTC
Created attachment 79832 [details]
pasting results into writer 4.0.3.3
Comment 10 bugquestcontri 2013-05-27 07:43:15 UTC
Created attachment 79833 [details]
pasting results into writer 3.6.6.2
Comment 11 bugquestcontri 2013-05-27 07:48:41 UTC
OS used in comment 8: XP Prof / SP3
Comment 12 ign_christian 2013-06-11 04:42:59 UTC
It seems copy-paste different chart generates different behavior. Please see:
Bug 63025 & Bug 63017.

I don't know whether it's the same.
Comment 13 Markus Mohrhard 2013-06-30 03:28:03 UTC
It is an import bug.

The exported document still looks ok but we seem to loose the information during import with the internal data provider.
Comment 14 Markus Mohrhard 2013-06-30 06:23:02 UTC
And I again have a really dirty hack that might introduce another regression.

The problem is again the changed order of calls during import. I need to think about it a bit if we can't solve all these cases at once.
Comment 15 Winfried Donkers (retired) 2013-10-03 08:31:13 UTC
Created attachment 87018 [details]
sample chart which does not paste OK in writer, Outlook, etc.

Attached document shows a simple chart with dates as X-values.
When copy/pasting this chart to another application (e.g. Writer or MS Outlook), the dates on the X-axis are shown as integers (i.e. unformatted).

When pasting in Writer, the chart can be edited and the date format restored, but when pasting to other applications, such as MS Outlook, that is not possible.

(Libreoffice version 4.0.5.2 and 4.1.2.2, Windows 7)
Comment 16 Robinson Tryon (qubit) 2013-10-23 16:49:55 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 17 Francisco 2014-05-18 21:37:12 UTC
*** Bug 73984 has been marked as a duplicate of this bug. ***
Comment 18 Joel Madero 2014-06-06 15:06:08 UTC
When nominating a bug please explain why on the meta tracker :) Can someone test again on 4.2.4.2 release? If it still exists on 4.2.4.2 then please add to MAB as it seems like a valid one to be over there and set importance to highest. Thanks!
Comment 19 Winfried Donkers (retired) 2014-06-10 06:19:40 UTC
Checked with Libreoffice version 4.2.5.1, Windows 7:

-problem with attachment 78329 [details] is still there.
-problem with attachment 87018 [details] is still there.

-when following instructions as in Description of this bug report, i.e. creating a chart for which the secundary y-axis has a unit in % (and the primary y-axis has not), the problem seems solved.
Comment 20 Kohei Yoshida 2014-06-19 14:35:20 UTC

*** This bug has been marked as a duplicate of bug 71767 ***