Bug Hunting Session
Bug 78369 - Legend issues after copy paste
Summary: Legend issues after copy paste
Status: RESOLVED DUPLICATE of bug 77506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 73984 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-07 04:53 UTC by Jan Husarik
Modified: 2014-06-19 14:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc Chart to be copied to Impress (18.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-05-07 05:28 UTC, Cyril
Details
screenshot of charts copied and pasted from Calc into Impress, and the copied and pasted from Impress itself (166.50 KB, image/png)
2014-06-18 09:18 UTC, Francisco
Details
Second screenshot for Comment 11 (209.09 KB, image/png)
2014-06-18 09:19 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Husarik 2014-05-07 04:53:30 UTC
When copy-paste a chart from Calc to Impress several issues appear:

1.) Legend names shift by 1 every time the presentation is saved until it completely disappears.

2.) Even if the legend names are edited in DATA TABLE in Impress, it will still disappear after save/open

3.) Even if the legend names are present, they are removed (or shifted by 1 down) if the presentation is shown in full screen or exported to PDF

4.) Additional empty and duplicated columns appear in the charts after copy paste. I was trying to figure out circumstances under which this last error occurs but could not find clear pattern.


Note: special copy paste GDI-metafile works but that is not really a solution since it is pasted as picture and cant be properly re-sized without influencing font size/aspect ratio.

Thank you for all the hard work, sincerely, Jan
Comment 1 Cyril 2014-05-07 05:16:12 UTC
Jan, could you please specify LO version and platform type you were using?
Comment 2 Cyril 2014-05-07 05:28:34 UTC
Created attachment 98598 [details]
Calc Chart to be copied to Impress

Calc Chart to be copied to Impress with disappearing X legend.
Comment 3 Cyril 2014-05-07 05:29:32 UTC
With LO Version: 4.2.3.3 Build ID: 420m0(Build:3) and Ubuntu Studio x86_64, X legend completely disappear at first paste from Calc to Impress.
Comment 4 Jan Husarik 2014-05-07 07:36:58 UTC
I was using Windows 7
Version: 4.2.3.3
Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0

but I had the same issue with OS X 10.9.2
Version: 4.2.0.4

did not test on linux yet
Comment 5 Francisco 2014-05-18 21:46:13 UTC
I have experienced the same bug under Kubuntu X86_64 with LibO 4.2.3, and not under LibO 4.1.5. Marking as NEW and possible related to bug 61805, though this is a quite different and older bug.
Comment 6 Francisco 2014-05-18 21:48:00 UTC
(In reply to comment #5)
> I have experienced the same bug under Kubuntu X86_64 with LibO 4.2.3, and
> not under LibO 4.1.5. Marking as NEW and possible related to bug 61805,
> though this is a quite different and older bug.

I added version 4.2.0.4 and platform: ALL since we have seen this behavior under 3 OSs and the older version where this bug has been seen is that.
Comment 7 Joel Madero 2014-05-21 23:38:05 UTC
@Francisco - indeed looks nasty. Can you confirm that this is a regression? Ie. was it present in 4.1? If not - have you ever bibisected ? (if not, are you willing to learn how to?). That helps tremendously. If it's a regression a bibisect would be nice and then I think it could go on 4.2mab :)
Comment 8 Francisco 2014-06-17 22:10:09 UTC
(In reply to comment #7)
> @Francisco - indeed looks nasty. Can you confirm that this is a regression?
> Ie. was it present in 4.1? If not - have you ever bibisected ? (if not, are
> you willing to learn how to?). That helps tremendously. If it's a regression
> a bibisect would be nice and then I think it could go on 4.2mab :)

Yes, that's the version Im using right now. And it has been working it all versions until now.

Sorry for my late reply, I didn't recive any email with this.
Comment 9 Francisco 2014-06-17 22:15:27 UTC
Ah, and, no, I have never done that. I always though it was pretty specific and... well, "difficult" to understand.

But if it's not that difficult, what should I do to know what to do?
Comment 10 Jan Husarik 2014-06-18 00:45:57 UTC
A little update:

1.) I noticed that the labels disappear immediately when trying to copy-paste multiple graphs at once from Calc to Impress. This was observed on Windows 7,LO 4.2.4.2. Could not check on other platforms yet.

2.) I tested copy-paste one by one grpahs on Ubuntu (sorry, didnt quite remember the version but as of last week it was most recent). Here the labels did not disappear. However, if the copy paste was made on windows 7 and then this file opened on Ubuntu, the labels continued to disappear.

I wish I could contribute little bit more to the effort of improving LO but at the moment I am little busy to learn new not work related stuff. Thanks all for the good work.
Comment 11 Francisco 2014-06-18 09:18:23 UTC
Created attachment 101286 [details]
screenshot of charts copied and pasted from Calc into Impress, and the copied and pasted from Impress itself

I'm attaching two screenshots:

The first shows the problem under Kubuntu 14.04 x86_64, with LibO 4.2.5. I copied 2 charts with axis names, title and legend from Calc into Impress, and then copied and pasted from Impress itself the same charts. The new charts have lost their legends. 

The second screenshot shows what happens after saving, closing and reopening the file: the *text* of the legend in chart copied from Calc and pasted at left is lost.

The chart copied from Calc and pasted at right had 2 series: y1 (blue) and y2 (orange). Strangely, the "blue" series has now lost the text of its legend, and it has been assigned to the "orange" series.
Comment 12 Francisco 2014-06-18 09:19:07 UTC
Created attachment 101287 [details]
Second screenshot for Comment 11
Comment 13 Francisco 2014-06-18 09:25:50 UTC
*** Bug 73984 has been marked as a duplicate of this bug. ***
Comment 14 Kohei Yoshida 2014-06-19 14:27:20 UTC
Possible duplicate of Bug 77506.
Comment 15 Francisco 2014-06-19 14:36:50 UTC
(In reply to comment #14)
> Possible duplicate of Bug 77506.

@Koei: Thank you, and indeed, its a dup.

*** This bug has been marked as a duplicate of bug 77506 ***