Bug 72827 - UI: FIREBIRD "View Refresh Tables" clears the list after tables created by "Tools Sql"
Summary: UI: FIREBIRD "View Refresh Tables" clears the list after tables created by "T...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Julien Nabet
QA Contact:
URL:
Whiteboard: target:4.4.0 target:4.3.0.0.beta2 tar...
Keywords:
: 79493 (view as bug list)
Depends on:
Blocks: Database-Firebird
  Show dependency treegraph
 
Reported: 2013-12-18 10:04 UTC by pierre-yves samyn
Modified: 2014-06-09 08:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-12-18 10:04:48 UTC
Hello

With an embedded Firebird "View Refresh Tables" clears the list after tables created by "Tools Sql"

Steps to reproduce:

1. File> New> Database> Firebird embedded
2. Tools > SQL, Type then Execute:

create table t1
(id integer not null,
field1 varchar(20) not null)

Actual & expected results : success (table created)

3. Close the dialog
4. View> Refresh tables

Expected result: display T1
Actual result: empty list

5. Save, Close, Reload the database
6. View> Database Objects> Tables

T1 ok

7. Tools > SQL, Type then Execute:

create table t2
(id integer not null,
field1 varchar(20) not null)

Actual & expected results : success (table created)

8. Close the dialog
9. View> Refresh tables

Expected result: display T1 & T2
Actual result: empty list

Need to save, close, reload to see the tables.

Platform: windows 7/64 & Version: 4.2.0.0.beta2+
Build ID: d663228bd348c844f38914c9e2167ef01fadf3b3
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-14_23:15:05

Also reproduced on windows 7/64 with  Version: 4.3.0.0.alpha0+
Build ID: f279acd3678d014d9d5dafe41971e0da4dec7b6c
TinderBox: Win-x86@47-TDF, Branch:master, Time: 2013-12-13_23:25:16

Regards
Pierre-Yves
Comment 1 ribotb 2013-12-18 11:01:50 UTC
Hi,

I confirm this bug (Win 7 32bits - LO 4.2.0 beta2).

Bernard Ribot
Comment 2 Alex Thurgood 2013-12-18 21:36:40 UTC
@Andrzej : looks like another one for you ?

Alex
Comment 3 Julien Nabet 2014-06-01 07:17:21 UTC
*** Bug 79493 has been marked as a duplicate of this bug. ***
Comment 4 Julien Nabet 2014-06-01 07:18:53 UTC
I should have checked first that this bugtracker existed :-(

See https://bugs.freedesktop.org/show_bug.cgi?id=79493#c1, I pushed a patch on master (see http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7dd4bbf0a54cc780002052a370f835572035f51)
Comment 5 Julien Nabet 2014-06-03 05:32:20 UTC
Thanks to Lionel, the fixes have been reviewed for the 2 branches 4.3 and 4.2

4.3: http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee38fa4ff5234b6b2342b330b39f5f456ee4a68c&h=libreoffice-4-3

4.2: http://cgit.freedesktop.org/libreoffice/core/commit/?id=f03c2bb813d87bc3c89af78f7f01c587db4c59de&h=libreoffice-4-2

Let's put this to FIXED now.
Comment 6 pierre-yves samyn 2014-06-07 17:32:55 UTC
Hi

WORKSFORME on windows 7/64 & Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Thank you :)

Regards
Pierre-Yves
Comment 7 Lionel Elie Mamane 2014-06-09 04:54:43 UTC
WORKSFORME means that the bug cannot be reproduced by anyone else. Resetting to FIXED.
Comment 8 pierre-yves samyn 2014-06-09 07:55:00 UTC
Hi

(In reply to comment #7)
> WORKSFORME means that the bug cannot be reproduced by anyone else. Resetting
> to FIXED.

Sorry Lionel, I do not understand this comment (my very bad english...)

Julien and I confirm the resolution of the bug. I was told (for other bugs) that the reporter could close it in that case. I made ​​a mistake?

Regards
Pierre-Yves
Comment 9 Lionel Elie Mamane 2014-06-09 08:08:01 UTC
(In reply to comment #8)
> (In reply to comment #7)

>> WORKSFORME means that the bug cannot be reproduced by anyone else. Resetting
>> to FIXED.

> Sorry Lionel, I do not understand this comment (my very bad english...)

See https://bugs.freedesktop.org/page.cgi?id=fields.html#status

Yes, the reporter can can close the bug. However, "WORKSFORME" does not mean that the bug was fixed, but that no developer could reproduce the bug. If the bug was fixed, then the resolution is "FIXED", not "WORKSFORME".

En français:

 Il faut mettre WORKSFORME dans le cas où malgré tous nos efforts,
 nous n'arrivons pas à "reproduire" le bug. C'est à dire que quand
 nous suivons les instructions du bug reporter, le bug n'apparaît pas.
 "Tous nos efforts", c'est quelque chose du genre: on a essayé sur le
 même OS que le reporter, mêmes versions, etc, etc. Ce qui n'est pas
 le cas ici.

 Dans le cas où le bug a été corrigé, la résolution à mettre est "FIXED".
 Ce qui est le cas ici..
Comment 10 pierre-yves samyn 2014-06-09 08:41:32 UTC
It is very clear now. Thank you for your explanation ... and all that you do

Regards
Pierre-Yves