Bug 72938 - LibreOffice unable to correctly handle font styles on Windows
Summary: LibreOffice unable to correctly handle font styles on Windows
Status: RESOLVED DUPLICATE of bug 72944
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-List
  Show dependency treegraph
 
Reported: 2013-12-20 23:01 UTC by dhpublic
Modified: 2018-01-23 22:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dhpublic 2013-12-20 23:01:09 UTC
Greetings,

We're running into problems because of the antiquated font support in LibreOffice Writer 4.1.3.2 for MS Windows. (We're running Windows 7 Ultra 64-bit on our computers.)

The problems are pretty basic: Writer does not recognize the family name and key parameters of a font. As such, Writer cannot support a full range of fonts within a family but is stuck in the stone age of only two weights and two slopes: regular, regular italic, bold and bold italic. We expect more.

For example, a staple sans serif font in our work is Helvetica. We use four weights (light, medium, bold, black) and two widths (normal, condensed), all with both plain and italic (oblique) slopes. This should give us 16 choices under the "Helvetica" family:

Helvetica
---------------------------
· Light
· Light Oblique
· Condensed Light
· Condensed Light Oblique
· Medium
· Medium Oblique
· Condensed Medium
· Condensed Medium Oblique
· Bold
· Bold Oblique
· Condensed Bold
· Condensed Bold Oblique
· Black
· Black Oblique
· Condensed Black
· Condensed Black Oblique

This is frankensteined under Writer into fractured Helvetica, Helvetica Black, Helvetica Black Cond, Helvetica Cond, Helvetica Light and Helvetica Light Cond pseudo families. Why? Because Writer does not appear to read or use the font family name to see that all of these fonts are members of the same Hevetica family. Nor does it gather the correct weight, width and slope parameters from each font.

Or take, for example, VAG Rounded. There are four weights commonly provided: thin, light, bold and black. To select the bold weight under Writer, you have to select the thin weight and turn on the program's "bold" attribute. But to select the black weight you must select the light weight and, again, turn on the program's "bold" attribute. What a muddled mess! How would anyone unfamiliar with this font family know when they were selecting bold verses black unless they were already familiar with the font and could visually distinquish the weights. (Experts can easily see the difference, but this confuses things for the majority of normal users---most probably aren't even aware of the problem.)

Again, what Writer fails to do is look inside the font to see that all of these fonts are members of the same family (VAG Rounded) and have different weights (thin, light, bold, black).

Fixing this will require that Writer obtain the full parameters for each font and correctly display the parameters in its user interface so the user can select the font they truly want. One way to display the parameters and facilitate user selection is to provide two lists. The first list contains the family name. The second list contains the available combinations of weight, width and slope. In my original Helvetica example, you would select "Helvetica" from the first list. Then you would select one of the 16 choices I listed above from the second list. This second list is usually ordered from thinnest weight at the top to heaviest weight at the bottom (rather than an alphabetical order).

If a font family doesn't include a "bold" weight or an "italic" slope, then they would not be provided. For this reason, "bold" and "italic" buttons or checkboxes are obsolete. Some savvy programs still provide them anyway and modify the font to create a faux bold or italic when these versions are not specifically provided within the font family. If you choose to do this and fake a bold weight and/or an italic slope, then it should be clear to the user that this is what is being done.

If you want to see a good example of how fonts are selected, just look at most any Adobe program (InDesign, Illustrator, Photoshop, etc.).

Here are the standard values accepted today for the font weight, width and slope parameters:

Weight (from thinnest to thickest):
-----------------------------------
· Thin
· Extra Light
· Light
· Semi Light
· Regular
· News
· Medium
· Semi Bold
· Bold
· Extra Bold
· Heavy
· Black
· Extra Black

Width (from narrowest to widest):
---------------------------------
· Ultra Condensed
· Extra Condensed
· Condensed
· Semi Condensed
· Normal
· Semi Expanded
· Expanded
· Extra Expanded
· Ultra Expanded

Slope:
---------
· Plain
· Italic
· Oblique

We're excited about the efforts that the Open Source community have made with LibreOffice and we would like to be able to use and recommend it to more clients. But, as it stands, these font problems strike at the heart of what a program like Writer is supposed to do: produce good-looking pages of text. Many of the other excellent features of the program are diminished because of fundamental issues with font support and selection.

Kind regards,

dhpublic
Comment 1 dhpublic 2013-12-21 04:53:30 UTC

*** This bug has been marked as a duplicate of bug 72944 ***
Comment 2 Thomas Linard 2018-01-05 09:59:08 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 3 Thomas Linard 2018-01-23 21:44:04 UTC
*** Bug 72944 has been marked as a duplicate of this bug. ***
Comment 4 Aron Budea 2018-01-23 22:54:42 UTC
Let's keep bug 72944 open instead.

*** This bug has been marked as a duplicate of bug 72944 ***