Bug 73020 - Viewing: LO 4.2.0.1 (RC1) Calc : Fast Scrolling a table with Sliders creates artifacts (win only) SOLVED with LO 4.2.0.3 (RC3)
Summary: Viewing: LO 4.2.0.1 (RC1) Calc : Fast Scrolling a table with Sliders creates ...
Status: RESOLVED DUPLICATE of bug 68961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.2.0.1:OSX confirmed:4.2.0.1...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-25 01:11 UTC by Karl
Modified: 2014-01-26 08:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
part of screenshot (137.81 KB, image/png)
2013-12-26 20:39 UTC, Karl
Details
creenshot 2 / duplicated cells (93.83 KB, image/png)
2013-12-29 10:51 UTC, Karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2013-12-25 01:11:50 UTC
Hi,
scrolling a table with the sliders at right for up/down or bottom for left/right
creates artifacts, especially on FAST MOVEMENT

which resolves (!)/ disapear, if the mouse button (after slider movements) is released

I am not sure, if it relates to "viewing".

LO 4.2.0.1
Win 7 / x64
Graphics-driver AMD Radeon legacy (HD 2400)


kind regards to all LO developers and all others
juergen
Comment 1 retired 2013-12-25 13:40:59 UTC
NoRepro:4.2.0.1:OSX
Comment 2 Karl 2013-12-26 20:39:05 UTC
Created attachment 91201 [details]
part of screenshot

I just took part of a sreen, without table contend.

The artifacts are created by duplikated column / row numbers.

In real cells and their contend ar "dubbled / manyfolted" the same way.

regards
Comment 3 retired 2013-12-29 01:20:50 UTC
Thanks for the screenshot Karl. Guess we'll have to wait for some windows users to confirm this glitch. I cannot reproduce this on OSX.
Comment 4 Karl 2013-12-29 10:51:07 UTC
Created attachment 91275 [details]
creenshot 2 / duplicated cells

sorry, the lower part might be too small

upper is the cells in normal view,
below if thei are crolled by slider fast.

the cells are "duplicated" too.

originally the rightest cell is column "P"
then "duplicated up to coulumn "Y"

regards
karl

PS: the duplication "solves" if mouse button on slider is released
Comment 5 Jacques Guilleron 2013-12-29 16:27:20 UTC
Hi Karl,

I don't reproduce using LO 4.1.3.2 & Windows 7 Home Premium.
Can you verify In Tools > Options > LibreOffice > View in Graphics Output
that Use hardware acceleration is checked?

Thank you,

Jacques
Comment 6 Chris 2013-12-29 19:34:06 UTC
Hi
I have a similar problem but so far no one can reproduce it.
Look at the bug 72401: https://bugs.freedesktop.org/show_bug.cgi?id=72401
Comment 7 Karl 2013-12-31 07:13:57 UTC
Hardware Accell IS CHECKED,
but unchecking it doesnt change anything.

The lifetime of the artifacts is "until mouse button is released"

regards
karl
Comment 8 Thomas van der Meulen 2014-01-03 12:51:30 UTC
I can reproduce this bug running 4.2.0.1 on Windows 7 
I can't reproduce this bug on mac 

here is a video to show that happens: http://youtu.be/vf00Nxuq41s 
(sorry for the bad quality)
Comment 9 Karl 2014-01-17 20:37:57 UTC
The same on LO 4.2.0.2 (RC2)

kind regards
karl
Comment 10 Karl 2014-01-26 01:32:53 UTC
MAY BE SOLVED !!!


I installed LO 4.2.0.3 today 
and "srolled fast" through my tables.

I might say: I can't see the effects anymore.

regards

karl
Comment 11 Thomas van der Meulen 2014-01-26 08:48:51 UTC
Set to resolved works for me as the used said but found a dubplicate in the RC3 release note. so setting it as a duplicate

*** This bug has been marked as a duplicate of bug 68961 ***