Bug Hunting Session
Bug 73273 - presenter console: slide transition jumpy (on dual screen display)
Summary: presenter console: slide transition jumpy (on dual screen display)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Multimonitor Presenter-Console
  Show dependency treegraph
 
Reported: 2014-01-04 06:29 UTC by Stephan Weinberger
Modified: 2019-03-29 18:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Render problem of presenter console (128.17 KB, image/jpeg)
2015-06-23 14:48 UTC, Carlos Rodriguez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Weinberger 2014-01-04 06:29:51 UTC
Problem description: 

I recently upgraded my old Debian laptop from lenny with OO (3.2.1) to wheezy with LO (3.5.4). I have used the presenter console with OO-Impress in a two-screen setup before and it worked like a charm.

In LO however the presenter console shows some weird behaviour on animated slide transitions: While loading the next slide preview the transition pauses for about half a second - which looks really crappy on animated transitions (especially because I use it for backdrops on stage - that's one of the reasons why i use Debian stable btw.).

A workaround is to switch to the slides preview dialog: as soon as the preview area is not drawn (because it's hidden behind the slide overview) animations run smoothly again. This however is cumbersome, because in
the overview focus does not follow the current slide, so using the presenter console becomes somewhat pointless... running the presentation without the presenter console extension works flawlessly too, but in a stage environment the preview definitely is nice to have.


Steps to reproduce:

1. install presenter console extension
2. create a presentation of some fullscreen images (i use image files in our beamer's native resolution of 1024x768 - so these are rather small files)
3. select some animated slide transitions
4. run the presentation

Current behavior:

on every slide change the transition animation starts to run, but after a fraction of a second is interrupted while the next slide's preview is drawn in the presenter console.

Expected behavior:

a smooth slide transition

It wouldn't even matter if the transition is delayed until the preview is drawn (it's only some 1/10s of a second), but it's the "hickup" kind of interruption that looks ugly.
Comment 1 Julien Nabet 2014-01-04 09:06:26 UTC
3.5.4 is very old, last LO version is 4.1.4. You must know that there won't be any fix (at least on TDF release) in 3.5.X, 3.6.X and 4.0.X 
Could you give 4.1.4 LO version a try by using testing repo?
Comment 2 Stephan Weinberger 2014-01-04 15:32:44 UTC
Updated LO to 4.1.4.2 from debian wheezy-backports - same behaviour. (Is the presenter console now built-in? it doesn't show up in the Extensions Manager anymore. How can i make sure I'm not somehow using the previsouly installed extension?)


Another weird detail: When I open the slides overview dialog in the presenter console and scroll around there (resulting in slide previews being loaded) this does *not* interfere with the animations (although in this dialog the programm has to load not only one but several slide previews at once; so i guess i can rule out general performance issues with my laptop). It really seems to be the one preview in the presenter console's main screen that causes the hickup.

Wild guess: does the slides overview dialog run in a seperate thread but the main screen does not?
Comment 3 Julien Nabet 2014-01-04 15:49:12 UTC
Version must contain the earliest version when the bug appeared, see
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Version

Anyway, thank you for your feedback, i put it back to unconfirmed.

About your questions,
"Is the presenter console now built-in?"
It seems so since 4.0 version

"How can i make sure I'm not somehow using the previsouly installed extension?"
Remove the package libreoffice-presenter-console if present

Here's the description of the package:
Package: libreoffice-presenter-console
Source: libreoffice
Version: 1:4.1.4-2
Installed-Size: 144
Maintainer: Debian LibreOffice Maintainers <debian-openoffice@lists.debian.org>
Architecture: all
Depends: libreoffice-impress (>= 1:4.0.0)
Description-en: transitional package for the LibreOffice presenter console
 This package used to contain the LibreOffice presenter console. It has been
 integrated with LibreOffice Impress 4.0. You can safely remove this package.

"does the slides overview dialog run in a seperate thread but the main screen does not?"
I don't know

Put it back to UNCONFIRMED
Comment 4 Jean-Baptiste Faure 2014-01-19 11:52:26 UTC
@reporter: please, could you attach your test file?

Set status to needinfo, please set back to unconfirmed once the required infos provided. Thank you very much.

Best regards. JBF
Comment 5 Stephan Weinberger 2014-02-09 23:47:14 UTC
http://xover.mud.at/~invisible/download/pt_test.odp is a shortened test file (~9 MB) - the original contains more slides, but the issue does not depend on file size (even running from a ramdisk makes no difference).

There are two automatic sequences (starting from slide 6 and slide 16) with animated slide transitions, where the issue is best visible (although it also happens at the manual crossfades).
It is also well visible at the change from slide 1 to slide 2 (circular animation: the circle starts zooming up, then stops at about 1/10th of the way, and continues to grow bigger after a short delay).

Again: the issue does *not* occur in single screen mode, nor does it occur when the presenter console is in slide list view (hiding the two-slides default screen). It's really only in the default view of presenter console on a dual screen display.
Comment 6 Stephan Weinberger 2014-02-10 00:13:18 UTC
Laptop is a Lenovo X220
CPU: i5-2520M with integrated graphics
HDD: Intel SSDSA2M160G2LE
Display: primary = Laptop builtin, secondary = 1024x768 VGA
OS: Debian Wheezy, Gnome desktop

The issue occurs regardless of power saving settings or the like (but since it works under the circumstances explained above this cannot be the cause anyway).
Comment 7 Jean-Baptiste Faure 2014-03-08 21:02:56 UTC
Not reproducible for me with (dev.) version 4.2.3.0.0+ under Ubuntu 13.10 x86-64.

Best regards. JBF
Comment 8 Owen Genat (retired) 2014-07-28 12:29:04 UTC
Summary edited for clarity i.e., to indicate this is a dual screen specific issue. FWIW I do get a small hourglass flickering at bottom left during the slideshow (most transitions) on a single screen 2009 iMac mini 2.53Ghz with Intel integrated graphics, running Debian 7 x86_64 + v4.3.0.3.
Comment 9 tommy27 2015-06-21 19:03:41 UTC
@Stephan Weinberger
please give an update of the bug current status with the latest LibO 4.4.3.2 release.
Comment 10 Carlos Rodriguez 2015-06-23 14:48:31 UTC
Created attachment 116768 [details]
Render problem of presenter console

What I've got on Debian 8 (jessie) on KDE with:

Versión: 4.3.7.2
Id. de compilación: 8a35821d8636a03b8bf4e15b48f59794652c68ba

and

Version: 4.4.5.0.0+
Build ID: be0f5f5b66c55081849250ffad9f600cd61a00a1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-06-20_22:26:11
Locale: es_ES.UTF-8

Transitions (Fade Smoothly) from slides numbered 2-3-4-5, 10-11-12, 13-14-15 ... start with a little "flash" and then goes smoothly.

I don't get the problem of interruption while the next slide's preview is drawn.

Things are getting worse on:

Version: 5.1.0.0.alpha1+
Build ID: a64999511ae654131d997eec9a3d78478cfc1c75
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-22_05:01:17
Locale: es-ES (es_ES.UTF-8)

Where not only I've got the "flash" issue but also the presenter console has a render problem and is not showing correctly. I don't have this render problem on previous versions.
Comment 11 Carlos Rodriguez 2015-06-23 14:58:55 UTC
(In reply to Carlos Rodriguez from comment #10)

> Things are getting worse on:
> 
> Version: 5.1.0.0.alpha1+
> Build ID: a64999511ae654131d997eec9a3d78478cfc1c75
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-06-22_05:01:17
> Locale: es-ES (es_ES.UTF-8)
> 
> Where not only I've got the "flash" issue but also the presenter console has
> a render problem and is not showing correctly. I don't have this render
> problem on previous versions.

This part seems to be noticed on bug 91574

I'll report there about the render issue.
Comment 12 tommy27 2015-08-17 17:01:59 UTC
@Carlos
would you please give an update of the bug status with current LibO 5.0.0.5 and 5.1.0.0 alpha?
Comment 13 Carlos Rodriguez 2015-08-18 18:07:18 UTC
Still getting the little "flash" issue on the same transitions: 2-3-4-5, 10-11-12-13-14-15 and 25-26-27-28. All associated with the "Fade Smoothly" Slide Transition effect. Also occurs with "Fade Through Black".

This occurs on Debian 8 (jessie) with:

Version: 5.1.0.0.alpha1+
Build ID: 5d6ef74eea5d73b8cd17f313ad87138d56dc76ce
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-18_01:28:44
Locale: es-ES (es_ES.UTF-8)

Version: 5.0.2.0.0+
Build ID: b6bd0111073d0a94b40b20cce85e10cdcb791d3e
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-08-18_09:17:32
Locale: es-ES (es_ES.UTF-8)

Version: 4.4.6.0.0+
Build ID: dfac25d2300b56ee4594346a4b5ce8b083a5c782
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-08-18_09:56:35
Locale: es_ES.UTF-8

Versión: 5.0.0.5
Id. de compilación: 437e4abdf9e72fd0a6e6f8697a0e659bc77f9b10
Configuración regional: es-ES (es_ES.UTF-8)

Versión: 4.4.5.2
Id. de compilación: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Configuración regional: es_ES.UTF-8
Comment 14 tommy27 2015-09-19 05:58:19 UTC
status NEW as per comment 13
Comment 15 QA Administrators 2016-09-20 10:32:50 UTC Comment hidden (obsolete)
Comment 16 Stephan Weinberger 2016-09-20 21:50:43 UTC
I just downloaded the latest .deb

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620

with this version it is even worse. Not only is the short pause in the
animation still present, there is now an additional white flash over the
whole screen at the beginning *and* end of the animation (if there is an animation in the slide transition; slides without a special transition still work fine, as they always did).

Running on a Lenovo Thinkpad X220, Debian wheezy with backports from
official debian and debian backports repo. Secondary display is
connected to the VGA output.

regards,
  Stephan
Comment 17 jebsolutions 2016-10-21 19:56:05 UTC
Still present in 5.3.0 alpha 1 on Windows 10 64bit and Lubuntu 16.04 64bit.
Comment 18 Bart 2017-02-18 16:38:03 UTC
Confirmation of the bug:
  Version: 5.3.0.3
  Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
  CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
  VCL: gtk3; Layout Engine: new;
  Locale: nl-BE (en_GB.UTF-8); Calc: group
  OS: Linux Mint 18, XFCE4

Dual screen setup, presenter console enabled

Easy to reproduce:
- create a slide-show with some slides and some shapes on
- add some slide transition to all slides
- start the slide show
- in presenter console, choose 'Slides' (Slide Overview)
- transitions are working fine
- in presenter console, choose 'Notes' (Notes View)
- transitions are not working
- in presenter console, unclick 'Notes' (Current Slide + Next Slide View)
- transitions are not working

Bart.
Comment 19 Bart 2017-02-18 17:33:26 UTC
Test in earlier version gives some different result:
  Version: 5.1.4.2
  Build ID: 1:5.1.4-0ubuntu1
  CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
  Locale: nl-BE (en_US.UTF-8)
  OS: Ubuntu Studio 16.04.1 LTS, XFCE4

Dual screen setup, presenter console enabled

In presenter console, any view, transitions are working, but:
some 'flashes' occur.

Bart.
Comment 20 jebsolutions 2017-06-08 14:51:33 UTC
In comment number 5 Stephan Weinberger is using the integrated intel drivers from the i5-2520.

My laptop has a similar Intel integrated gpu (Intel i7-2620M).  This has the same problems.  

However, when I tested it with the Nvidia graphics card in my laptop everything worked!  

https://bugs.documentfoundation.org/show_bug.cgi?id=95479#c8

Recent changes to LibreOffice broke a lot of graphics related transitions.

I am pretty sure that most of the remaining "flickering" "showing a previous slide" and "slide transition" bug reports -- there are at least 10 different ones! -- are all symptoms of this same basic problem.  

This is a regression.  Previous older versions work fine.  And the latest OpenOffice 4.2.1 also work fine on the same hardware.

These symptoms can ALL be reliably and consistently shown if you use VirtualBox and install the VirtualBox Guest drivers.  So if you are a dev where it "works fine for me" please please please try it under VirtualBox.  You will right away see the problem.
Comment 21 QA Administrators 2018-06-09 02:40:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug