Bug 91574 - SLIDESHOW: presenter console background and buttons not shown during slideshow
Summary: SLIDESHOW: presenter console background and buttons not shown during slideshow
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other Windows (All)
: highest blocker
Assignee: Michael Meeks
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords: haveBacktrace, regression
: 92780 93369 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-24 12:05 UTC by tommy27
Modified: 2016-10-25 19:21 UTC (History)
17 users (show)

See Also:
Crash report or crash signature:


Attachments
an error log what was taken by WinDbg (15.41 KB, text/plain)
2015-06-03 14:38 UTC, Masui Masanori
Details
Render problem of presenter console (128.17 KB, image/jpeg)
2015-06-23 15:13 UTC, Carlos Rodriguez
Details
bt with debug symbols (5.38 KB, text/plain)
2015-07-05 09:46 UTC, Julien Nabet
Details
Presenter console ghost window (152.23 KB, image/jpeg)
2015-07-05 14:17 UTC, Carlos Rodriguez
Details
my random code-reading notes on some of the oddness here. (61.24 KB, text/plain)
2015-07-21 21:15 UTC, Michael Meeks
Details
Missing console under Windows XP x86 running version 5.0.0.4 (400.76 KB, image/jpeg)
2015-07-27 14:47 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2015-05-24 12:05:48 UTC
tested under Win8 using LibO 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: en-US (it_IT)

- load an .odp file in Impress
- click Slide Show/Start from first slide

presenter console is not shown, but you can still advance trough slides using arrow keys or mouse clicks
if you click Esc LibO crashes

serious regression, works fine in 4.4.x

p.s. I set version to 5.0 beta1 since 5.1 master is not yet available in the version list
Comment 1 Julien Nabet 2015-05-24 17:04:57 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Windows-only bug?
Comment 2 tommy27 2015-05-29 21:32:22 UTC
still present with LibO 5.1.0.0.alpha1+
Build ID: 6c1cabe677f5eb24b465dd6e316c8c66df64bb29
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-29_06:48:08
Locale: en-US (it_IT)
Comment 3 Masui Masanori 2015-05-31 06:53:35 UTC
I reproduced it. Tested under Windows8.1(X64) and MacOS X(10.10.3) with LibO 5.0.0.0.beta1(BuildID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3).

It was occurred by the steps below.

Steps to Reproduce:
1. Start LibO-Dev
2. Make a New Impress Presentation
3. Select Slideshow > Start from first Slide to Start Slideshow

And the times of crushing are as follows

* Windows: After playing slideshow, when I attempted clicking to finish slideshow, it crushed.
* Mac: It crushed on Step3 of Steps to Reproduce.

Although the version of LibO and steps, can you test them?
Comment 4 Thorsten Behrens (CIB) 2015-05-31 19:58:35 UTC
Yeah, presenter console seems seriously busted on 5.0 - on linux, libreoffice-5-0 build from yesterday, and just getting an empty frame for the presenter view. No immediate crash though.
Comment 5 Joel Madero 2015-05-31 22:18:46 UTC
Would be nice for someone seeing this crash to get us a decent backtrace: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 6 tommy27 2015-06-02 06:36:37 UTC
(In reply to Masui Masanori from comment #3)
> I reproduced it. Tested under Windows8.1(X64) and MacOS X(10.10.3) with LibO
> 5.0.0.0.beta1(BuildID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3).
> 

I revert version to 5.0 beta1 according to this comment

actually when the slideshow is over, I don't see an immediate crash as in the original report, however when I click Esc or Exit slideshow the LibO interface gets frozen... I cannot click on anything and I have to Ctrl+Alt+Canc to kill the application

tested on Win8 using 5.1.0.0.alpha1+
Build ID: 6c1cabe677f5eb24b465dd6e316c8c66df64bb29
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-29_06:48:08
Comment 7 Masui Masanori 2015-06-03 14:38:46 UTC
Created attachment 116259 [details]
an error log what was taken by WinDbg

(In reply to Joel Madero from comment #5)
> Would be nice for someone seeing this crash to get us a decent backtrace:
> https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

I got an error log. Please let me know if there are any problems.
Comment 8 Thorsten Behrens (CIB) 2015-06-03 15:15:44 UTC
(In reply to Masui Masanori from comment #7)
> Created attachment 116259 [details]
> an error log what was taken by WinDbg
> 
That one looks like bug 91426 - but it then doesn't quite explain the Linux
issues. Let's wait for beta2, unless someone gets a linux backtrace.
Comment 9 Masui Masanori 2015-06-04 14:07:28 UTC
(In reply to Thorsten Behrens from comment #8)
> (In reply to Masui Masanori from comment #7)
> > Created attachment 116259 [details]
> > an error log what was taken by WinDbg
> > 
> That one looks like bug 91426 - but it then doesn't quite explain the Linux
> issues. Let's wait for beta2, unless someone gets a linux backtrace.

Thank you for testing. OK, I will test again after getting beta2:)
Comment 10 Adolfo Jayme 2015-06-09 01:41:48 UTC
MABs are obsolete =)
Comment 11 tommy27 2015-06-14 12:40:22 UTC
retested under Win8.1 x64 using LibO 5.1.0.0.alpha1+
Build ID: bb9dad2ef23829b2500c9f99154bca6a8ba7d49a
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-11_23:59:18
Locale: en-US (it_IT)

I still see two issues once you start the slideshow

1- presenter console not shown either you are on a single monitor or a dual monitor setup

2- once you finish the presentation and click exit presentation, if you are on a single monitor setup there's no issue. if you are on a dual setup monitor the focus stays on the secondary monitor so all the LibO GUI which is on the primary monitor gets frozen and you can't click anything so you can't exit the application... the only way to exit is to click on the taskbar icon in the secondary monitor (on Win8 you have taskbars on both monitors) and exit the application

I don't see any real crash now (as I noted in comment 0) so I'm changing summary notes from:
SLIDESHOW: presenter console not shown and crash on exit 

to:
SLIDESHOW: presenter console not shown and focus remains on the secondary monitor

can anyone retest according to my latest findings with 5.0 beta3 or latest 5.1 dailies?
Comment 12 tommy27 2015-06-17 08:36:27 UTC
retested under Win7 x64 using LibO 5.1.0.0.alpha1+ updated today

the issue remains the same... but as said in previous comment, since Windows 7 (and earlier releases) has no taskbar in the secondary monitor (unlike Win8.1) you cannot use that workaround.

so the issue is even worse on those Windows system where you have to Ctrl+Alt+Canc and kill LibO in order to retake possess of your computer.
Comment 13 Masui Masanori 2015-06-18 15:31:33 UTC
I'm writing about comment #3 .

I retested it with LibO 5.0.0.0.beta3 and confirmed it hadn't occured on Windows8.1(X64).

But on MacOS X(10.10.3), it was reproduced again..

> * Mac: It crushed on Step3 of Steps to Reproduce.
Comment 14 tommy27 2015-06-18 19:17:47 UTC
@Masui
are you on a dual monitor setup?
Comment 15 Masui Masanori 2015-06-20 09:18:20 UTC
(In reply to tommy27 from comment #14)
> @Masui
> are you on a dual monitor setup?

@tommy27
no. I'm using only one monitor.

[Environment]
・PC: Mac mini 2012
・Monitor: PHL 224E5
Comment 16 Carlos Rodriguez 2015-06-23 15:13:17 UTC
Created attachment 116769 [details]
Render problem of presenter console

Got this issue on Debian 8 (jessie) with KDE:

Version: 5.1.0.0.alpha1+
Build ID: a64999511ae654131d997eec9a3d78478cfc1c75
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-22_05:01:17
Locale: es-ES (es_ES.UTF-8)

and

Version: 5.0.0.1
Build ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Locale: es-ES (es_ES.UTF-8)

After pressing F5 to start presentation, I can go through it with the cursor or key press but the presenter console renders badly.

Works fine on:

Version: 4.4.5.0.0+
Build ID: be0f5f5b66c55081849250ffad9f600cd61a00a1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-06-20_22:26:11
Locale: es_ES.UTF-8

Versión: 4.4.3.2
Id. de compilación: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Configuración regional: es_ES

Versión: 4.3.7.2
Id. de compilación: 8a35821d8636a03b8bf4e15b48f59794652c68ba
Comment 17 tommy27 2015-06-23 19:12:17 UTC
probably we are dealing with different issues with presenter console in different O/S...

I reported under Windows that the console is not showed at all and the focus remains on secondary monitor when exiting the slideshow

Masui reported a crash under MacOS

Carlos reported a badly renderd presenter console under Linux
Comment 18 tommy27 2015-06-24 04:22:07 UTC
@Carlos
are you working on a dual monitor setup or with a single monitor?
Comment 19 Carlos Rodriguez 2015-06-24 07:58:25 UTC
(In reply to tommy27 from comment #18)
> @Carlos
> are you working on a dual monitor setup or with a single monitor?

Dual monitor with a not so new Intel(R) HD Graphics 4000
Comment 20 Pedro 2015-06-29 11:41:07 UTC
This bug also affects Windows XP Pro x86. Tested with 5.0.0.2 on a dual monitor system. Exiting presentation with Esc leaves a "ghost" task in the taskbar (which is closed when the presentation is closed on the main window). There is no crash.

This is a major regression.
Comment 21 tommy27 2015-07-02 04:20:21 UTC
> (In reply to tommy27 from comment #18)
> > @Carlos
> > are you working on a dual monitor setup or with a single monitor?
> 
> Dual monitor with a not so new Intel(R) HD Graphics 4000

thanks for feedback. what about exiting the presentation? do you have the same secondary monitor taskbar focus issue I described under Windows? see comment 11
Comment 22 Cor Nouws 2015-07-02 08:34:27 UTC
tested in 5002 on Ubuntu 32 bits
No presenter console.
No crash.
After the presentation, when I use Ctrl+` , to toggle between active LibreOffice windows, I do see an *empty* window, just the *frame* and for the *transparent*.
Comment 23 Cor Nouws 2015-07-02 08:35:32 UTC
(In reply to Cor Nouws from comment #22)

> I do see an *empty* window, just the *frame* and for the *transparent*.

I do see an *empty* window, just the *frame* and for the rest *transparent*.
Comment 24 tommy27 2015-07-02 08:42:40 UTC
thanks Cor, are you able to exit the slideshow without using keyboard shortcuts?
there's should be an "exit presentation" or something like that at the end of it.
Comment 25 Cor Nouws 2015-07-02 10:44:37 UTC
(In reply to tommy27 from comment #24)
> thanks Cor, are you able to exit the slideshow without using keyboard
> shortcuts?
> there's should be an "exit presentation" or something like that at the end
> of it.

Yes, if I click it exits presentation mode
Comment 26 Cor Nouws 2015-07-02 10:45:58 UTC
(In reply to Cor Nouws from comment #23)

> I do see an *empty* window, just the *frame* and for the rest *transparent*.

And after closing the presentation document, the empty window remains
(Sorry, can't take a screen shot of the  ghost window :) )
Comment 27 tommy27 2015-07-02 10:51:57 UTC
ok, but what about the "focus" of the LibO application? does it remains on the secondary monitor like in Windows (which makes impossible to select anything in the primary monitor... not only LibO, but also taskbar etc. etc.) or stays on the primary monitor allowing to work with LibO and other apps?
Comment 28 Cor Nouws 2015-07-02 11:09:34 UTC
(In reply to tommy27 from comment #27)
> ok, but what about the "focus" of the LibO application? does it remains on
> the secondary monitor like in Windows (which makes impossible to select
> anything in the primary monitor... not only LibO, but also taskbar etc.
> etc.) or stays on the primary monitor allowing to work with LibO and other
> apps?

Something weird with focus ongoing too here.

But I expect (maybe too optimistic) that one bug in the software may have various effects, depending on OS, set up etc etc..
Comment 29 Jean-Baptiste Faure 2015-07-03 04:41:28 UTC
Not working as expected confirmed for me under Linux Ubuntu 15.04 with a dual screen.
Just tested with 
Version: 5.0.0.2.0+
Build ID: 50b93a183bcdd9981a740a92cd5cc6be77be1973
Ubuntu_15.04_x86-64
Locale : fr-FR (fr_FR.UTF-8)

built at home.
The bad behaviour is different depending on whether you use VCL plugin GTK3 (default) or GTK2.
GTK3: the screen of the speaker is empty
GTK2: the screen of the speaker is a duplicate of the edit window.
For both closing the slide-show does not go back to the edit mode.

I did not experienced a crash. Same behaviour for the master.

Best regards. JBF
Comment 30 tommy27 2015-07-03 04:55:37 UTC
thanks for testing.

the crash was probably some other bug present at the time of the initial report but has not been reproduced subsequently either on Windows and Linux (a Mac user is still reporting a crash) while the issues of presenter console visualization and slideshow exit are still present
Comment 31 Arnaud LE CAM 2015-07-03 07:53:47 UTC
It doesn't crash for me (dual screen), presenter console is shown on the primary screen, but I'm loosing focus (and mouse responding) on primary screen.
A way to retrieve focus on primary screen, is to open a terminal on secondary screen, and manually kill soffice.bin

Version: 5.1.0.0.alpha1+
Build ID: a28231b72b5a87dddffad82a34deac4e5bb76ed1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-02_06:22:36
Locale: fr-FR (fr_FR.UTF-8)
GUI Toolkit tested : gen, gtk, gtk2, gtk3, kde, kde4
Distrib : Xubuntu 14.10
Ubuntu's Kernel package : 3.16.0-41-generic (x86_64)

May this specific issue should be tracked by a new bug, "on graphics stack" component ?
Comment 32 Commit Notification 2015-07-03 19:49:03 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f96b38ddda1759023e6021511d6d660abf98a54e

tdf#91574 fix presenter console not displayed

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2015-07-03 19:49:10 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3228c66b0a10124d60f4671ab70fa42f97e7529&h=libreoffice-5-0

tdf#91574 fix presenter console not displayed

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Jean-Baptiste Faure 2015-07-04 09:59:29 UTC
(In reply to Commit Notification from comment #33)
> Christian Lohmaier committed a patch related to this issue.
> It has been pushed to "libreoffice-5-0":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=e3228c66b0a10124d60f4671ab70fa42f97e7529&h=libreoffice-5-0
> 
> tdf#91574 fix presenter console not displayed

With this commit LO quit without error message just after the slide-show started. I do not see the speaker console.

Tested with Version: 5.0.0.2.0+
Build ID: d78b81b379333bd471c670bc9f49304f1d6f030a
Ubuntu_15.04_x86-64
Locale : fr-FR (fr_FR.UTF-8)

Best regards. JBF
Comment 35 tommy27 2015-07-04 17:28:45 UTC
retested under Win8.1 x64 with LibO  5.1.0.0.alpha1+ (x64)
Build ID: a551d82bfc3ddae2354d39c90e31ad6eefcd1617
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-04_07:51:25
Locale: en-US (it_IT)

things now are even worse...
the presenter console is still not shown and LibO crashes as soon as I start the slideshow and move to the second slide.

I'll retest with a 32 bit build from a different tinderbox when it will be available.
Comment 36 tommy27 2015-07-05 06:22:26 UTC
it seems that the Windows 32bit tinderbox are not working and there's no recent daily build available

so I retested the latest 64bit build 5.1.0.0.alpha1+ (x64)
Build ID: 67afab2a7cd5596d321bb85e6e2624df19c2296b
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-04_22:51:13
Locale: en-US (it_IT)

the issue still persist. still no presenter console and crash after moving slideshow from 1st to 2nd slide.

please, Linux and Mac users, test and tell if you see the same problem.

I also think we should split the current report in different sub-issues... 
I mean:

#1- presenter console not shown
#2- crash after advancing trough slideshow
#3- loss of focus in dual monitor after exiting the slideshow

issue #1 has always been constant even after Christian committ which was supposed to address this side of the bug, while #2 and #3 varied among different daily builds so I suspect it's not a single bug causing all the trouble
Comment 37 Julien Nabet 2015-07-05 09:46:08 UTC
Created attachment 117054 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I had a crash.

See bt attached
Comment 38 Julien Nabet 2015-07-05 09:49:54 UTC
Michael: Seeing this http://opengrok.libreoffice.org/search?q=maVDev&project=core&defs=&refs=&path=&hist=
I wonder if we should change maVDev to declare it like this ScopedVclPtr<VirtualDevice> or if we should just use VclPtr<VirtualDevice>::Create (but in this case with which parameter?)
Comment 39 Julien Nabet 2015-07-05 09:57:36 UTC
I submitted a patch here:
https://gerrit.libreoffice.org/#/c/16770/

I chose the simplest way (but perhaps not the right way)
(diff --git a/canvas/source/vcl/spritecanvashelper.cxx b/canvas/source/vcl/spritecanvashelper.cxx
index 095dae6..e6fa3e7f7 100644
--- a/canvas/source/vcl/spritecanvashelper.cxx
+++ b/canvas/source/vcl/spritecanvashelper.cxx
@@ -177,7 +177,7 @@ namespace vclcanvas
     SpriteCanvasHelper::SpriteCanvasHelper() :
         mpRedrawManager( NULL ),
         mpOwningSpriteCanvas( NULL ),
-        maVDev(),
+        maVDev(VclPtr<VirtualDevice>::Create()),
         maLastUpdate(),
         mbShowFrameInfo( false ),
         mbShowSpriteBounds( false ),
)
at least, I don't reproduce the crash with this.
Comment 40 Carlos Rodriguez 2015-07-05 14:17:40 UTC
Created attachment 117064 [details]
Presenter console ghost window

On Debian 8 (jessie) with KDE and:

Version: 5.1.0.0.alpha1+
Build ID: 8b788891796ff0571f779cdbe8ce809c35c42754
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-03_01:07:30
Locale: es-ES (es_ES.UTF-8)

Version: 5.0.0.2.0+
Build ID: 64b4ed9de3852494416cdcb8c25d2e24fc4d0253
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-07-03_09:08:51
Locale: es-ES (es_ES.UTF-8)

#1- presenter console not shown but window task exists (see attachment). I can click where the controls should be and the presentation follows BUT "forward button" seems to go "backwards" and reciprocally.
#2- NOT crashing after advancing trough slideshow and I can get the focus on other windows normally below the presenter console window.
#3- After exiting presentation I loss of focus in the display where the presenter console was. I can do Alt+Tab to go through the windows tasks and focus one of the LibO windows and close the ODP file or create a new one but I'm unable to get the focus on anything below this window. The only way to do it is closing it that kills the "presenter console" ghost window.
Comment 41 Carlos Rodriguez 2015-07-05 14:24:42 UTC
Upgrading to:

Version: 5.1.0.0.alpha1+
Build ID: 3c45bfb0cabf206f6217f1de9eb5cfa12b78e46f
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-04_01:25:39
Locale: es-ES (es_ES.UTF-8)

I get a crash as soon as I press F5 to start the presentation :-(
Comment 42 Christian Lohmaier 2015-07-06 12:50:06 UTC
Yes - getting the crash currently is expected (see the comment in https://gerrit.libreoffice.org/#/c/16724/ )

the crash and not showing the presenter console are different buts - although not showing the console did hide the crash. Julien's fix addresses the crasher.
Comment 43 tommy27 2015-07-06 12:55:31 UTC
@cloph
so basically once Julien crash fix will be merged we should be finally able to see the presenter console?
Comment 44 Arnaud LE CAM 2015-07-06 13:35:30 UTC
as I said in comment #31, I agree with tommy27 on his comment #36.

I'm only concerned by issue #3, and i think it would be easy to track if we split this bug into 3 new ones :
#1- presenter console not shown
#2- crash after advancing trough slideshow
#3- loss of focus in dual monitor after exiting the slideshow

Is there a simple way on buggzila to create 3 new bugs, linkink comments and attachment of this one ?
Comment 45 tommy27 2015-07-06 14:27:48 UTC
if nobody has objections, I'll do the split tonight then I'll tell everybody the link to the the new bugs.
Comment 46 Commit Notification 2015-07-06 19:53:11 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36a77b748a0b1d35ce72b2e14d1daa158d5f7c4b

tdf#91574: SLIDESHOW: crash when second monitor connected

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2015-07-06 19:54:45 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=135c3c567aeda1db3d81858cdad401b1df1d2504&h=libreoffice-5-0

tdf#91574: SLIDESHOW: crash when second monitor connected

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 48 tommy27 2015-07-07 05:29:40 UTC
retested under Win8.1 x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 0251e61640b94094918406b33ee7b05564409feb
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-06_23:45:07
Locale: en-US (it_IT)

this time no crash after launching slideshow 

presenter console is still not shown correctly (you got a white screen with current slide miniature) during slideshow 

when you exit slideshow (Esc key) the slideshow windows closes and the presenter console reappears 

basically the presenter console GUI is not show at all apart from the current slide miniature... when you exit the slideshow the grey background of the presenter console along with its buttons appears around the slide miniature

focus still remains in the secondary monitor so in Windows 8.1 you have to use the secondary monitor to regain possess of the primary
Comment 49 Michael Meeks 2015-07-07 21:30:17 UTC
Thanks for the testing; just pushed another fix - would love input on whether this makes things good finally. For me the fix cleanups a load of lingering / leaking slide-show windows and makes slideshow work nicely (at least for me on Linux). I saw quite a curious paint related crasher here too - somehow with toolkit queuing idle emitted paint events on VCLXWindows but not managed to reproduce - hopefully also gone.

Thanks !
Comment 50 Commit Notification 2015-07-07 21:32:15 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d48353f336890211920fe9b53a538f7b3526c4e1

tdf#91574 - fix slideshow presenter console lifecycle.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 51 Commit Notification 2015-07-08 13:39:18 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7079f691a31caffff380610b3c77a2faa0bcf0b3&h=libreoffice-5-0

tdf#91574 - fix slideshow presenter console lifecycle.

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 52 tommy27 2015-07-08 14:38:26 UTC
retested under Win7x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 449d272daf5e99f039cdfdd25f020bd798fb9e1d
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-08_08:13:06
Locale: it-IT (it_IT)


things are better now not 100% fixed...

first the good news...
there's no more crash either at start or end of slideshow
the second monitor issue is gone

the abd news are that the presenter console is still shown incorrectly...
actually you see just the current slide miniature surrounded by a blank white background in the monitor which is supposed to show the presenter console

the presenter console grey background and buttons only show up when you reach the last slide.

so I'm changing again the summary notes to better reflect the current issue status
Comment 53 Jean-Baptiste Faure 2015-07-09 04:20:35 UTC
Retested with Version: 5.0.0.2.0+
Build ID: 5de8f1559afafe4a5430142c305549223d467606
Ubuntu_15.04_x86-64
Locale : fr-FR (fr_FR.UTF-8)
containing the commit 

tdf#91574 - fix slideshow presenter console lifecycle.
https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=7079f691a31caffff380610b3c77a2faa0bcf0b3

Now Presenter Screen seems to work as expected. Thank you very much.

Best regards. JBF
Comment 54 tommy27 2015-07-09 05:34:00 UTC
works in Linux as said in previous comment but still broken under Windows.

retested again with 5.1.0.0.alpha1+
Build ID: d3b6f3790953bdfeaeebcd3ba9ec370d94ca4ebf
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-09_00:11:55
Locale: en-US (it_IT

same findings as in comment 52

please Mac users give update of the bug current status in your platform
Comment 55 tommy27 2015-07-09 12:38:03 UTC
a Mac user in the QA mailing list said that presenter console works fine under OS X Yosemite (10.10.4) with multi-window

so it seems the residual issues affect Windows only...
Comment 56 Carlos Rodriguez 2015-07-09 14:44:00 UTC
Confirmed fixed on Debian 8 (jessie):

Version: 5.1.0.0.alpha1+
Build ID: 85ce6a2446deb0f4c01604b6188f969603de9b16
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-09_02:29:43
Locale: es-ES (es_ES.UTF-8)

and 

Version: 5.0.0.2.0+
Build ID: 991dd34d66dada90de0f5eb8f28deb74af8c5851
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-07-09_08:22:48
Locale: es-ES (es_ES.UTF-8)

Thank you!!
Comment 57 Michael Meeks 2015-07-09 18:06:42 UTC
Wow - so, at least I can reproduce on Windows. Will have a look and try to get it into RC3.
Comment 58 Michael Meeks 2015-07-14 16:22:17 UTC
I've had a further wrestle with this ... the slideshow and worse sdext/ code is some of the most -horribly- tangled stuff I've seen in libreoffice's VCL usage. No wonder its under-responsive & performs poorly ;->

Anyhow - it seems that the proximate cause of the non-rendering is that:

CanvasUpdateRequester::RequestUpdate is not called on Windows, at least until we get an invalidate from something eg. a mouse-over causing a re-render of the canvas-based presenter-console toolbar. It seems there is also something of a delay here on Linux too which makes it easier to chase but even so ... the code maketh one cry.
Comment 59 Roland Taylor 2015-07-16 21:36:52 UTC
I have not updated the nightly build yet, but still seeing this issue in the RC from the PPA, which updated between last night and today.
Comment 60 Roland Taylor 2015-07-16 21:37:43 UTC
*** Bug 92780 has been marked as a duplicate of this bug. ***
Comment 61 Michael Meeks 2015-07-20 20:21:23 UTC
More reading of the pure over-engineered horrors in the impress code-base =) Turns out that this is specific to the DX canvas. If we disable that Tools->Options->View - and un-check "use hardware acceleration" - life is good again - albeit that it still takes far longer than is remotely feasible to actually render the presenter view - (and the projected slides), but that's nothing too new =) F9 should within a few ms be able to configure both displays to be showing the right thing, but there is a huge pile of code here seemingly designed to avoid things happening sensibly here ;-)
Comment 62 Roland Taylor 2015-07-21 02:07:27 UTC
Seems to be fixed in the latest RC build from the LibreOffice Pre-release PPA.

Works with or without hardware acceleration enabled.
Comment 63 tommy27 2015-07-21 04:12:19 UTC
@Roland
it's fixed in Linux, we know that.
but the bug persists under Windows.

still reproducible with LibO 5.1.0.0.alpha1+
Build ID: fcdddbd30a8b5cf6a5cc4d2ff28b7d4a20f8ec6b
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-20_02:07:48
Locale: en-US (it_IT)
Comment 64 Roland Taylor 2015-07-21 15:30:41 UTC
Not sure what wasn't clear but I still had the problem after everyone else said ut was fixed. This is why I reported that I'm no longer seeing it.
Comment 65 tommy27 2015-07-21 15:44:37 UTC
probably they retested with a daily 5.0 build with the fix merged while you waited to test it only in the official 5.0 RC3 which featured that fix (see target in whiteboard) whilst RC2 still had the bug.

correct me if my suppositions are wrong
Comment 66 Roland Taylor 2015-07-21 15:54:23 UTC
I don't want to launch into extended discussion but as far as I understand the PPA was up to date.

It was already hosting RC3 when I commented that it wasn't fixed for me a few comments up.
Comment 67 Michael Meeks 2015-07-21 19:54:51 UTC
Hi Roland - thanks for your feedback - if you can paste the git hash / details from Help->About that really helps us to isolate the exact version you're seeing this in. Unfortunately the Windows problem is really pretty unpleasant, but my hope is the Linux issue is fixed.
Comment 68 Michael Meeks 2015-07-21 20:14:21 UTC
Well; after yet more wading through the code - I have a fix; the real question is - why does it fix it ? ;-)

diff --git a/canvas/source/directx/dx_9rm.cxx b/canvas/source/directx/dx_9rm.cxx
index 63e12b7..42c37ac 100644
--- a/canvas/source/directx/dx_9rm.cxx
+++ b/canvas/source/directx/dx_9rm.cxx
@@ -680,7 +680,6 @@ namespace dxcanvas
 
             mpWindow->SetControlForeground();
             mpWindow->SetControlBackground();
-            mpWindow->EnablePaint(sal_False);
 
             const SystemEnvData *pData = mpWindow->GetSystemData();
             const HWND hwnd(reinterpret_cast<HWND>(pData->hWnd));

I -imagine- that this method stops the window paint event getting emitted; and hence we miss the chain to:

sdext::presenter::PresenterPane::windowPaint (this=0x7fffc01b16c8, rEvent=...) at /data/opt/libreoffice/master/sdext/source/presenter/PresenterPane.cxx:139
PaintListenerMultiplexer::windowPaint (this=0x1ffcfe8, evt=...) at /data/opt/libreoffice/master/toolkit/source/helper/listenermultiplexer.cxx:122

That ultimately triggers the CanvasUpdateRequester::RequestUpdate - and various other rendering pieces that in the end calls the various updateScreen methods that whack this stuff to the display.
Comment 69 Michael Meeks 2015-07-21 20:50:00 UTC
Still not understanding the change here; but this is what I'd expect to see to get the rendering into order:

#0  sd::presenter::CanvasUpdateRequester::RequestUpdate (this=<error reading variable: can't compute CFA for this frame>, bUpdateAll=<error reading variable: can't compute CFA for this frame>) at /data/opt/libreoffice/master/sd/source/ui/presenter/CanvasUpdateRequester.cxx:81
#1  0x00007fffc25d0bcb in sd::presenter::PresenterCanvas::updateScreen (this=<error reading variable: can't compute CFA for this frame>, bUpdateAll=<error reading variable: can't compute CFA for this frame>) at /data/opt/libreoffice/master/sd/source/ui/presenter/PresenterCanvas.cxx:562
#2  0x00007fffad103911 in sdext::presenter::PresenterPaneBorderPainter::Renderer::PaintBorder (this=0x213e710, rsTitle="Current Slide (1 of 2)", rBBox=..., rUpdateBox=..., rsPaneURL="private:resource/pane/Presenter/Pane1") at /data/opt/libreoffice/master/sdext/source/presenter/PresenterPaneBorderPainter.cxx:503
#3  0x00007fffad1023a4 in sdext::presenter::PresenterPaneBorderPainter::paintBorder (this=0x7fffc01b3798, rsPaneBorderStyleName="private:resource/pane/Presenter/Pane1", rxCanvas=uno::Reference to (sd::presenter::PresenterCanvas *) 0x7fffdc09b928, rOuterBorderRectangle=..., rRepaintArea=..., rsTitle="Current Slide (1 of 2)") at /data/opt/libreoffice/master/sdext/source/presenter/PresenterPaneBorderPainter.cxx:229
#4  0x00007fffad10149f in sdext::presenter::PresenterPaneBase::PaintBorder (this=0x7fffc01b16c8, rUpdateBox=...) at /data/opt/libreoffice/master/sdext/source/presenter/PresenterPaneBase.cxx:410
#5  0x00007fffad0fef09 in sdext::presenter::PresenterPane::windowPaint (this=0x7fffc01b16c8, rEvent=...) at /data/opt/libreoffice/master/sdext/source/presenter/PresenterPane.cxx:139
#6  0x00007ffff247b192 in PaintListenerMultiplexer::windowPaint (this=0x1ffcfe8, evt=...) at /data/opt/libreoffice/master/toolkit/source/helper/listenermultiplexer.cxx:122
#7  0x00007ffff22fca86 in VCLXWindow::ProcessWindowEvent (this=0x7fffdc3b6498, rVclWindowEvent=...) at /data/opt/libreoffice/master/toolkit/source/awt/vclxwindow.cxx:470
#8  0x00007ffff22fc753 in VCLXWindow::WindowEventListener (this=0x7fffdc3b6498, pEvent=0x7fffffffc9d0) at /data/opt/libreoffice/master/toolkit/source/awt/vclxwindow.cxx:417
#9  0x00007ffff22fc5bf in VCLXWindow::LinkStubWindowEventListener (instance=0x7fffdc3b6498, data=0x7fffffffc9d0) at /data/opt/libreoffice/master/toolkit/source/awt/vclxwindow.cxx:408
#10 0x00007ffff0754b0f in Link<void*, long>::Call (this=0x156ffa0, data=0x7fffffffc9d0) at /data/opt/libreoffice/master/include/tools/link.hxx:127
#11 0x00007ffff0d2aeb4 in VclEventListeners::Call (this=0x1ffca00, pEvent=0x7fffffffc9d0) at /data/opt/libreoffice/master/vcl/source/app/vclevent.cxx:63
#12 0x00007ffff0803e6e in vcl::Window::CallEventListeners (this=0x1ffd1a0, nEvent=1000, pData=0x7fffffffcca8) at /data/opt/libreoffice/master/vcl/source/window/event.cxx:214
#13 0x00007ffff074b733 in vcl::Window::Paint (this=0x1ffd1a0, rRect=Rectangle = {...}) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:994
#14 0x00007ffff074891f in PaintHelper::DoPaint (this=0x7fffffffcc70, pRegion=0x1ffc800) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:268
#15 0x00007ffff0749b80 in vcl::Window::ImplCallPaint (this=0x1ffd1a0, rBuffer=..., pRegion=0x1ffc800, nPaintFlags=62) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:566
#16 0x00007ffff07496b2 in PaintHelper::~PaintHelper (this=0x7fffffffcdb0, __in_chrg=<optimized out>) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:505
#17 0x00007ffff0749bd1 in vcl::Window::ImplCallPaint (this=0x166bd70, rBuffer=..., pRegion=0x21071d0, nPaintFlags=60) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:570
#18 0x00007ffff07496b2 in PaintHelper::~PaintHelper (this=0x7fffffffcef0, __in_chrg=<optimized out>) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:505
#19 0x00007ffff0749bd1 in vcl::Window::ImplCallPaint (this=0x2003a90, rBuffer=..., pRegion=0x1fd4570, nPaintFlags=60) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:570
#20 0x00007ffff07496b2 in PaintHelper::~PaintHelper (this=0x7fffffffd030, __in_chrg=<optimized out>) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:505
#21 0x00007ffff0749bd1 in vcl::Window::ImplCallPaint (this=0x166b380, rBuffer=..., pRegion=0x0, nPaintFlags=60) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:570
#22 0x00007ffff0749cea in vcl::Window::ImplCallOverlapPaint (this=0x166b380) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:591
#23 0x00007ffff0749ec1 in vcl::Window::ImplHandlePaintHdl (this=0x166b380) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:620
#24 0x00007ffff0749da9 in vcl::Window::LinkStubImplHandlePaintHdl (instance=0x166b380, data=0x2040350) at /data/opt/libreoffice/master/vcl/source/window/paint.cxx:602

And of course this is completely inhibited by:

ImplCallPaint's path here:

    if (mpWindowImpl->mbPaintDisabled)
    {
        if (mpWindowImpl->mnPaintFlags & IMPL_PAINT_PAINTALL)
            Invalidate(InvalidateFlags::NoChildren | InvalidateFlags::NoErase | InvalidateFlags::NoTransparent | InvalidateFlags::NoClipChildren);
        else if ( pRegion )
            Invalidate(*pRegion, InvalidateFlags::NoChildren | InvalidateFlags::NoErase | InvalidateFlags::NoTransparent | InvalidateFlags::NoClipChildren);
        return;
    }

Tomaz - any ideas what changed here and why ? its somewhat unclear to me why we don't end up with some loop here if we invalidate, trigger a paint that ends up here with paint disabled & we trigger a new invalidate; hmm ...
Comment 70 Michael Meeks 2015-07-21 21:12:14 UTC
Would love this verified on Windows vs. master before getting too excited for -5-0 =)
Comment 71 Commit Notification 2015-07-21 21:13:06 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=591238e8a4f1164adb51d3bada0cd90c3e7c655e

tdf#91574 - ensure we get paint events to render directx presenter console.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 72 Michael Meeks 2015-07-21 21:15:38 UTC
Created attachment 117372 [details]
my random code-reading notes on some of the oddness here.
Comment 73 tommy27 2015-07-22 05:45:51 UTC
(In reply to Michael Meeks from comment #70)
> Would love this verified on Windows vs. master before getting too excited
> for -5-0 =)

works under Win8.1x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 591238e8a4f1164adb51d3bada0cd90c3e7c655e
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_00:03:41
Locale: en-US (it_IT)

set status to VERIFIED
would like to see it pushed to 5.0.x as well.
thansk Micheal
Comment 74 V Stuart Foote 2015-07-22 14:00:57 UTC
On Windows 7 sp1, 64-bit en-US with
Version: 5.1.0.0.alpha1+ (x64)
Build ID: 591238e8a4f1164adb51d3bada0cd90c3e7c655e
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_00:03:41
Locale: en-US (en_US)

Timer works, Notes, Slides panes show and can be manipulated.

So would agree its fixed now on Windows, and ready to back-port--Thanks Michael!
Comment 75 V Stuart Foote 2015-07-22 14:06:16 UTC
Should have added also good with the 32-bit builds

Version: 5.1.0.0.alpha1+
Build ID: 8be5ec39051cc0eb70ec9882a45a95c661f7398f
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-22_05:19:39
Locale: en-US (en_US)
Comment 76 Commit Notification 2015-07-22 16:23:45 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5df3725f81564a8380209881b6f2c48b2fe158b3&h=libreoffice-5-0

tdf#91574 - ensure we get paint events to render directx presenter console.

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 77 Pedro 2015-07-27 14:47:20 UTC
Created attachment 117470 [details]
Missing console under Windows XP x86 running version 5.0.0.4

It is not fixed in 5.0.0.4 under Windows XP x86

I still get the same: it runs correctly on the first run showing the console on the main monitor and the slideshow on the second. On the second run (and all following) the console is white, with some very small images on the Top Left Corner and a correct preview of the current slide in the correct position. The slideshow is working correctly on the second monitor.

See attached image.
Comment 78 V Stuart Foote 2015-07-27 15:55:17 UTC
(In reply to Pedro from comment #77)
> It is not fixed in 5.0.0.4 under Windows XP x86
> 

Will not be fixed for 5.0.0, comment 76 is clear that target is 5.0.1
Comment 79 tommy27 2015-09-04 08:54:03 UTC
*** Bug 93369 has been marked as a duplicate of this bug. ***
Comment 80 Willy Weisz 2015-11-16 11:03:21 UTC
(In reply to V Stuart Foote from comment #78)
> (In reply to Pedro from comment #77)
> > It is not fixed in 5.0.0.4 under Windows XP x86
> > 
> 
> Will not be fixed for 5.0.0, comment 76 is clear that target is 5.0.1

I'm running 5.0.3.2 (openSuse 13.1) and the bug is still there: The presenter console on terminal 2 consists of a completely white screen except for a frame with the running time displayed in yellow.

The presentation on terminal 1 is as expected, but there is no way to decently end Impress: Both terminals are blocked, and can only be unblocked with Ctrl+Alt+Del.

So please reopen the bug and fix it.
Comment 81 Willy Weisz 2015-11-16 11:12:02 UTC
I forgot to mention that the presenter console works fine using the same presentation under Impress 4.4.6.3 running in the same environment.
Comment 82 Daniel Hora 2015-11-17 15:49:13 UTC
Hi, Willy, 

Some months ago, I found out this issue had something to do with profile folder, but I was using Linux. 

I don't know how to explain it technically. But, despite having upgraded from LO 4 to 5, my profile folder remained as "4", as if no upgrade had happened. 

The solution was: with LO closed, I copied my profile folder to another place, then I  deleted the original folder. When I opened LO again it created a new profile folder, solving the problem. 

I could then copy my profile settings from the old to the new folder. But I didn't feel it was really necessary.

I don't know it it does apply to Windows.

Good luck!
Comment 83 Willy Weisz 2015-11-17 18:18:46 UTC
(In reply to Daniel Hora from comment #82)

Hi Daniel,

thank you for pointing me to the non-updated configuration. I removed the directory .config/libreoffice and restarted LO 5.

Now the presenter console shows the actual slide and the preview of the next one, and LO can be exited decently.

But:
1. The background is white instead of black (bad contrast),
2. the digits for the time measurement are over-pixeled when they are non-zero,
3. and the frame showing the graphical menue (e.g. switch terminals) is present, but only white.

Question to the maintainers:
Should I open an new bug report?
Comment 84 Willy Weisz 2015-11-18 10:40:22 UTC
Out of sheer despair I downloaded LO 5 from the libreoffice site, and
IT WORKS AS IT SHOULD!

Therefore I ask you not to re-open this bug report.

So, it's a bug in the openSuSE distribution of LO 5.0.3. I'll open a bug report with openSuSE.
Comment 85 Pedro 2015-11-18 11:03:26 UTC
(In reply to Willy Weisz from comment #84)
> Out of sheer despair I downloaded LO 5 from the libreoffice site, and
> IT WORKS AS IT SHOULD!
> 
> Therefore I ask you not to re-open this bug report.
> 
> So, it's a bug in the openSuSE distribution of LO 5.0.3. I'll open a bug
> report with openSuSE.

Thank you for investigating further and for reporting your findings.

For future situations, yes it is preferable to open a new bug report. Even if the problem is seems to be the same, it is preferable to start with a fresh report (no mixing with previous comments/symptoms)