Download it now!
Bug 73306 - Result of a PDF Export of a barcode crushed
Summary: Result of a PDF Export of a barcode crushed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-01-05 14:29 UTC by dinali
Modified: 2019-11-09 20:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
police ean13 créée par grandzébu (8.31 KB, application/x-font-ttf)
2014-01-05 14:29 UTC, dinali
Details
export with 4.1.4.2 (9.40 KB, application/pdf)
2014-01-06 20:37 UTC, Julien Nabet
Details
test with LO 4.1.4.2 on Windows (3.88 KB, application/pdf)
2014-01-06 21:03 UTC, Julien Nabet
Details
test on mac (3.86 KB, application/pdf)
2014-01-07 20:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dinali 2014-01-05 14:29:20 UTC
Created attachment 91523 [details]
police ean13 créée par grandzébu

Problem description: 
Bonjour,
Sur la version 4.1.4.2 de librooffice, apparait un bug lors de l'export pdf de la police code Ean13 (crée par grandzébu, http://grandzebu.net/informatique/codbar-en/ean13.htm).
Jusqu'à présent, j'utilisais une ancienne version d'openoffice (3.1.0) et l'export pdf fonctionnait parfaitement pour cette police.

Steps to reproduce:
1. taper un texte du type 9HSMHKA*acfjij+ (en respectant la casse). C'est un nombre de 12 chiffres encodé pour créer un gendcod
2. utiliser sur ce texte la police code Ean13
3. exporter en pdf

Current behavior:
avec une ancienne version d'openoffice, le code-barre (ou gencod) était bien retranscrit

Expected behavior:
Avec la dernière version de libreoffice, le code-barre est écrasé par l'exportation en pdf. (A savoir le phénomène se produit de la même manière sur Apache open office)

cordialement,

Jennifer              
Operating System: Windows 7
Version: 4.1.4.2 release
Comment 1 Jacques Guilleron 2014-01-05 21:03:22 UTC
Hi Jennifer,

English language is required here. Can you do it?

Thanks,

Jacques
Comment 2 Jacques Guilleron 2014-01-05 21:04:17 UTC Comment hidden (obsolete)
Comment 3 Adolfo Jayme 2014-01-06 02:59:12 UTC
Hi Sophie, would you like to translate this bug report for us? :-)
Comment 4 Julien Nabet 2014-01-06 20:21:01 UTC
Quick translation:
"
Hi,

On 4.1.4.2 LO version, there's a bug which appears during PDF export of the font "Code EAN13" (which has been created by grandzébu, http://grandzebu.net/informatique/codbar-en/ean13.htm).
Until now, I used a former version of OpenOffice (3.1.0) and the PDF export perfectly worked for this font.

Steps to reproduce:
1. Type a text like 9HSMHKA*acfjij+ (respect the letter case), it's a number of 12 characters specifically forged to create an EAN (European Article Numbering) code (Translator's note: "GENCODE" was the name of a French organism to manage EAN codes in France)
2. Apply the font "Code EAN13" on this text 
3. Export to PDF

(translator's note: I've fixed the confusion between current and expected behaviour)
Current behavior:
With last LO version, the barcode is "crushed" (removed?) by PDF export. (This also occurs in Apache OpenOffice)

Expected behavior:
"With an old OpenOffice version, the barcode (or gencod) was well exported"
(translator's note: Should export ok)

Regards.
"
Comment 5 Julien Nabet 2014-01-06 20:27:37 UTC
Jenifer: pour information, les bugs doivent être déclarés en anglais.
(translation: for your information, bugs must be declared in English)
Comment 6 Julien Nabet 2014-01-06 20:37:29 UTC
Created attachment 91558 [details]
export with 4.1.4.2

On pc Debian x86-64 with LO Debian package 4.1.4.2, I don't reproduce this.
The test file export seems ok.

(sur Debian x86-64 avec le paquet LibreOffice 4.1.4.2 de Debian, je n'ai pas reproduit le problème. Le fichier d'export de test semble correct).
Comment 7 Julien Nabet 2014-01-06 21:03:03 UTC
Created attachment 91560 [details]
test with LO 4.1.4.2 on Windows

I attached the result of a PDF export on Windows, the barcode is indeed crushed.

(J'a joint le résultat d'un export PDF sur Windows, le code barre est effectivement écrasé).
Comment 8 Julien Nabet 2014-01-06 21:07:54 UTC
So the problem is confirmed.

Michael: any idea who may help here?
Comment 9 dinali 2014-01-06 21:12:36 UTC
Merci Julien pour ta traduction. Je ne savais pas que je devais rapporter le bug en anglais mais tu l'as traduit bien mieux que je ne l'aurais fait!




Envoyé depuis mon appareil mobile Samsung

-------- Message d'origine --------
De : bugzilla-daemon@freedesktop.org 
Date :06/01/2014  21:27  (GMT+01:00) 
A : dinali@free.fr 
Objet : [Bug 73306]
  PDF: problème de transcription d'une police par
  l'export PDF 

Comment # 5 on bug 73306 from Julien Nabet
Jenifer: pour information, les bugs doivent être déclarés en anglais.
(translation: for your information, bugs must be declared in English)
You are receiving this mail because:
You reported the bug.
Comment 10 Julien Nabet 2014-01-07 20:19:42 UTC
Created attachment 91614 [details]
test on mac

I attached a pdf made on Mac OS 10.7.5 with LO 4.1.4

It's quite small (but it was small too on Writer even after having selected font size 16) but not crushed
Comment 11 pierre-yves samyn 2014-01-08 10:53:24 UTC
Hello

If it helps I confirm reproduce the problem on windows xp
already with version LibreOffice 3.5.0rc1 
Version ID : b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87

(I have not tested with an older version)

I confirm it is ok with OOo 3.2.1

Regards
Pierre-Yves
Comment 12 Julien Nabet 2014-01-08 12:11:25 UTC
Pierre-Yves: Thank you for your feedback, I update version accordingly.

(BTW, about my Windows test, it was with Win7 64)
Comment 13 QA Administrators 2016-02-21 08:36:56 UTC Comment hidden (obsolete)
Comment 14 Michael Meeks 2016-10-29 19:47:14 UTC
Hmm; looks like a font-embedding issue - that's a very odd font, and we would need it in the PDF; did we change the defaults there somewhen ? Either way - unclear why I'm CC'd here =)
Comment 15 QA Administrators 2017-10-30 08:30:50 UTC Comment hidden (obsolete)
Comment 16 eisa01 2019-11-09 20:26:09 UTC
This exports fine on Windows now

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded