Bug 73560 - Other: Invisible menu text when desktop effects are disabled
Summary: Other: Invisible menu text when desktop effects are disabled
Status: RESOLVED DUPLICATE of bug 72262
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-13 15:05 UTC by Ortwin Glück
Modified: 2014-01-13 15:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen photo (72.82 KB, image/jpeg)
2014-01-13 15:05 UTC, Ortwin Glück
Details
dialog photo (81.68 KB, image/jpeg)
2014-01-13 15:06 UTC, Ortwin Glück
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ortwin Glück 2014-01-13 15:05:34 UTC
Created attachment 91953 [details]
screen photo

Under KDE when Desktop effects are disabled (Alt-Shift-F12 / Settings > Enable Desktop effects on startup) all menu text in libreoffice disappears.

It's really weird: On the splash screen (where you select the specific LO application) all the items are blank, only the underscore (that marks the keyboard shortcut of that menu item) is visible. The same for the main application menu. Also any text in dialogs and context menus.

In dialogs the text becomes visible when I move the window.

Strangely when I make a screenshot (witch ksnapshot) the text is visible on the saved image.


Operating System: Linux (Other)
Version: 4.1.3.2 release
Comment 1 Ortwin Glück 2014-01-13 15:06:31 UTC
Created attachment 91954 [details]
dialog photo
Comment 2 Maxim Monastirsky 2014-01-13 15:23:12 UTC
Hi,

Thanks for reporting this bug! The issue described here is already reported as Bug 72262, hence I'll mark your report as a duplicate.

Would be great if you could also inform (Please do it as a comment in Bug 72262):

- The distribution you're using.

- KDE version.

- What graphics card you're using, and what driver.

- What happens if you switch to XRender instead of OpenGL (It's a setting in KDE 'System Settings' under Desktop Effects->Advanced->Compositing type)?

- Did you turn on font anti-aliasing\hinting (It's a setting in KDE 'System Settings' under Application Appearance->Fonts)? What happens if you change hinting setting or turn off anti-aliasing completely?

- Also take a look Tools->Options...->LibreOffice->View. There are settings related to hardware acceleration\font anti-aliasing. Does it make any difference if you turn them off? (note that there are two anti-aliasing check boxes in that dialog.)

Thanks.

*** This bug has been marked as a duplicate of bug 72262 ***