Bug 72262 - Menu text disappears as soon as mouse pointer touches it (KDE with Nvidia card)
Summary: Menu text disappears as soon as mouse pointer touches it (KDE with Nvidia card)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 73560 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-03 12:04 UTC by wannek-spamfree
Modified: 2015-12-15 10:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
lo-writer_menu-only-dashes.jpg (124.33 KB, image/jpeg)
2013-12-03 19:02 UTC, wannek-spamfree
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wannek-spamfree 2013-12-03 12:04:57 UTC
Problem description: 
  In all components of libreoffice the menu items which are fine at start disapear, when aproaching with the mouse pointer. Only dashes are left. The structure keeps the same, it is still klickable, but all opening sub-menus contain only dashes.
Steps to reproduce:
1. open any libreoffice component
2. move the mouse pointer toweards a menu item
3. it reads "-"
4. Click on menu, it opens a sub menu window
5. only dashes; but clickable, if you know where it is.
6. If you click on the main window title bar, the menu comes back.
Current behavior:
 see above.
Expected behavior:
 normal menus
Hint:
  I'm using KDE 4.11.3 under Debian.
  If i switch compositing to xrender instead of opengl, then all menus look and stay as expected.

Operating System: Debian
Version: 4.1.3.2 release
Last worked in: 4.1.1.2 release
Comment 1 Maxim Monastirsky 2013-12-03 12:22:54 UTC
Hi,

Which LibreOffice build are you using? From http://www.libreoffice.org/download, or from Debian repositories? For the latter case, Did you install 'libreoffice-kde' package, or you're using gtk rendering? Could you also attach a screenshot of the bug?
Comment 2 wannek-spamfree 2013-12-03 19:02:37 UTC
Created attachment 90183 [details]
lo-writer_menu-only-dashes.jpg

Hi Maxim,

thanks a lot for taking care!

I don't know if you need that information enclosed, so i let it stand here:
> https://bugs.freedesktop.org/show_bug.cgi?id=72262
> 
> Maxim Monastirsky <momonasmon@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |momonasmon@gmail.com
> 
> --- Comment #1 from Maxim Monastirsky <momonasmon@gmail.com> ---

> Which LibreOffice build are you using? From
> http://www.libreoffice.org/download, or from Debian repositories? 
I use the libreoffice debs of Debian sid, for example:
$ dpkg -s libreoffice-writerPackage: libreoffice-writer
Status: install ok installed
Priority: optional
Section: editors
Installed-Size: 26515
Maintainer: Debian LibreOffice Maintainers
<debian-openoffice@lists.debian.org>
Architecture: amd64
Source: libreoffice
Version: 1:4.1.3-1
Replaces: libreoffice-core (<< 1:3.3.2-5)
Depends: libreoffice-base-core (= 1:4.1.3-1), libreoffice-core (=
1:4.1.3-1), libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libicu48 (>= 4.8-1),
libmwaw-0.1-1, libodfgen-0.0-0, libstdc++6 (>= 4.6), libwpd-0.9-9,
libwpg-0.2-2, libwps-0.2-2, libxml2 (>= 2.7.4), uno-libs3 (>=
4.1.0~alpha), ure, zlib1g (>= 1:1.1.4)
Recommends: libreoffice-math, libreoffice-java-common (>= 1:4.1.3~),
default-jre | gcj-jre | openjdk-7-jre | openjdk-6-jre | sun-java5-jre |
sun-java6-jre | java5-runtime | jre
Suggests: libreoffice-base, libreoffice-gcj
...

> For the latter case, Did you install 'libreoffice-kde' package, or
> you're using gtk rendering? 
I do not have a libreoffice-kde installed.

By the way, i tried adding that single package.
But it did not change the behaviour, the menu items still disappear one
after another if the mousepointer comes close and opening submenus show
only dashes.
So, removed it again.

> Could you also attach a screenshot of the bug?
Funnily a screenshot is not possible, since that "updates" somehow the
whole screen and the menus look as if normal. But i have a photograph
attached.

The menu items, which i did not touch yet, are still visible (german).

Best regards!
Uli
Comment 3 Maxim Monastirsky 2013-12-04 08:38:43 UTC
Hi Uli,

Please don't reply using your e-mail client, use the web interface instead. It's located at https://bugs.freedesktop.org/show_bug.cgi?id=72262.

- From the photo that you provided it's clear that you're using the 'generic' rendering plugin. Would be great if you could also test the gtk\gtk3 plugins. The relevant packages are 'libreoffice-gtk' and 'libreoffice-gtk3'. You may also need to export 'SAL_USE_VCLPLUGIN=gtk' or 'SAL_USE_VCLPLUGIN=gtk3'.

- Did you turn on font anti-aliasing\hinting (It's a setting in KDE 'System Settings' under Application Appearance->Fonts)? What happens if you change hinting setting or turn off anti-aliasing completely?

- Also take a look Tools->Options...->LibreOffice->View. There are settings related to hardware acceleration\font anti-aliasing. Does it make any difference if you turn them off? (note that there are two anti-aliasing check boxes in that dialog.)

- Also please inform what graphics card you're using, and what driver.

Thanks.
Comment 4 wannek-spamfree 2013-12-04 18:31:48 UTC
Hi Maxim,

thanks for your answer!

> Would be great if you could also test the gtk\gtk3 plugins. 
> The relevant packages are 'libreoffice-gtk' and 'libreoffice-gtk3'.
I did install those two and got a different look: more rounded corners for example of the font tool box. So this is supposed to be successful.
But: same behaviour, dashes ....

> You may also need to export 'SAL_USE_VCLPLUGIN=gtk' or 
> 'SAL_USE_VCLPLUGIN=gtk3'.
I did not do that.

> Did you turn on font anti-aliasing\hinting (It's a setting in KDE
> 'System Settings' under Application Appearance->Fonts)? 
Yes, the checkbox reads "activated".

> What happens if you change hinting setting or turn off anti-aliasing
> completely?
Switched to "deactivated" 
==> same behaviour (gtk) and same behaviour (generic).

> Also take a look Tools->Options...->LibreOffice->View.
> There are settings related to hardware acceleration\font anti-aliasing. 
> Does it make any difference if you turn them off? (note that there are
> two anti-aliasing check boxes in that dialog.)
Both were checked.
Both switched to off ==> still the same behaviour.
(no difference, whether KDE system anti-aliasing on or off)

> Also please inform what graphics card you're using, and what driver.
$ inxi -G
Graphics:  Card: NVIDIA GF108GLM [Quadro 1000M] X.Org: 1.14.3 driver: nouveau Resolution: 1920x1200@60.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits) GLX Version: 2.1 Mesa 9.2.2

Thanks again and good luck!
Comment 5 Maxim Monastirsky 2013-12-05 17:41:46 UTC
(In reply to comment #4)
> > What happens if you change hinting setting or turn off anti-aliasing
> > completely?
> Switched to "deactivated" 
> ==> same behaviour (gtk) and same behaviour (generic).
That's bad. There is a similar bug from a user with Nvidia card, but he reported that it doesn't happen with anti-aliasing turned off. See Bug 69342 comment 13.
Comment 6 wannek-spamfree 2013-12-09 09:28:20 UTC
Bug still exists and behaves the same in Version
LibreOffice 4.1.3.2 410m0(Build:2)
By the way: no other program showed that strange behaviour so far.
Comment 7 retired 2013-12-23 13:14:38 UTC
Does 4.2.0.1 change anything for the better? http://www.libreoffice.org/download/pre-releases/
Comment 8 wannek-spamfree 2014-01-08 12:29:40 UTC
I tried now the LibreOffice_4.2.0.1_Linux_x86-64 and the behaviour is still the same: dashes whenever i hover the mouse over the menue structure.
Comment 9 Maxim Monastirsky 2014-01-13 15:23:12 UTC
*** Bug 73560 has been marked as a duplicate of this bug. ***
Comment 10 Ortwin Glück 2014-01-13 15:38:14 UTC
I have the same problem. See screenshots in Bug 73560. My system:
- HP EliteBook 8540w with NVidia GT215GLM [Quadro FX 1800M] (NV50)
- Gentoo
- kde-base/kde-meta-4.11.2-r1:4
- app-office/libreoffice-bin-4.1.3.2-r3 with KDE integration
- kernel option: nouveau.noaccel=0 (because Xorg crashes with accel)
- x11-base/xorg-server-1.14.3-r2:0/1.14.3
- x11-drivers/xf86-video-nouveau-1.0.9:0
- media-libs/mesa-9.1.6:0 with EGL, Gallium, LLVM

using XRender with native option (OpenGL option doesn't work)

font aliasing enabled.

None of the options under LibreOffice->View have any influence.
Comment 11 Maxim Monastirsky 2014-01-13 16:02:12 UTC
(In reply to comment #10)
> using XRender with native option (OpenGL option doesn't work)
That's interesting, since it works with XRender for the original reporter (see comment 0).
Comment 12 Ortwin Glück 2014-01-14 08:35:24 UTC
> That's interesting, since it works with XRender for the original reporter

I suspect that his OpenGL setting doesn't fully work and thus KDE disables Desktop effects automatically. Once he switches to XRender Desktop effects get enabled again, and the problem disappears.
Comment 13 wannek-spamfree 2014-01-14 09:46:11 UTC
(In reply to comment #12)
> > That's interesting, since it works with XRender for the original reporter
> 
> I suspect that his OpenGL setting doesn't fully work and thus KDE disables
> Desktop effects automatically. Once he switches to XRender Desktop effects
> get enabled again, and the problem disappears.

What is "doesn't fully work"; how to check?
If you tell me *which* desktop effect to switch, i could try.
The KDE config setting does not change at all, if i switch with Ctrl+Alt+F12.
And yes, working menues and the red shiny frame around the window appear together.
(But at the end, i do not want that effect)
Comment 14 Ortwin Glück 2014-01-14 10:23:55 UTC
> What is "doesn't fully work"; how to check?

KDE performs all sorts of checks when enabling Desktop Effects (= compositing). By that I mean that KDE decides to disable Desktop effects because because it decided that the OpenGL support is insufficient or too slow.

> If you tell me *which* desktop effect to switch, i could try.

It's not specific effects. It's compositing itself. That's what Ctrl+Alt+F12 toggles.

> The KDE config setting does not change at all, if i switch with Ctrl+Alt+F12.

The config only tells KDE what you want. Not whether compositing is actually turned on or even working. Also the config is not affected by the hotkey. Compositing is toggled on the fly by the hotkey.

> And yes, working menues and the red shiny frame around the window appear
> together.
> (But at the end, i do not want that effect)

eee!
Comment 15 wannek-spamfree 2014-02-10 11:06:50 UTC
News on that:
today i observed wine windows showing the same menu, dashes only. 
So, it is likely to be a more common thing and not only libreoffice related.
  libwine                                         install
  libwine-bin:i386                                install
  libwine-gecko-1.4                               install
  wine                                            install
  wine-bin                                        install

What could i test further?
Comment 16 Maris Nartiss 2014-04-28 09:39:24 UTC
I have the same issue and currently LO is the only application where I have observed it. Other texts of LO are also also disappearing (i.e. Writer status bar messages like "Page 1/2"). It is not possible to take a screenshot, as it triggers repaint and all missing text is present in the screenshot. Other KDE SC programs, Firefox etc. are unaffected. 

Enabling desktop effects (alt+shift+F12) fixes the issue.
KDE anti-aliasing setting has no effect on the issue. LO anti-aliasing setting has no effect on the issue.

LO: 4.2.1.1 (downloaded RPMs)
kde-base/kwin-4.11.8
x11-base/xorg-server-1.15.1
x11-drivers/xf86-video-nouveau-1.0.10
kernel: 3.13.1
OpenGL version string: 2.1 Mesa 10.1.0
Chipset: "NVIDIA NV98"
Comment 17 Maris Nartiss 2014-06-30 09:46:10 UTC
The issue seems to be fixed by upgrade of some of system components, not LO itself. Unfortunately as many components were upgraded, it's hard to find the guilty one.

Working system:
LO 4.2.5.2
kde-base/kwin-4.11.10-r1
x11-base/xorg-server-1.15.99.903
x11-drivers/xf86-video-nouveau-1.0.10
kernel: 3.15.0-gentoo
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 3.0 Mesa 10.2.2
Comment 18 tommy27 2014-06-30 10:25:41 UTC
@wannek
please give us update of the status of the bug on your system
hopefully this is fixed by system upgrade like happened to Maris
Comment 19 Ortwin Glück 2014-06-30 10:35:42 UTC
I can help you rule out some of these as my system is still broken with equal or newer components:
> LO 4.2.5.2 -- doesn't fix it for me
> kde-base/kwin-4.11.10-r1
> x11-base/xorg-server-1.15.99.903
> x11-drivers/xf86-video-nouveau-1.0.10 -- doesn't fix it for me
> kernel: 3.15.0-gentoo -- still broken on 3.15.2
> OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
> OpenGL version string: 3.0 Mesa 10.2.2

If would bet my money on mesa :-)
Comment 20 Ortwin Glück 2014-06-30 10:49:16 UTC
(In reply to comment #19)
> If would bet my money on mesa :-)
No, also broken with:
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
OpenGL version string: 3.0 Mesa 10.2.2
OpenGL shading language version string: 1.30
Comment 21 wannek-spamfree 2014-06-30 12:28:37 UTC
No, sorry.
I did a complete dist-upgrade a few minutes ago. But no success, i still
have the dashes, whenever my mouse-pointer hits any part of the menu.
The Shift-Alt-F12 workaround still works back and forth.

My system:
Linux 3.15-2-amd64
x11-common: 1:7.7+7
xserver-xorg: 1:7.7+7
libreoffice: 1:4.2.5-1
libegl1-mesa: 10.2.1-2


On 30.06.2014 12:25, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=72262
> 
> --- Comment #18 from tommy27 <barta@quipo.it> ---
> @wannek
> please give us update of the status of the bug on your system
> hopefully this is fixed by system upgrade like happened to Maris
>
Comment 22 wannek-spamfree 2014-07-04 07:48:17 UTC
After another dist-upgrade, i got the new mesa version:
  libreoffice:   1:4.2.5-1+b1
  libegl1-mesa:  10.2.2-1
But the issue still persists.
Comment 23 tommy27 2014-07-20 09:37:45 UTC
4.2.6.2 will be released by the end of the month.
please retest once it's available
Comment 24 wannek-spamfree 2014-08-28 17:09:33 UTC
Success!

As of today's dist-upgrade, which brought
  libreoffice:           1:4.3.0-3
  libegl1-mesa:          10.2.6-1
all the menu is visible all the time, no matter which mode i choose with
Shift-Alt-F12.

(Can't tell if this is the very first version working, since my last d-u
was a few weeks ago)

Thanks! Solved - at least or me.
Comment 25 tommy27 2014-08-28 17:23:16 UTC
Nice to hear that
Comment 26 Robinson Tryon (qubit) 2015-12-15 10:53:47 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]