Download it now!
Bug 73620 - Presenter console: Notes's button don't work, Notes view is missing
Summary: Presenter console: Notes's button don't work, Notes view is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-14 17:52 UTC by vulcain
Modified: 2014-01-23 22:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Note's vew is not here. Only Notes 's button change (color change to grey/white hightlight) (272.39 KB, image/png)
2014-01-14 17:52 UTC, vulcain
Details
Screenshot of expected result. (248.44 KB, image/png)
2014-01-14 17:54 UTC, vulcain
Details
Screenshot of presenter (left) + Screen for listeners (right). The first slide is missing with LibreOffice 4.2 beta 1 (149.97 KB, image/png)
2014-01-19 16:52 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2014-01-14 17:52:37 UTC
Created attachment 92065 [details]
Note's vew is not here. Only Notes 's button change (color change to grey/white hightlight)

In LibreOffice 4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56

We could no see the note view in presenter console.

1) Add a secondary monitor to your computer
2) Open an odp
3) Launch via F5
4) Click on Notes's button: no action. Only the button is highlight on white/grey (see the mouse on the attachement)

Workform:
6) Exit the slideshow (echap or other)
7) Launch again
8) You have presenter console with the Notes's view
Comment 1 vulcain 2014-01-14 17:54:27 UTC
Created attachment 92069 [details]
Screenshot of expected result.

Screenshot of expected result.

Make with LibreOffice 3.5.7.2 
Version ID : 350m1(Build:2)
Comment 2 Dominique Boutry 2014-01-16 09:02:35 UTC
Is the presenter console a component/feature of LibO ? (I'm on Win7)

Thanks
Comment 3 vulcain 2014-01-16 09:55:16 UTC
(In reply to comment #2)
> Is the presenter console a component/feature of LibO ? (I'm on Win7)
> 
> Thanks

Presenter console is a LiberOffice's feature since version 4.0 (cf https://wiki.documentfoundation.org/ReleaseNotes/4.0#Extensions ) Before, Presenter console, it's only an extension.
You need a secondary monitor or a projector. You can add your TV as secondary monitor via VGA or HDMI cables.

LibreOffice check presenter console in its manuals tests: http://manual-test.libreoffice.org/manage/case/136/
Comment 4 Jean-Baptiste Faure 2014-01-16 11:35:02 UTC
Reproducible on Ubuntu 13.10 x86-64.

Best regards. JBF
Comment 5 vulcain 2014-01-19 16:50:28 UTC
I test other version of LibreOffice.

Don't reproduce with:
* 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
* 4.1.5.1 Build ID: e0a1805d063a472a7b281ae3977a26d42a48b20


bug reproduce with:
* 4.2.0.0.beta1 Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
* 4.2.0.0.beta2 Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
* 4.3.0.0.alpha0+ Build ID: 602c87b4259d118e5db6d8a990c4695103f916dd
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-01-18_00:02:21

With 4.2.0.0 beta1, there are worst: the screen are black but the behavior is the same: after click on Note and make Echap, we could have note's screen (see attachement)

Presenter console crash often.
Comment 6 vulcain 2014-01-19 16:52:05 UTC
Created attachment 92406 [details]
Screenshot of presenter (left) + Screen for listeners (right). The first slide is missing with LibreOffice 4.2 beta 1

Version: 4.2.0.0.beta1 Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
Comment 7 Jean-Baptiste Faure 2014-01-21 20:12:46 UTC
Fixed in version 4.2.1.0.0+, surely by the same commit as bug 73618.

Will check on master after rebuild.

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2014-01-22 05:09:29 UTC
Works in master too. 
Version: 4.3.0.0.alpha0+ Build ID: f278397787f7b79cee8536e806e8b7113800f2ef

Best regards. JBF
Comment 9 vulcain 2014-01-23 22:12:08 UTC
I confirm this bug is resolved in 4.2.0.3 Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0 on Ubuntu 12.04.4 

@ Stahl and JBF: Thanks you