Download it now!
Bug 73623 - Presenter console: Diapos's button don't work, Diapos view is missing
Summary: Presenter console: Diapos's button don't work, Diapos view is missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-14 18:06 UTC by vulcain
Modified: 2014-01-23 22:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Diapos's view is not here. Diapos 's button change (color change to grey/white hightlight). Current and next slide dissapear (159.79 KB, image/png)
2014-01-14 18:06 UTC, vulcain
Details
Epected result (334.07 KB, image/png)
2014-01-14 18:09 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vulcain 2014-01-14 18:06:27 UTC
Created attachment 92077 [details]
Diapos's view is not here. Diapos 's button change (color change to grey/white hightlight). Current and next slide dissapear

Diapo's vew is not here. Only Diapos's button change (color change to grey/white hightlight)

In LibreOffice 4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56

We could no see the note view in presenter console.

1) Add a secondary monitor to your computer
2) Open an odp
3) Launch via F5
4) Click on Diapos's button: no action. The button is highlight on white/grey (see the mouse on the attachement). The current slide and the next slide are missing.


Expected result: have the Diapos's view (see attachement)
Comment 1 vulcain 2014-01-14 18:09:12 UTC
Created attachment 92078 [details]
Epected result

Screenshot of expected result.

Make with LibreOffice 3.5.7.2 
Version ID : 350m1(Build:2)
Comment 2 Jean-Baptiste Faure 2014-01-16 11:36:42 UTC
Reproducible on Ubuntu 13.10 x86-64

I guess this bug has the same root cause than bug 73618 and bug 73620

Best regards. JBF
Comment 3 vulcain 2014-01-19 16:51:01 UTC
I test other version of LibreOffice.

Don't reproduce with:
* 4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
* 4.1.5.1 Build ID: e0a1805d063a472a7b281ae3977a26d42a48b20


bug reproduce with:
* 4.2.0.0.beta1 Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
* 4.2.0.0.beta2 Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d
* 4.3.0.0.alpha0+ Build ID: 602c87b4259d118e5db6d8a990c4695103f916dd
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-01-18_00:02:21

With 4.2.0.0 beta1, there are worst: the screen are black  and Presenter console crash often when we click on Diapo view.
Comment 4 Jean-Baptiste Faure 2014-01-21 20:11:43 UTC
Fixed in version 4.2.1.0.0+, surely by the same commit as bug 73618.

Will check on master after rebuild.

Best regards. JBF
Comment 5 Jean-Baptiste Faure 2014-01-22 05:09:58 UTC
Works in master too. 
Version: 4.3.0.0.alpha0+ Build ID: f278397787f7b79cee8536e806e8b7113800f2ef

Best regards. JBF
Comment 6 vulcain 2014-01-23 22:12:11 UTC
I confirm this bug is resolved in 4.2.0.3 Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0 on Ubuntu 12.04.4 

@ Stahl and JBF: Thanks you