Download it now!
Bug 73749 - search for text in Impress via ctrl-f crashes LibreOffice
Summary: search for text in Impress via ctrl-f crashes LibreOffice
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-17 18:17 UTC by JPJ
Modified: 2015-02-20 15:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace log (24.12 KB, text/plain)
2014-01-17 20:17 UTC, JPJ
Details
test impress file for reproducing the crash during search bug (12.72 KB, application/vnd.oasis.opendocument.presentation)
2014-01-27 16:06 UTC, JPJ
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JPJ 2014-01-17 18:17:10 UTC
Searching for text in Impress via ctrl-f crashes LibreOffice.  This happened every time I searched in an existing powerpoint presentation.  I then created a simple 6 slide Impress presentation from a template in the presentation wizard with a single line of text on each slide.  LibreOffice also crashes each time I search for text via ctrl-f in this new Impress presentation.


    I'm using the x86-64 version of LibreOffice 4.2.0.2 (4.2 RC 2) on Kubuntu 12.04.4.
Comment 1 Julien Nabet 2014-01-17 19:26:54 UTC
On pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce this.

- Did you install any LO specific extensions?
- Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?

If you still reproduce this, could you retrieve a backtrace, copy paste the content in a file and attach the file to the bugtracker? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 2 JPJ 2014-01-17 20:16:37 UTC
    Renaming my profile did not fix the problem.

    Extension manager shows these in the new profile:
- English spelling dictionaries, hyphenation rules, thesaurus, and grammar checker 201.12.05.1
- French spelling dictionary, hyphenation rules, and thesaurus 4.11, Discollecte
- Solver for Nonlinear Programming 0.9, The Document Foundation
- Spanish spelling dictionary, hyphenation rules, and thesaurus 0.7, rla-es
- Wiki Publisher 1.1.1, The Document Foundation

    These are the additional extensions in my original profile:
Alternative searching 1.4, Tomas BILEK
Zotero LibreOffice Integration 3.5.8

    Also, the Extensions button at the bottom of the left column of Start Center does not function at all.  It appears active but does nothing.  Perhaps this is related.

    I don't have a libreoffice-dbg package but I'm attaching the backtrace results anyway.
Comment 3 JPJ 2014-01-17 20:17:31 UTC
Created attachment 92302 [details]
backtrace log
Comment 4 Jean-Baptiste Faure 2014-01-26 16:34:00 UTC
I do not reproduce with version 4.2.0.3.0+ on Ubuntu 13.10 x86-64

Do you still encounter the same crash with the RC3 ?

Best regards. JBF
Comment 5 JPJ 2014-01-27 01:39:42 UTC
I still reproduce the problem in 4.2.0.3 (4.2 RC 3).
Comment 6 Jean-Baptiste Faure 2014-01-27 04:58:43 UTC
(In reply to comment #5)
> I still reproduce the problem in 4.2.0.3 (4.2 RC 3).

Ok, so please, attach your test file and describe step by step what you do to reproduce the crash. 
Do you confirm that you use ctrl+F and not ctrl+H ?
Do you reproduce the crash whatever you type in the search field ?

Best regards. JBF
Comment 7 JPJ 2014-01-27 16:06:04 UTC
Created attachment 92866 [details]
test impress file for reproducing the crash during search bug

    I have been able to reproduce the problem on every file I've tried including existing Impress files, new Impress files, and existing ppt files.

    In this case I created a new 7 slide Impress file with just text on each slide using LibreOffice 4.2.0.3 (4.2 RC3). This file is attached.  Then I typed ctrl+f, typed the text "harry" (without the quotes) and hit enter.  Since I had started on the last slide I was prompted to ask whether or not I wanted to continue at the beginning.  I selected "Yes" at which point the search continued through the rest of the slides and then LibreOffice crashed.

    If I start on the first slide, LibreOffice crashes almost as soon as the search has began.  I've tried various search terms such as "jungle", "cat", "bryophytes", etc.  The crash happens regardless of which search term I use.
Comment 8 JPJ 2014-01-27 16:39:35 UTC
    I just installed 4.2.0.3 (4.2 RC3) on windows 7 sp 1 in a virtual machine.  The same problems occurs in this environment as well.  At first I used the test file I attached to this bug earlier.  Then I created a new file using the windows install.  The crash still happens.  A difference between the crash here and the crash under Kubuntu is that the docuement recovery dialog starts immediately in the windows environment.
Comment 9 Jean-Baptiste Faure 2014-01-27 19:32:46 UTC
It is very strange, I do not still reproduce the crash. I reported another bug like this one (bug 74104) but the crash is triggered differently and it concerns the search&replace dialog (ctrl+H).

Did you try with a clean new LibreOffice user profile?
https://wiki.documentfoundation.org/Faq/General/110

Best regards. JBF
Comment 10 JPJ 2014-01-27 20:07:56 UTC
(In reply to comment #9)
> It is very strange, I do not still reproduce the crash. I reported another
> bug like this one (bug 74104) but the crash is triggered differently and it
> concerns the search&replace dialog (ctrl+H).
> 
> Did you try with a clean new LibreOffice user profile?
> https://wiki.documentfoundation.org/Faq/General/110
> 
> Best regards. JBF


I did try a new profile in Kubuntu with RC 2.  I just tried again with RC 3 to make sure but that still did not help.  RC 3 was the first install of LibreOffice in the windows VM so that was a brand new profile too.
Comment 11 JPJ 2014-01-30 16:51:47 UTC
    I just tested with 4.2.0.4 (release) and still have the same problem.  Searching via ctrl-f causes LibreOffice to crash on Kubuntu 12.04.4 on my laptop, and on windows 7 sp 1 in a virtual machine.  I also just went through all the same tests in a Kubuntu 12.04.2 virtual machine and the crash happens there as well.
Comment 12 JPJ 2014-01-30 19:21:12 UTC
    Same problem exists running LibreOffice 4.2.0.4 (release) under Gnome on Ubuntu 12.04.2 and Ubuntu 12.04.4 in a VirtualBox VM.
Comment 13 JPJ 2014-01-30 19:40:35 UTC
    I just to access to a windows 7 sp1 install on a separate laptop with different hardware.  The exact same problem exists there too.
Comment 14 Jean Prunneaux 2014-02-20 16:07:18 UTC
Hi,

It seems this bug is related with this one (under Win7):
https://bugs.freedesktop.org/show_bug.cgi?id=74653

This bug is fixed in LO 4.2.1.1.

Regards
Comment 15 Michael Meeks 2014-07-28 16:16:03 UTC
JPJ - thanks for the report; can you confirm whether this still affects you for a recent LibreOffice 4.2.x ? =)
Comment 16 QA Administrators 2015-02-19 04:37:11 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 2015-02-18
Comment 17 Jean-Baptiste Faure 2015-02-20 06:20:29 UTC
(In reply to JPJ from comment #7)
> [...]
>     If I start on the first slide, LibreOffice crashes almost as soon as the
> search has began.  I've tried various search terms such as "jungle", "cat",
> "bryophytes", etc.  The crash happens regardless of which search term I use.

Ok, so closing as duplicate because it seems that the issue is that the search term is not present in the text, exactly as in bug 74653.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 74653 ***
Comment 18 JPJ 2015-02-20 14:41:47 UTC
I somehow missed comment 15 and lost track of this bug.  I can confirm that the bug disappeared in 4.3.x and is not present in 4.4.0.3.  It was not a duplicate bug though.  The crash occurred even when the search term was present.
Comment 19 Julien Nabet 2015-02-20 15:29:39 UTC
just nitpicking, since there's no specific fix, I'll put WFM