Bug 73814 - grouped shape in ODG file badly distorted when inserted in Writer document
Summary: grouped shape in ODG file badly distorted when inserted in Writer document
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard: odf target:4.3.0 target:4.2.0
Keywords: regression
: 74109 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-01-19 23:09 UTC by Alex Thurgood
Modified: 2014-01-27 14:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
wrongly displayed PNG file (16.85 KB, image/png)
2014-01-19 23:09 UTC, Alex Thurgood
Details
correct display in 4132 (13.82 KB, image/png)
2014-01-19 23:14 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2014-01-19 23:09:52 UTC
Created attachment 92415 [details]
wrongly displayed PNG file

I have been using a PNG file that I originally exported from an ODG file created in LibreOffice 3.3.0 or OpenOffice.org 3.3. This file is inserted into a Writer document template that I have been using for 3 years.

In LO 4.2.0.2 on Mac OSX Mavericks, if I open the Writer document containing the inserted PNG file, it appears completely distorted as in attached screenshot.

This is a regression over LO 4.1.3.2 where the image displays normally and as it should.

Am setting highest priority, and blocker status. If this is considered wrong, well, reset it.
Comment 1 Alex Thurgood 2014-01-19 23:11:19 UTC
Note that the attached file is a "screenshot" of how the actual file is displayed in LO 4202.
Comment 2 Alex Thurgood 2014-01-19 23:14:25 UTC
Created attachment 92416 [details]
correct display in 4132
Comment 3 Regina Henschel 2014-01-19 23:42:40 UTC
Please open the file in LO4.1, set LO 4.1 to save in format "1.2 Extended (compat mode), and resave the file. Then open it in LO 4.2. If it is ok then, it is bug 65516.
Comment 4 Alex Thurgood 2014-01-20 10:07:40 UTC
(In reply to comment #3)

Hi Regina,

> Please open the file in LO4.1, set LO 4.1 to save in format "1.2 Extended
> (compat mode), and resave the file. Then open it in LO 4.2. If it is ok
> then, it is bug 65516.


Did that, and it made absolutely no difference.

FWIW, there was a similar, although not as bad, problem, during or 4.0.x development where the white area of the loop in the letter "P" ended up as red - the loop of the "P" was clearly being misinterpreted and intersecting with the white space. Now it is the "G" that is being misinterpreted.

Generally, we go on about MS not respecting its standards. What good is our own standard if the reference implementation doesn't even respect it ?  

Alex
Comment 5 Alex Thurgood 2014-01-20 10:20:59 UTC
Tested on :

My original Writer doc containing the inserted PNG :

LO 3.3.4 - "P" loop displays incorrectly, remainder displays correctly

LO 3.5.7 - displays correctly

LO 3.6.6.2 - displays correctly

LO 3.6.7.2 - displays correctly

LO 4.0.5.2 - displays correctly

LO 4.1.3.2 - displays correctly

LO 4.2.1.0.0 - displays incorrectly, disproportionate letter "G", intersected and inverted colour "P" loop
Comment 6 Alex Thurgood 2014-01-20 10:22:43 UTC
As testing has confirmed, earliest version so far where the problem is reproducible is 4.2.0.1 rc
Comment 7 Alex Thurgood 2014-01-20 10:29:55 UTC
NeoOffice 3.4 p0 : incorrectly displayed "P" loop, rest is correct
OpenOffice 3.4 : incorrectly displayed "P" loop, rest is correct
Comment 8 Thomas van der Meulen 2014-01-20 15:03:59 UTC
Alex could you upload load a test file so I can test this bug and set it to new?
Thank you in advance.
Comment 9 Michael Stahl (CIB) 2014-01-20 21:50:08 UTC
cannot reproduce this bug with the second attachment on Linux (master, current 4.2 or 4.2.0.1)

both Insert->Image in Writer and opening PNG in Draw + Copy/Paste work for me
Comment 10 Alex Thurgood 2014-01-22 10:10:09 UTC
(In reply to comment #9)
> cannot reproduce this bug with the second attachment on Linux (master,
> current 4.2 or 4.2.0.1)
> 
> both Insert->Image in Writer and opening PNG in Draw + Copy/Paste work for me

Hi Michael,

The problem is not with the PNG attachments I have uploaded, they are "screenshots" illustrating the problem, as I mentioned in my original submission.


Let me retrace the history.
I created a Draw ODG file for my company's logo at the beginning of 2010 with the first release of LO, or possibly OpenOffice.org 3.2.1.

I exported the objects in that Draw file to a PNG image.

That PNG image was then inserted into my Writer template.

This was done in 2010.

In LO 4.1.3.2 and in most (but not all) of the previous versions of LO as tested and reported here, the Writer template/document displays the PNG image correctly.

Release candidates 4.2rc1 and rc2 both display the PNG image incorrectly in letters I have written based on that template. This means that all of the letters I have written to my clients using that template now display incorrectly when opened in 4.2

I will not upload the files here because I have no desire for them to become "public", not to mention the potential for trademark dilution of the logo.
Comment 11 Alex Thurgood 2014-01-22 10:16:18 UTC
Also tested on :

Version: 4.3.0.0.alpha0+
Build ID: 42f551d524a1df46f6a311d5897ac30bd8fc1aaf

Linux 64bit

The problem is present there too - changing OS to all.

Alex
Comment 12 Regina Henschel 2014-01-22 10:27:50 UTC
Alex, please attach the source document containing the graphic, not the result in LO4.3. I want to see the path definitions in the source. I still think it might be a problem with the "close path" command "z".
Comment 13 Alex Thurgood 2014-01-22 10:35:11 UTC
(In reply to comment #12)
> Alex, please attach the source document containing the graphic, not the
> result in LO4.3. I want to see the path definitions in the source. I still
> think it might be a problem with the "close path" command "z".


Hi Regina,

It might well be what you say it is, but I'll not be uploading my business document template containing my business logo to a server where it will become "public domain".
Comment 14 Regina Henschel 2014-01-22 10:52:01 UTC
Alex, would you mind sending it to me directly?
Comment 15 Michael Stahl (CIB) 2014-01-23 21:42:31 UTC
... so the PNG in the bug title is a red herring, it's actually
a grouped shape with 3 sub-shapes that are positioned wrongly.

the bug was introduced by same commit as bug 73355, resolving duplicate

*** This bug has been marked as a duplicate of bug 73355 ***
Comment 16 Alex Thurgood 2014-01-24 06:06:33 UTC
(In reply to comment #15)
> ... so the PNG in the bug title is a red herring, it's actually
> a grouped shape with 3 sub-shapes that are positioned wrongly.
> 
> the bug was introduced by same commit as bug 73355, resolving duplicate
> 
> *** This bug has been marked as a duplicate of bug 73355 ***

Thanks for looking at this.

Alex
Comment 17 Michael Stahl (CIB) 2014-01-27 11:02:37 UTC
turns out there were 2 commits that affect this document - second one is bug 74109
Comment 18 Commit Notification 2014-01-27 11:15:27 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df2ad69d5df350636c1eb1772b16a2e203a88fa7

Resolves: fdo#73814 wrong name for drawing::PointSequenceSequence property



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2014-01-27 11:31:17 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6eac0306a61066e91ff748a7cb2a6a86a94820ac&h=libreoffice-4-2

Resolves: fdo#73814 wrong name for drawing::PointSequenceSequence property


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2014-01-27 13:06:14 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=35e7cb39634b0afbbb364fc50fad1a02ce74573b&h=libreoffice-4-2-0

Resolves: fdo#73814 wrong name for drawing::PointSequenceSequence property


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2014-01-27 14:43:42 UTC
*** Bug 74109 has been marked as a duplicate of this bug. ***