Bug 74109 - grouping and size lost between 4.1 and 4.2 for drawings done in Writer
Summary: grouping and size lost between 4.1 and 4.2 for drawings done in Writer
Status: RESOLVED DUPLICATE of bug 73814
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-27 08:10 UTC by Jean-Baptiste Faure
Modified: 2015-01-24 12:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test document with the drawing described in the bug description (9.07 KB, application/vnd.oasis.opendocument.text)
2014-01-27 08:10 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-01-27 08:10:28 UTC
Created attachment 92837 [details]
test document with the drawing described in the bug description

Steps to reproduce:
1/ open a new empty document in LibreOffice 4.1.4
2/ add drawing toolbar
3/ create 2 forms, for example 2 circles
4/ draw a line between these 2 circles
5/ select the line and click on one of its ends, the point becomes red
6/ in the drawing toolbar, click on the Points icon, a new toolbar appears
7/ In this toolbar, click on the button Symetric Transition (idem if you click on Smooth Transition, the purpose is to transform the line in a curve). Now move the point in the middle of the line to transform the line in a curve.
9/ as a witness, draw a line between both circles
9/ In the drawing toolbar, click on the button Select (the first one) and draw a selection rectangle around your nice drawing to select it entirely. Right click and choose Group > Group in the contextual menu.
10/ save your file and exit LO 4.1.4
11/ open your file with LO 4.2.0.3

Current behavior : the curve is not where it should, but the straight line is correct.

Expected behavior: LO 4.2 should not distort the drawing

This bug has been reproduced on MS-Windows and Linux (FR QA mailing-list)

Best regards. JBF
Comment 1 Alex Thurgood 2014-01-27 08:37:38 UTC
DUP of 73355 ?
Comment 2 Alex Thurgood 2014-01-27 08:39:48 UTC

*** This bug has been marked as a duplicate of bug 73355 ***
Comment 3 Jean-Baptiste Faure 2014-01-27 09:20:09 UTC
(In reply to comment #1)
> DUP of 73355 ?

No, bug 73355 is for Draw, this one for Writer. I did the drawing without using Draw module. And did my tests with 4.2.0.3.0+ which contains the commit fixing bug 73355.

Best regards. JBF
Comment 4 Michael Stahl (CIB) 2014-01-27 11:00:12 UTC
so ... it turns out there are 2 bugs here, this one
and the bug 73355, and the secret bugdoc in bug 73814
is actually affected by _both_ of them; at least we have a
public reproducer for both bugs now.

this bug is from commit:

commit e44335abe006d05f0f915279605a03ef084116d6
Author:     Caolán McNamara <caolanm@redhat.com>
AuthorDate: Thu Oct 31 15:51:30 2013 +0000

    Related #i123433# PolyPolygonBezier must be drawing::PolyPolygonBezierCoords

    Change-Id: Idc7e0a2651f2e0b499bbf8b8443ffb84b54a45b6
Comment 5 Caolán McNamara 2014-01-27 14:43:42 UTC

*** This bug has been marked as a duplicate of bug 73814 ***