Bug 73966 - FORMATTING: bullets images should resize with text
Summary: FORMATTING: bullets images should resize with text
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All Linux (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-23 11:02 UTC by Faisal Menawer
Modified: 2019-01-23 23:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bullet image type (89.09 KB, image/png)
2014-04-09 07:03 UTC, Faisal Menawer
Details
example showning Word supports this feature (63.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-11-19 02:25 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Faisal Menawer 2014-01-23 11:02:00 UTC
if you change the size of paragraph has bullet numbering
the size of the bullets will changed. But if the paragraph size
the images bullets will had one size only.

Steps to reproduce:
1. open writer or impress.
2. insert image bullet from "bullets and numbering".
3. write some text.
4. change the text size.

Current behavior:
the bullet size not changed if the text size are changing.

Expected behavior:
the bullet size changed if the text size are changing.
Comment 1 tommy27 2014-04-09 05:43:30 UTC
tested under Win7x64 using Version: 4.3.0.0.alpha0+
Build ID: 7d3a899f0ea4311b216b8398751d33a88b83d6ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-05_00:09:26

not reproducible. bullet size do change together with text size.

I mark this as RESOLVED WORKSFORME.
feel free to reopen if you still experience this issue with recent daily builds.
Comment 2 Faisal Menawer 2014-04-09 07:03:09 UTC
Created attachment 97109 [details]
bullet image type

using mint 14 64-bit
Version: 4.3.0.0.alpha0+
Build ID: 34669e634d7cb18099e8d27eed10e5b816237411

Still reproducible. So i am reopen it again,
the bug are in the image type only.
Comment 3 tommy27 2014-04-09 07:09:24 UTC
nice screenshot. must be Linux specific issue.

revert status to UNCONFIRMED waiting for confirmation by another Linux user.
Comment 4 Owen Genat (retired) 2014-07-18 15:26:59 UTC
(In reply to comment #0)
> if you change the size of paragraph has bullet numbering
> the size of the bullets will changed. But if the paragraph size
> the images bullets will had one size only.

(In reply to comment #3)
> waiting for confirmation by another Linux user.

I can confirm that image bullet identifiers (i.e., Format > Bullets & Numbering > Graphics/Image tab) for unordered lists in Impress (and Writer for that matter) DO NOT scale with the point size of the text. Font-base bullet identifiers (i.e., Format > Bullets & Numbering > Bullets tab) DO scale with the point size of the text. This is as expected and it has been this way since at least v3.5 and probably before. There is no value in scaling a raster image (the provided bullets are GIF) as it merely becomes pixellated. If the image bullets were in a vector format it may be a different matter.

Tested under GNU/Linux with these versions:

- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.5.2 Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5
- v4.3.0.2 Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409
- v4.4.0.0.alpha0+ Build ID: 3fdd4f069d5436cf39708004af7fda8175fbc4c2

Behaviour is identical in each case. I think this can be RESOLVED as NOTABUG.
Comment 5 Joel Madero 2014-07-19 02:41:16 UTC
Seems like a valid enhancement request if not a bug. I'm not sure how the devs would have to implement this to avoid pixelated images.

Marking as:
New
Enhancement
Low - not going to have much of an impact on many users
Comment 6 Luke 2015-11-19 02:25:19 UTC
Created attachment 120646 [details]
example showning Word supports this feature

Word scales both regular bullets and image bullets the same way. Our .docx importer doesn't import image bullets because we don't support this feature. 

I do not think image scaling is an issue as it's up to the user to pick an appropriate resolution for the size of the bullets they require.
Comment 7 Luke 2019-01-23 23:06:22 UTC
Tamás,
You're working on this area. Would you be interested in taking a look at this?