Bug 73973 - Add Plains Cree language to LibreOffice [crk-CA]
Summary: Add Plains Cree language to LibreOffice [crk-CA]
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:4.3.0 target:5.2.0 target:5.1....
Keywords:
: 97584 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-23 12:38 UTC by Francis Tyers
Modified: 2016-11-12 10:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francis Tyers 2014-01-23 12:38:57 UTC
Hey there,

Could you add Plains Cree (ISO-639-3: crk) so that it can be selected from the drop-down menu, and a spellchecker can be installed.

http://www.ethnologue.com/language/crk

Work ongoing on spellchecker here:

https://victorio.uit.no/langtech/trunk/langs/crk

There are two orthographies for this language, one syllabic and one based on Latin script. It would be good to have support or both. e.g.

Plains Cree (Canada, Latin)
Plains Cree (Canada, Syllabic) 

Perhaps the codes could be crk-CA and crk-CA-Latn.
Comment 1 Eike Rathke 2014-01-23 14:09:15 UTC
Actually crk-Latn-CA and crk-Cans-CA

Following http://www.ethnologue.com/language/crk the language list entries probably should be

Cree, Plains, Latin
Cree, Plains, Syllabics
Comment 2 Francis Tyers 2014-02-18 15:12:00 UTC
(In reply to comment #1)
> Actually crk-Latn-CA and crk-Cans-CA
> 
> Following http://www.ethnologue.com/language/crk the language list entries
> probably should be
> 
> Cree, Plains, Latin
> Cree, Plains, Syllabics

This looks good! Thanks :)
Comment 3 Commit Notification 2014-02-25 23:15:29 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=75a22a9fb88b128bb31eb51dc763e42cb76e26c2

added Cree, Plains, Latin [crk-Latn-CN] and Syllabics [crk-Cans-CN], fdo#73973



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 SMoshagen 2016-04-13 22:22:48 UTC
(In reply to Commit Notification from comment #3)
> Eike Rathke committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=75a22a9fb88b128bb31eb51dc763e42cb76e26c2
> 
> added Cree, Plains, Latin [crk-Latn-CN] and Syllabics [crk-Cans-CN],
> fdo#73973

I didn't notice when the bug was closed, but:

the country code part of the locae is wrong. What was committed (as seen above) was CN for China. The correct country code for Plains Cree is CA for Canada (and secondarily US for the United States).

The wrong country code makes using spellers for this locale unreliable, as there is no proper match between spellers with the correct locale string and LO because of the wrong country code.

I opted to reopen the bug since the issue at hand is directly connected to the initial commit that was supposed to fix this bug.
Comment 5 Eike Rathke 2016-04-14 11:59:20 UTC
Oh f*.. /facepalm
Comment 6 Commit Notification 2016-04-14 12:15:11 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2b289c403b7759032a2a50ae23b27f7bd74409f

Resolves: tdf#73973 it's [crk-Latn-CA] and [crk-Cans-CA]

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2016-04-14 12:31:20 UTC
Pending review
https://gerrit.libreoffice.org/24082 for 5-1
https://gerrit.libreoffice.org/24083 for 5-0
https://gerrit.libreoffice.org/24084 for 5-0-6
Comment 8 Commit Notification 2016-04-14 13:55:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c9d5d68a2617f54f38222fc147183d91017b3b99&h=libreoffice-5-1

Resolves: tdf#73973 it's [crk-Latn-CA] and [crk-Cans-CA]

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-04-14 15:05:21 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70341edfa41b3d06fef45c5c24cbf5478830894d&h=libreoffice-5-0

Resolves: tdf#73973 it's [crk-Latn-CA] and [crk-Cans-CA]

It will be available in 5.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-04-14 15:11:05 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cfb4519a971e3168f202486665a8ce28942ed97b&h=libreoffice-5-0-6

Resolves: tdf#73973 it's [crk-Latn-CA] and [crk-Cans-CA]

It will be available in 5.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Justin L 2016-11-12 10:37:30 UTC
*** Bug 97584 has been marked as a duplicate of this bug. ***