Download it now!
Bug 74077 - Calc changing formulas unadvertidely between 4.1 and 4.2
Summary: Calc changing formulas unadvertidely between 4.1 and 4.2
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha1
Hardware: Other All
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0
Keywords: bibisected, regression
: 73760 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-01-26 10:57 UTC by Olivier Hallot
Modified: 2015-12-17 07:35 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
file with cell changing formulas from 4.1 to 4.2 (28.06 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2014-01-26 10:57 UTC, Olivier Hallot
Details
File showing the error (10.11 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2014-01-26 11:43 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2014-01-26 10:57:02 UTC
Created attachment 92806 [details]
file with cell changing formulas from 4.1 to 4.2

Calc is changing cell formulas between version 4.1.4 and 4.2.0.3

4.1.4 from Ubuntu PPA
4.2.0.3 from W7  and Linux.


In the sample file I attached cell D28 changes from

=D27*0,09

to 

=D27*0,32

without even touching any other cell.

A spreadsheet caoont change formulas between versions.
Comment 1 Olivier Hallot 2014-01-26 11:43:09 UTC
Created attachment 92809 [details]
File showing the error
Comment 2 Eliane Domingos de Sousa 2014-01-26 13:13:29 UTC
The same problem with me. I'm using Linux Mint 15 Oliva 64 bits and LibreOffice 4.2.0.3.
Comment 3 Björn Michaelsen 2014-01-26 13:15:26 UTC
cell content is already 0,32 at source-hash-1581b1fc3ac82a7bd62df968226e98604a4ca52d (bibisect 2013-11 oldest).
Comment 4 Olivier Hallot 2014-01-26 13:17:34 UTC
Error occurs even on a blank spreadsheet:

procedure: On a blank sheet under 4.1.4, fill the cells in column A

Row 1 (nothing)
Row 2 =A1
Row 3 =A2*0,32
Row 4 =A3*0,09

Save it and open it in LO 4.2

results obtained in 4.2

Row 1 (nothing)
Row 2 =A1
Row 3 =A2*0,32
Row 4 =A3*0,32

#fail!
Comment 5 Cor Nouws 2014-01-26 14:43:40 UTC
Already a problem in alpha1
Comment 6 Björn Michaelsen 2014-01-26 14:48:43 UTC
cell content is still 0,09 at source-hash-4b9740b4ec3987e1d4d2ad6d20b4dcf996a4fa2e (bibisect 2013-10 oldest).
bibisecting now ...
Comment 7 Björn Michaelsen 2014-01-26 14:56:39 UTC
Bisect log:
# bad: [25428b1e953636f74986622c5df614f04c150ed1] source-hash-cb4e009c4539c535108021934e545194b35cad9d
# good: [f0f6c65eb764f0303f59c58d320e9b0d5a894377] source-hash-4b9740b4ec3987e1d4d2ad6d20b4dcf996a4fa2e
git bisect start 'latest' 'oldest'
# good: [a72833796a7e527d9efc9ca6d8fe9b579e469105] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect good a72833796a7e527d9efc9ca6d8fe9b579e469105
# good: [b21386bf459ae47bd6e461ea94cea6a06729a1ff] source-hash-570fe620e9d573cfc9fc260e6518563c6a6c1a3c
git bisect good b21386bf459ae47bd6e461ea94cea6a06729a1ff
# bad: [091d742e82f2b4608690c697d14f846ffc9164c7] source-hash-349c91c8ec6afc1f5c8499529d559af34d115a76
git bisect bad 091d742e82f2b4608690c697d14f846ffc9164c7
# good: [8f9ca7d8ab2e98061706d2fae7501b75a902d93a] source-hash-3cf0b5cdb05e1d77610431b1b1328102bf05b602
git bisect good 8f9ca7d8ab2e98061706d2fae7501b75a902d93a
# bad: [957af3a493bd71de62b536a590a2630aa4a53a27] source-hash-5166f28e797aec47a8a48213203ebd6a7ee06302
git bisect bad 957af3a493bd71de62b536a590a2630aa4a53a27
# good: [7bd35cbe665503fc9fc769437a723e90b46b2a3a] source-hash-e4ebe80be51fb33545091aa4f0bbc0ea2fe674f0
git bisect good 7bd35cbe665503fc9fc769437a723e90b46b2a3a
# bad: [896c52dbcc24f55d6487750f2d72f0c010f62cff] source-hash-d1cbaee70d3f922937a1993914436c8fc899ebfc
git bisect bad 896c52dbcc24f55d6487750f2d72f0c010f62cff
# good: [e9c4bed0b2622077e75004f7b8a50dd9a02fa584] source-hash-417d1c2b13cbd70300d2921b5667dfadc7e25895
git bisect good e9c4bed0b2622077e75004f7b8a50dd9a02fa584
# first bad commit: [896c52dbcc24f55d6487750f2d72f0c010f62cff] source-hash-d1cbaee70d3f922937a1993914436c8fc899ebfc

So introduced in:
http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=417d1c2b13cbd70300d2921b5667dfadc7e25895..d1cbaee70d3f922937a1993914436c8fc899ebfc

which has 8 calc commits in the beginning.
Comment 8 Björn Michaelsen 2014-01-26 21:02:37 UTC
For the life of me, I cant make sense of this. When I compile 417d1c2b13cbd70300d2921b5667dfadc7e25895 here, it also turns out the bad 0.32 result, although the bibisect build is fine. I even rechecked the "about" box of the bibisect build. I tried to tweak the ./configure-flags of my build to match the bibisect builds flags, still my current builds are always wrong, while the bibisect buildx are right up to until 417d1c2b13cbd70300d2921b5667dfadc7e25895.
Comment 9 Commit Notification 2014-01-27 05:38:00 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d1a4d246f6c82585c6ec8d5d856cf802bffcede

we need to check that the content is equal as well, fdo#74077



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Markus Mohrhard 2014-01-27 05:39:49 UTC
Pending review for 4-2 and 4-2-0.
Comment 11 Commit Notification 2014-01-27 05:56:51 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33c387d27fd36448372d11cb4c4a1971ef5058d1

better check for more formula token types, related fdo#74077



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Markus Mohrhard 2014-01-27 06:03:47 UTC
This one affects all formulas where the difference between two formulas is only a string, a value, a range name, ...

There are a few more cases that I need to inspect later.
Comment 13 Commit Notification 2014-01-27 09:37:36 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb4325eca45b9db36584439f30f7624a1c260e0e&h=libreoffice-4-2

we need to check that the content is equal as well, fdo#74077


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-01-27 12:55:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f59fc4e1ce2d6a506fe5a11123cc32e8c7f16540&h=libreoffice-4-2-0

we need to check that the content is equal as well, fdo#74077


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-02-02 19:37:08 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d881d03e5e7156a434719c689af05717bc58913

fdo#74077: Write unit test for this.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Jean-Baptiste Faure 2014-02-04 05:31:02 UTC
It seems that this bug affects LO 4.1.5.2 too.

Please, is it possible to backport the fix to 4.1.5 ?

Best regards. JBF
Comment 17 Jean-Baptiste Faure 2014-02-04 07:49:18 UTC
(In reply to comment #16)
> It seems that this bug affects LO 4.1.5.2 too.

Sorry, wrong bug report. No problem with LO 4.1.5.2 on the test file.
Best regards. JBF
Comment 18 Kohei Yoshida 2014-02-07 18:17:49 UTC
*** Bug 73760 has been marked as a duplicate of this bug. ***
Comment 19 vulcain 2014-02-17 17:56:41 UTC
In Ubuntu 12.04.4 x86_64 LibreOffice 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b 

I have =D26*0,32 in Cell D27 and =D27*0,09 in Cell D28
Comment 20 Robinson Tryon (qubit) 2015-12-17 07:35:15 UTC Comment hidden (obsolete)