Bug 74179 - .xls table linked in .ppt file is not correctly printed or exported to .pdf
Summary: .xls table linked in .ppt file is not correctly printed or exported to .pdf
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: bibisectRequest, filter:pdf, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-01-29 13:13 UTC by Gianmarco
Modified: 2016-12-20 18:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ppt file with linked xls table (102.50 KB, application/vnd.ms-powerpoint)
2014-01-29 14:15 UTC, Gianmarco
Details
xls with the table linked in the ppt slide (22.00 KB, application/vnd.ms-excel)
2014-01-29 14:16 UTC, Gianmarco
Details
Test document with Calc table (17.00 KB, application/msword)
2014-06-19 09:03 UTC, Eugene Kin
Details
Exported PDF from LibO 3.6 (606.02 KB, application/unknown)
2014-06-19 09:04 UTC, Eugene Kin
Details
Exported PDF from LibO 4.0 (398.98 KB, application/unknown)
2014-06-19 09:04 UTC, Eugene Kin
Details
Exported PDF from LibO 4.3 RC1 (51.28 KB, application/unknown)
2014-06-19 09:05 UTC, Eugene Kin
Details
Exported PDF from LibO 3.5 (25.97 KB, application/unknown)
2014-06-19 09:05 UTC, Eugene Kin
Details
Exported PDF from OO 4.1 (25.96 KB, application/unknown)
2014-06-19 09:06 UTC, Eugene Kin
Details
Exported PDF from LibO 4.3 RC3 (50.36 KB, application/unknown)
2014-07-18 07:03 UTC, Eugene Kin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gianmarco 2014-01-29 13:13:53 UTC
I open with Impress a ppt file which contain a table linked to an excel sheet.
I can see correctly the table on the screen but if I try to print or export it as PDF it loose data in the table.
The table is managed in LO like an image (the link is lost) but since we use a lot of presentation to show company data on momthly basis it is impossible to print any reliable data.
Tested on Windows 7 PRO sp1 32bit and Windows Enterprise 64bit.LO version 4.0.4.2 ;4.1.0.4 ;4.1.4.2;4.1.3.2;4.1.1.2
Test with Debian stable (LO 3.5) print and export are OK.
Same behaviour if we save the file as ODP.
regards
Gianmarco
Comment 1 Gianmarco 2014-01-29 14:15:32 UTC
Created attachment 92998 [details]
ppt file with linked xls table

same issue if we use pptx and xlsx (so MSO2010 files)
Comment 2 Gianmarco 2014-01-29 14:16:12 UTC
Created attachment 93000 [details]
xls with the table linked in the ppt slide
Comment 3 Eugene Kin 2014-06-19 09:01:09 UTC
Confirm the issue with printing and PDF export of DOC/DOCX documents with Calc table in it

1) Create new Text Document
2) Copy/Paste table from Calc
3) Save document in DOC or DOCX format
4) Close document
5) Open document
6) Try to print or make PDF export

Operation takes too long (LibO freezes for couple of minutes)
Tables are exported as images
Printed or exported document get broken (some borders and/or text is missing)

LibO version: 3.6 - 4.3 RC1
LibO 3.5, OpenOffice 4.1.0, Symphony 3.0.1 are making correct export to PDF and printing

Tested on Windows 7 SP1 x64 and Windows XP SP3
Comment 4 Eugene Kin 2014-06-19 09:03:13 UTC
Created attachment 101341 [details]
Test document with Calc table
Comment 5 Eugene Kin 2014-06-19 09:04:10 UTC
Created attachment 101342 [details]
Exported PDF from LibO 3.6
Comment 6 Eugene Kin 2014-06-19 09:04:46 UTC
Created attachment 101343 [details]
Exported PDF from LibO 4.0
Comment 7 Eugene Kin 2014-06-19 09:05:23 UTC
Created attachment 101344 [details]
Exported PDF from LibO 4.3 RC1
Comment 8 Eugene Kin 2014-06-19 09:05:53 UTC
Created attachment 101345 [details]
Exported PDF from LibO 3.5
Comment 9 Eugene Kin 2014-06-19 09:06:23 UTC
Created attachment 101346 [details]
Exported PDF from OO 4.1
Comment 10 Eugene Kin 2014-07-18 07:02:05 UTC
Same here
LibO 4.3 RC3
Comment 11 Eugene Kin 2014-07-18 07:03:27 UTC
Created attachment 103016 [details]
Exported PDF from LibO 4.3 RC3
Comment 12 tommy27 2014-07-18 09:53:32 UTC
edited summary notes and set status as NEW because of independent confirmation by Eugene.

@Gianmarco
please, tell me the very first version the bug is reproducible with.
is 4.0.4.2 ?
Comment 13 Eugene Kin 2014-07-18 13:13:09 UTC
No. I can reproduce the issue with LibO 3.6.6.2
Comment 14 tommy27 2014-07-18 13:27:17 UTC
Thanks. I update version field. Is should ALWAYS indicate the FIRST version where the bug appeared.
Comment 15 Eugene Kin 2014-12-19 12:01:07 UTC
Same here
LibO 4.4.0.1
Comment 16 Eugene Kin 2015-01-09 09:53:38 UTC
Issue still here
LibO 4.4.0.2
Comment 17 Eugene Kin 2015-05-22 11:53:18 UTC
LibO 5.0.0.0beta1 not fixed yet
Comment 18 QA Administrators 2016-09-20 09:41:53 UTC Comment hidden (obsolete)
Comment 19 Eugene Kin 2016-09-23 20:26:31 UTC
The last good version is 3.5.7.2
The first affected version is 3.6.0.4
Issue still present in latest 5.2.2.2
Comment 20 Xisco Faulí 2016-12-06 11:09:39 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 18b3138a7ac4da823e41640bed8a4707029b8fb0
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Probably only happening in Windows. Can someone confirm it's still reproducible in master?
Comment 21 Buovjaga 2016-12-20 18:52:45 UTC
To summarize:

Gianmarco's PPT exports OK
- with 3.5 on Linux (Gianmarco's test)
- with 5.4 on Linux (my test)

Gianmarco's PPT exports badly (only top left corner)
- with 3.6.7.2 on Linux (my test)
- with 5.4 on Windows (my test)

Eugene's DOC exports OK
- with 3.3 on Linux (my test)
- with 5.4 on Linux (my test)

Eugene's DOC exports badly
- with 3.6.7.2 on Linux (my test) (nothing)
- with 5.4 on Windows (my test) (only top 4 rows have content)

So all in all, Gianmarco's and Eugene's issue seem to have the same root cause and this *should* be bibisectable as it has worked on Linux in the bibisect range.

Changing OS to all, even though Linux is OK now with master.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: db9aec4520766c87a09d4cb0238ed06ebaeaaeeb
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 18th 2016

Version: 5.4.0.0.alpha0+
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-18_07:01:05
Locale: fi-FI (fi_FI); Calc: group

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)