Bug Hunting Session
Bug 74365 - EDITING: 'Contour of individual object' should apply when 'Modify Obj. w/ Attributes' is enabled
Summary: EDITING: 'Contour of individual object' should apply when 'Modify Obj. w/ Att...
Status: RESOLVED DUPLICATE of bug 74364
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 11:54 UTC by dg1727
Modified: 2014-12-18 16:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dg1727 2014-02-02 11:54:22 UTC
LibreOffice 4.1.4.2 on Ubuntu 13.04.  

Bug 74364 is similar to this bug, but for Writer instead of Draw.  

1.  Create a new document in Draw.  
2.  Using the Drawing toolbar, draw 3 rectangles in a row, left to right, drawing the middle one a little smaller than the other 2.  Leave the right-hand one selected.  
3.  Shift-click the left-hand rectangle to make a multiple selection that contains the left & right rectangles.  
4.  The displayed selection-handles change from being on the edges of the right-hand rectangle to being on the edges of the bounding box of the 2-rectangle selection.  
5.  Issue:  There is nothing visible to indicate that the middle rectangle isn't selected but the left & right rectangles are selected.  

This is especially a problem if the user is Shift-clicking items like the middle rectangle to add them to, or subtract them from, the multiple selection - there is no visual cue that the Shift-click of the middle rectangle did anything.  (Since the middle rectangle is entirely within the bounding box of the left-&-right-rectangle selection.)  

Inkscape and Dia give much better visual feedback of multiple selections:  
 * Inkscape draws dashed lines around the individual objects.  
 * Dia continues to show the selection handles of the individual objects, but changes the handle colour & makes the handles unselectable.  

I prefer Dia's approach.  The dashed lines in Inkscape can be hard to see.  I think LO Draw should still have selection handles for the bounding box so the selected objects can be resized collectively.

I believe the requested change would cause the Tools > Options... > LibreOffice Draw > View > "Contour of each individual object" tickbox to act as many people would expect it to.  Currently, that tickbox has effect (dashed lines are shown) _only_ when Options toolbar > "Modify Object with Attributes" is disabled, AND _only_ when the multiple selection is being moved or otherwise modified with the mouse.  I think the tickbox should be in effect regardless of those 2 conditions ("Modify Object with Attributes" & whether the selection is being interacted with).
Comment 1 dg1727 2014-12-01 10:06:28 UTC
On the Drawing toolbar, there is a button called Points.  If this button is selected, Draw performs more or less as requested, but still doesn't have the following:  

> I think LO Draw should still have selection handles for the bounding box so
> the selected objects can be resized collectively.

I also think the requested behavior should be in effect even if the Points button isn't selected.
Comment 2 Robinson Tryon (qubit) 2014-12-18 15:22:22 UTC
Giving this bug to the UX Team for evaluation.
Comment 3 V Stuart Foote 2014-12-18 15:58:42 UTC
@dlg1727,

Very likely that the code handling these drawing objects are the same in both draw and writer. Taking care of one will correct the other. Closing this as duplicate of your enhancement bug 74364

*** This bug has been marked as a duplicate of bug 74364 ***