Bug 74388 - Calc crashes when pasting a cell containing single byte and double byte characters from A1 to A2
Summary: Calc crashes when pasting a cell containing single byte and double byte chara...
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on: 72470
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-02 16:28 UTC by HT
Modified: 2014-02-07 22:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test file for your convenience. (11.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-02 16:28 UTC, HT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HT 2014-02-02 16:28:45 UTC
Created attachment 93229 [details]
Test file for your convenience.

Calc crashes every time when pasting a cell containing single byte and
double byte characters. 

Steps to reproduce:
1 Open the attached bugdoc.ods
2 Copy A1 cell
3 Select any cell and paste it
4 Calc crashes

Environmet:
Windows 7
LibreOffice 4.2.0.4 Japanese, downloaded from the official site.

It occurs on a newly created file as well, therefore non-file-specific.
It does not require any complex formatting or data to reproduce this as
you can see from the attachment.

It is very common to see cells containing both single and double byte
characters here in Japan, and copy & paste is quite repeatedly used
operation makes LibreOffice unusable therefore I personally believe
this issue is rather a major one. However, I have set its severity to
"Normal" just for the sake of it. Please do change it if you feel there
is the need. Thank you.
Comment 1 Julien Nabet 2014-02-02 21:02:44 UTC
Just for information, on pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce the crash.

bfoman: if you installed 4.2.0.4, would you have some time to try to test this and retrieve a backtrace if you reproduce the problem? (the test case is very straightforward since it's just a copy paste of a cell)
Comment 2 bfoman (inactive) 2014-02-03 17:43:40 UTC
(In reply to comment #1)
> bfoman: if you installed 4.2.0.4, would you have some time to try to test
> this and retrieve a backtrace if you reproduce the problem? (the test case
> is very straightforward since it's just a copy paste of a cell)

Checked with:
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Windows 8.1 Enterprise 64 bit

Could not reproduce. Copy paste with no crash. A1 cell is visible here as aA - should be Japanese character?
Comment 3 Anthony 2014-02-05 03:40:12 UTC
I Just recently upgraded from 4.14 to 4.2.0.4.

Using Windows 7 Pro x64 and can confirm we are having the same issue with copy and paste from Libre to Webmail in Chrome and IE11. Data will copy but no formatting is copied.
Comment 4 water.qian 2014-02-05 15:05:54 UTC
I can re-produce it Windows XP Calc v4.2.0.4. Actually I think it might be duplicated with my Bug 74482 - FORMATTING: Calc hangs when formating Chinese date format on 2 adjacent cells.

The issue only happen if you paste A1 to A2.  It is ok to past to A3, etc.
Comment 5 bfoman (inactive) 2014-02-05 15:50:30 UTC
(In reply to comment #3)
> I Just recently upgraded from 4.14 to 4.2.0.4.
> Using Windows 7 Pro x64 and can confirm we are having the same issue with
> copy and paste from Libre to Webmail in Chrome and IE11. Data will copy but
> no formatting is copied.

Seems this is another issue - bug 74523 or similar.
Comment 6 Björn Michaelsen 2014-02-06 00:59:34 UTC
> The issue only happen if you paste A1 to A2.  It is ok to past to A3, etc.

Partially confirming this for LibreOffice 4.2.0 on Ubuntu trusty: I get a looping soffice.bin here, eating CPU and freezing the Window.

Not happening on LibreOffice 4.1.4 on Ubuntu 13.10, thus a regression.
Comment 7 Kohei Yoshida 2014-02-07 05:24:06 UTC
It *may* be caused by the same root cause as Bug 72470, but I'm not 100% sure.  Worth a re-test once that fix lands.
Comment 8 m.a.riosv 2014-02-07 22:32:43 UTC
Retested, works for me with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
        TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Bug is still reproducible with 4.2.0.4 after copying the cell a couple of times..

Changed status: duplicate 72470, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***