Download it now!
Bug 74470 - ACCESSIBILITY: OS X the Format Paragraph dialog causes VoiceOver to go into a crash loop when open
Summary: ACCESSIBILITY: OS X the Format Paragraph dialog causes VoiceOver to go into a...
Status: RESOLVED DUPLICATE of bug 72408
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2014-02-03 19:09 UTC by Marco Zehe
Modified: 2015-06-20 11:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Zehe 2014-02-03 19:09:53 UTC
STR:
1. Install 4.2.0 release onto OS X Mavericks.
2. Run it and switch on VoiceOver with CMD+F5.
3. Create a new Writer document.
4. Open Format menu, Paragraph... menu item.

Result: The dialog that opens makes VoiceOver go silent. Sometimes, one hears the repeating VoiceOver start sound, indicating that VoiceOver is restarted due to it having crashed.

5. Press Escape to close the dialog.

Result: VoiceOver restarts once more and then stays on.

I've also observed this in other dialogs when focus is on certain elements, like in the PDF export dialog, although for obvious reasons I don't know what the element says. You'll see it when you tab through the dialog.

I can also not test this on a current 4.3.0-dev build, since that immediately freezes when opening a new Writer document when VoiceOver is running.
Comment 1 V Stuart Foote 2014-02-03 20:02:44 UTC
Roman, Boris ???
Comment 2 V Stuart Foote 2014-02-04 01:59:55 UTC
Tweaking the title a bit. And, could an OS X VoiceOver user confirm with Accessibility Inspector/Verifier.
Comment 3 Niklas Johansson 2014-02-22 15:35:20 UTC
I can confirm it, but I also would say that I believe it is the same issue as I reported in the bug fdo#72408 [1]. When you open the Paragraph dialog you usually land on a textbox and as I reported VoiceOver restarts it self or as you describe it goes into a crash loop. Since no one has confirmed my bug I wont mark this as a duplicate but I will set the Version field to 4.1.2.3 since it's an earlier version and I've seen the issue there as well.

[1] https://bugs.freedesktop.org/show_bug.cgi?id=72408
Comment 4 Joel Madero 2015-05-02 15:41:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 5 Buovjaga 2015-06-20 11:12:19 UTC

*** This bug has been marked as a duplicate of bug 72408 ***