Bug 74835 - Sidebar: editing page margins is very laggy, with high CPU load
Summary: Sidebar: editing page margins is very laggy, with high CPU load
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2014-02-11 11:00 UTC by Mihkel Tõnnov
Modified: 2016-10-24 15:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2014-02-11 11:00:50 UTC
When I edit page margins from the sidebar, Writer lags several seconds behind, with high CPU load. In addition, I can't directly enter the margin values there, only scroll for some reason (i.e. the margin value boxes won't let me write anything there).

Tried now with LibreOffice 4.2.0 RC4 (on Debian Linux, packages from TDF), but the bug was there already in RC3 (at least). However, it works reasonably fast with 4.2.0 beta 2, so it looks like a regression from some time after that.

Steps to reproduce:
1) Create a new document in Writer
2) Enter/copy about a page's worth of text there
3) Open the "Page" part on the Properties sidebar
4) Edit page margins (note that you can only scroll with mouse wheel, not type your desired margin values right into the boxes)
5) Observe lag and CPU spiking
Comment 1 Jorendc 2014-02-11 18:37:50 UTC
I fail to reproduce, tested using Mac OSX 10.9 with LibreOffice 4.2.0.4.

Kind regards,
Joren
Comment 2 Joel Madero 2014-03-02 21:21:58 UTC
Two more machines that cannot reproduce:

Ubuntu 13.10
LibreOffice 4.2.1.1 release
GNOME3

Ubuntu 12.04
GNOME3
LibreOffice 4.2.1.1 release

Both the page margins work quite quickly, one is an i7 quad core but the other one is an older machine that shows no lag at all.

Marking as WFM

@Mihkel - please try with 4.2.1.1 release, if you still see the lag mark as UNCONFIRMED and we'll try to find another tester
Comment 3 Joel Madero 2014-03-02 21:24:43 UTC
One more thing - cannot type values on any of the test machines - so that should be a new bug report as it's a separate issue
Comment 4 Mihkel Tõnnov 2014-03-10 20:54:57 UTC
Tried with 4.2.1.1, still laggy for me:
if I scroll any margin field there, the value first changes by 0,1, then freezes while the page margin moves, then jumps to the final value (which then usually needs further adjusting). Setting as UNCONFIRMED, as requested.
Comment 5 Mihkel Tõnnov 2014-03-10 21:08:23 UTC
(In reply to comment #3)
> One more thing - cannot type values on any of the test machines - so that
> should be a new bug report as it's a separate issue

Filed bug 76002.
Comment 6 V Stuart Foote 2014-03-10 22:02:47 UTC
On Windows 7 sp1, 64-bit no notable lag when resizing
also no issue with direct text entry of margins in roll boxes. 
Will annotate bug 76002 accordingly.

Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

nor on
Version: 4.3.0.0.alpha0+
Build ID: 0919979bd1da3379e030b353a097d8fe1fd8341a
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-10_01:36:32

So no impact on Windows.

Will poke at a Linux in a bit.
Comment 7 V Stuart Foote 2014-03-11 02:37:17 UTC
On Linux (Fedora 20) 3.11.10-301.fc20.x86_64 with GNOME 3 DTE and
Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

I see no delay or lag when using the widgets in the Sidebar 'Page' Content Panel where the predefined  'Narrow', 'Normal', 'Wide' and 'Mirrored' settings are immediately applied to repaint the document page. 

I see the same immediate effect with changes to the 'Left', 'Right', 'Top' and 'Bottom' spinners.

Can confirm the issue of bug 76002.
Comment 8 V Stuart Foote 2014-03-11 02:40:48 UTC
QA administration -- revised summary to reflect split off of bug 76002
Comment 9 A (Andy) 2014-10-17 22:42:36 UTC
for me also not reproducible with LO 4.3.2.2 (Win 8.1)
Comment 10 Alex Jordan 2014-10-26 20:21:38 UTC
Mihkel, is this issue occurring for you just regularly scrolling? The only way I was able to reproduce this was by scrolling extremely fast (by setting my mouse's scroll resistance off). I'm on LO 4.3.3.2 stable.

Either way, I _could_ reproduce. I'm marking this bug as NEW, but it may be resolved as INVALID by a developer if it turns out that this is reasonable behavior for the amount of input events being generated (which wouldn't surprise me).
Comment 11 Yousuf Philips (jay) (retired) 2015-08-08 23:28:01 UTC
Not happening for me on my 8 year old laptop.

@Mihkel: Please provide additional information on how this can be confirmed.

Version: 5.1.0.0.alpha1+
Build ID: 25534a62b2ba398c6298c6b9e521f20de1087540
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-07_14:13:33
Locale: en-US (en_US.UTF-8)
Comment 12 Mihkel Tõnnov 2015-09-04 21:29:31 UTC
I can no longer reproduce this lag with KDE4 in Mageia 5 (running on the same computer as before). So possibly it is/was an issue stemming from KDE3/GTK2 on my old OS (Debian Lenny). Marking as WorksForMe, as it doesn't make much sence to try and get it working lag-free on a near-ancient OS/DE :)