Bug Hunting Session
Bug 76002 - Can't enter custom values in some popup windows (GTK2/GTK3 specific)
Summary: Can't enter custom values in some popup windows (GTK2/GTK3 specific)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: All Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:5.2.4
Keywords: needsDevEval, topicUI
: 89026 (view as bug list)
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2014-03-10 21:07 UTC by Mihkel Tõnnov
Modified: 2016-11-03 21:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mihkel Tõnnov 2014-03-10 21:07:41 UTC
Opening a separate bug request as per https://bugs.freedesktop.org/show_bug.cgi?id=74835#c3:

I can't directly enter the desired page margin values on the "Page" part of the Properties sidebar, can only scroll there (i.e. the margin value boxes won't let me write anything there - they do take focus, though, so Up/Down arrow works).
Comment 1 Jorendc 2014-03-10 21:12:51 UTC
Following https://bugs.freedesktop.org/show_bug.cgi?id=74835#c3 this is confirmed by Joel. Marking as NEW.
Comment 2 Mihkel Tõnnov 2014-03-10 21:14:51 UTC
Oh, and the version is possibly older than 4.2.0.0.beta2, but I can't test this at the moment.
Comment 3 V Stuart Foote 2014-03-10 22:01:44 UTC
Not affecting Windows builds. Setting platform to just Linux.
Comment 4 V Stuart Foote 2014-03-11 02:36:39 UTC
On Linux (Fedora 20) 3.11.10-301.fc20.x86_64 with GNOME 3 DTE and
Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

Confirming the Sidebar issue with this Linux build of no text cursor focus allowing direct entry of margin settings in any of the Custom value spinner widgets of the 'Page' Content Panel:  'Left', 'Right', 'Top' or 'Bottom'

Spinners are fully functional to increase/decrease each and the document repaint is immediate.
Comment 5 Maxim Monastirsky 2014-03-11 09:19:29 UTC
Affects only gtk/gtk3 plugins. Doesn't affect gen/kde4.
Comment 6 Joel Madero 2014-03-11 22:36:53 UTC
Prioritizing to Minor (you can still edit the page margins just not through this one method) so it can slow down professional work (if you prefer the sidebar) but not prevent it
Comment 7 Björn Michaelsen 2015-05-19 13:01:13 UTC
add dev-list to cc for some EasyHacks ...
Comment 8 Maxim Monastirsky 2015-07-07 17:35:06 UTC
*** Bug 89026 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2015-07-07 17:43:29 UTC
So other sidebar popup windows (like character spacing and line spacing) have the same problem.
Comment 10 Mihkel Tõnnov 2015-09-04 21:44:51 UTC
(In reply to Maxim Monastirsky from comment #5)
> Affects only gtk/gtk3 plugins. Doesn't affect gen/kde4.

It affects me on KDE4 as well (Mageia 5, LibO 5.0.0 RPMs from TDF). Could someone else check this?

(In reply to Mihkel Tõnnov from comment #0)
> I can't directly enter the desired page margin values on the "Page" part of
> the Properties sidebar, can only scroll there (i.e. the margin value boxes
> won't let me write anything there - they do take focus, though, so Up/Down
> arrow works).

By the way, Up/Down arrow no longer works there for me in KDE4.
Comment 11 Mihkel Tõnnov 2015-09-04 22:04:12 UTC
Okay, nevermind that - that's caused by having the gnome-integration package installed (in addition to kde-integration). So indeed GTK-specific. (Also setting architecture to "All", because I've seen this on x86 and x64 alike.)
Comment 12 Robinson Tryon (qubit) 2015-12-13 11:24:05 UTC Comment hidden (obsolete)
Comment 13 Maxim Monastirsky 2016-10-19 08:16:06 UTC
Fixed already.

*** This bug has been marked as a duplicate of bug 87120 ***
Comment 14 Francisco 2016-10-19 08:45:40 UTC
(In reply to Maxim Monastirsky from comment #13)
> Fixed already.
> 
> *** This bug has been marked as a duplicate of bug 87120 ***

Hi Maxim,

Bug 87120 appears as verified fixed according to V Stuart using windows 10, using
>On Windows 10 Pro 64-bit en-US with
>Version: 5.2.0.0.alpha0+
>Build ID: 157469896ef56720f33676222b95e81c04ab5c72
>CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
>TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-06_20:10:15
>Locale: en-US (en_US)

>Verified fixed, thanks! 

while this is a *GTK specific* bug which I can still reproduce with LibO 

Versión: 5.2.2.2
Id. de compilación: 1:5.2.2-0ubuntu1~trusty0
Subprocesos de CPU: 4; Versión de SO: Linux 3.13; Renderizado de IU: predeterminado; 
Configuración regional: en-US (es_AR.UTF-8); Calc: group

So it's not the same bug nor fixed.
Comment 15 Maxim Monastirsky 2016-10-19 09:01:09 UTC
(In reply to Francisco from comment #14)
> Bug 87120 appears as verified fixed according to V Stuart using windows 10,

> while this is a *GTK specific* bug
Yes I know, but they both were fixed by the same commit AFAIK.

> Versión: 5.2.2.2
> Id. de compilación: 1:5.2.2-0ubuntu1~trusty0
> Subprocesos de CPU: 4; Versión de SO: Linux 3.13; Renderizado de IU:
> predeterminado; 
> Configuración regional: en-US (es_AR.UTF-8); Calc: group

Well I can't reproduce with:

Version: 5.2.2.2
Build ID: 1:5.2.2-0ubuntu1
CPU Threads: 2; OS Version: Linux 4.8; UI Render: default; 
Locale: en-US (en_IL); Calc: group

under Ubuntu 16.10, nor with 5.2/master builds under Fedora 24. Tested with both paragraph line and character spacing sidebar popups.

> So it's not the same bug nor fixed.
Then please give us more information about your environment (DE, VCL plugin used etc.) and exact reproduction steps. Setting to NEEDINFO until more information is provided. Thanks!
Comment 16 Francisco 2016-10-19 12:56:18 UTC
(In reply to Maxim Monastirsky from comment #15)

> Then please give us more information about your environment (DE, VCL plugin
> used etc.) and exact reproduction steps. Setting to NEEDINFO until more
> information is provided. Thanks!

Interesting. I still can reproduce it with even with a fresh user prefix.

Steps:
1) Create a ODT document
2) Click on the page margin dropdown button. It should list different options for page margins, including 4 text boxes with personalized values at the end.
3) Click on one of this boxes, in order to introduce a custom value using the keyboard

Result:
The prompt doesn't appear

Expected
A prompt appears, indicating that the user is able to introduce a custom number, as in any of this kind of text boxes (Font name and size, position and size for shapes, etc.)

This is what was indicated in comment 0. Also, the fact that the mouse wheel is still working remains.

Furthermore, if one does the same with the Character spacing drop down, a prompt appears in the custom value box if its clicked inside.


On the other hand, sidebar on LibreOffice 5.3 has now a new Page deck, in which custom page margins can't be added. So this bug is only affecting LibO 5.1 - 5.2.
Comment 17 Maxim Monastirsky 2016-10-19 13:40:27 UTC
OK now I see it. So paragraph line and character spacing dropdowns (i.e. Bug 89026 - which is marked as a duplicate of this bug) are fixed, but the page margin is not fixed.

(In reply to Francisco from comment #16)
> On the other hand, sidebar on LibreOffice 5.3 has now a new Page deck, in
> which custom page margins can't be added. So this bug is only affecting LibO
> 5.1 - 5.2.
The page margins dropdown exists in 5.3 too, it is just used in the notebookbar instead. But it allows typing, so indeed it remains 5.1 - 5.2 problem for now.

Anyway, this patch seems to do the trick for 5.2:

https://gerrit.libreoffice.org/30059/
Comment 18 Francisco 2016-10-19 14:28:44 UTC
(In reply to Maxim Monastirsky from comment #17)
> 
> Anyway, this patch seems to do the trick for 5.2:
> 
> https://gerrit.libreoffice.org/30059/

Ok Maxim, thanks for the explanation. Does it mean that it will be ready for LibO 5.2.3?
Comment 19 Commit Notification 2016-11-03 21:28:49 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae8226a2166d6a25dd5b711b0f004ad5da1ba90e&h=libreoffice-5-2

tdf#76002 Grab focus to sidebar dropdowns

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.