Bug 75075 - Stock Chart 3 & Stock Chart 4 not appropriate display
Summary: Stock Chart 3 & Stock Chart 4 not appropriate display
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.3.0
Keywords: regression
: 75193 76667 77441 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-17 03:04 UTC by William Smith
Modified: 2015-01-24 13:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Stock Chart with 2 Print Screen Images Inserted (330.12 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-17 03:04 UTC, William Smith
Details
Stock Chart 4 bug (105.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-19 04:10 UTC, William Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Smith 2014-02-17 03:04:11 UTC
Created attachment 94182 [details]
LibreOffice Stock Chart with 2 Print Screen Images Inserted

The bug effects LO 4.2.0, but not 4.1.5. The OHLC Spread/Range option of the Stock Chart 3 and the Candle option of the Stock Chart 4 does not show appropriately. I tried to reverse the Low position with the High position, but it did not make any difference. When I use LO Calc 4.1.5 to open the same file it works just fine. Please take a look at the LO Calc ods file. (There two screen prints are inserted into the chart file for the comparison.) The top screen print is how it supposed to be, the lower image is with the bug. Also I have noticed that the data labels were not saved in the chart.
Comment 1 William Smith 2014-02-19 04:10:14 UTC
Created attachment 94322 [details]
Stock Chart 4 bug

LibreOffice Stock Chart with 2 Print Screen Images Inserted
Comment 2 e325001 2014-03-27 00:50:02 UTC
*** Bug 76667 has been marked as a duplicate of this bug. ***
Comment 3 Markus Mohrhard 2014-03-29 16:21:23 UTC
*** Bug 75193 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2014-03-30 15:12:38 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6162ce7feb89d2f973ce1077b76ca691f00df1ac

set first position and then size, fdo#75075



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 tommy27 2014-04-16 11:55:41 UTC
*** Bug 77441 has been marked as a duplicate of this bug. ***
Comment 6 tommy27 2014-04-16 11:56:54 UTC
@Markus
could this be backported to 4.2.x as well?
4.1.x branch is not affected according to first comment.