Bug Hunting Session
Bug 75093 - Draw objects in frames disappear in writer documents.
Summary: Draw objects in frames disappear in writer documents.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-17 13:36 UTC by mail
Modified: 2014-07-10 01:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Lots of Draw objects in frames have disappeared (become invisible?) (405.30 KB, application/vnd.oasis.opendocument.text)
2014-02-17 13:36 UTC, mail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2014-02-17 13:36:37 UTC
Created attachment 94202 [details]
Lots of Draw objects in frames have disappeared (become invisible?)

Similar to Bug 75091, embedded Draw objects in writer documents disappear when I try to paste a draw object into a frame. The document becomes corrupted beyond repair (at least for me) as undo does not work in this case. This bug happens every few weeks to me, it is even worse than Bug 75091 as lots of OTHER images disappear SILENTLY, i.e. images somewhere in the document disappear and I continue working for quite a while without noticing. This is a nightmare for me, as I have large, complex legacy documents.

The feature creep in LO, instabilities and general cracking of the seams that have become more pronounced with version 4.x make working with LO a new adventure every day.

Add the notorious (nearly 10 years now?) problem of "Disappearing Pictures" (http://ask.libreoffice.org/en/question/24520/impress-images-disappear-randomly-and-spontaneously/) that is about as pleasant as cracking your pants in front of an audience. Add the general neglect for impress development in the LO community which I've never understood - as a professor I make negative advertisement for LO every time to a lot of students. 

I'm done. MS Office, here I come.
Comment 1 mail 2014-02-25 08:33:31 UTC
I'm really sorry - this seems to be more of a rendering problem: After restarting Windows and LO the images were visible again. Still, this problem has become more pronounced with 4.1.x (maybe 4.0.x but I skipped that branch) and it is at least a nuisance (if you know that the document is not corrupt after all).
Comment 2 sophie 2014-03-05 14:29:53 UTC
Hi, I don't reproduce with version 4.1.5.3 under Debian 6.0, the document displays all the objects. May be you'll have a better handling if you increase the values under Tools > Options > LibreOffice > Memory. Sophie
Comment 3 Joel Madero 2014-07-10 01:43:59 UTC
As Sophie (one of our lead QA people) cannot confirm I am closing this as WORKSFORME.

Suggestions:
1. Do what Sophie suggested by increasing memory in settings
2. Reset profile https://wiki.documentfoundation.org/UserProfile
3. Download and try 4.2 branch: http://www.libreoffice.org/download/libreoffice-fresh/

If none of those work please set the bug back to UNCONFIRMED and we'll try additional tests. Thanks!