Bug 75191 - ACCESSIBILITY: remove deprecated atk_role_register
Summary: ACCESSIBILITY: remove deprecated atk_role_register
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on: 39944
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2014-02-19 09:01 UTC by Jacobo Aragunde Pérez
Modified: 2016-10-25 19:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2014-02-19 09:01:22 UTC
atk_role_register is deprecated [1]. Our code should be reviewed to check if LibO needs any roles that do not exist yet in ATK, and fill bugs to get them added in the specification. Finally, atk_role_register should be removed.

We need to be careful with roles that might not exist in older versions of ATK. We can still find old versions of ATK in some platforms supported by LibO, probably RHEL.

[1] https://developer.gnome.org/atk/unstable/AtkObject.html#atk-role-register
Comment 1 Joel Madero 2014-05-19 15:18:28 UTC
Requesting developer input on this one as I have no clue if (1) it's a valid request and (2) if the bug tracker is the appropriate place to list all the code that we should remove.
Comment 2 Jacobo Aragunde Pérez 2014-07-03 15:01:40 UTC
(In reply to comment #1)
> Requesting developer input on this one as I have no clue if (1) it's a valid
> request

I think it is, as I was the one filing it :D . The goal of the bug was serving as a reminder of something that should be done at some point.

> (2) if the bug tracker is the appropriate place to list all the
> code that we should remove.

My opinion is that it's a valid place, but of course that's a matter of discussion.

In this particular case we are not talking about removing a lot of code, just doing some calls in a different way. I'll try to cook a patch to reduce unnecessary use of atk_role_register and I think we could close the bug.
Comment 3 Jacobo Aragunde Pérez 2014-07-03 15:12:13 UTC
I've just noticed that atk_role_register call was marked as deprecated on the commit 2e1177a1b602623d5f2703bdee558f83318928ac.
Comment 4 Jacobo Aragunde Pérez 2014-07-03 18:34:15 UTC
atk_role_register will not be necessary once every accessible role in LibreOffice matches a role in ATK. I've reviewed the list of missing roles and did an update on bug #39944.

Once that bug is closed, this one could be considered fixed too; atk_role_register would still be present in our code but only used when LO has to work with old-ish ATK versions.
Comment 5 Robinson Tryon (qubit) 2014-07-03 18:59:33 UTC
Bug appears to be appropriately commented and triaged, so removing 'NeedAdvice' from the whiteboard.
Comment 6 QA Administrators 2015-07-18 17:44:40 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 7 Jacobo Aragunde Pérez 2015-08-12 09:03:57 UTC
There have been no changes in ATK role mappings, so this bug is still valid.
Comment 8 Jacobo Aragunde Pérez 2015-08-12 09:05:03 UTC
Sorry for the noise, I forgot to add:

Version: 5.1.0.0.alpha1+
Build ID: 0f4b3cb7d3d68906de316a64dcec281da2a641bd
Comment 9 Commit Notification 2015-12-28 12:56:12 UTC
Jacobo Aragunde Pérez committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b250f3ddd7d8a14746b4df1029b7cbf3ae86b1d1

tdf#75191: only call atk_register_role if strictly necessary

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.