Bug 75311 - FILEOPEN: Legend of Chart created in Excel .xlsx lost when imported
Summary: FILEOPEN: Legend of Chart created in Excel .xlsx lost when imported
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-21 10:22 UTC by Luke
Modified: 2014-02-24 16:19 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple .xlsx chart showing issue chart legend missing (10.34 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-02-21 10:22 UTC, Luke
Details
Another Simple .xlsx chart showing issue chart legend missing (10.25 KB, application/vnd.ms-excel.12)
2014-02-21 10:27 UTC, Luke
Details
Simple .odt chart showing legend position saved on import (24.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-21 10:30 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-02-21 10:22:16 UTC
Created attachment 94495 [details]
Simple .xlsx chart showing issue chart legend missing

Steps to reproduce:
1. Create a chart in Excel 2007/skydrive
2. Manually move the chart’s legend anywhere (without using the default positions, top, bot, left right)
3. Save the .xlsx file
4. Open with LibreOffice Calc 4.2 or newer

Note: The legend is missing. Even if you do a print preview, the legend is not displayed. However, if you play with the chart by resizing and moving it around, you can usually make the legend reappear. It will be in the correct place, unlike Bug 75309.
Comment 1 Luke 2014-02-21 10:27:18 UTC
Created attachment 94498 [details]
Another Simple .xlsx chart showing issue chart legend missing
Comment 2 Luke 2014-02-21 10:30:22 UTC
Created attachment 94500 [details]
Simple .odt chart showing legend position saved on import

This attachment shows that the position is saved from imported .xlsx files. However, if you save this .odt file as .xlsx file, the legend position will be lost.
Comment 3 Luke 2014-02-24 16:19:17 UTC
While testing another bug, I reinstalled LO, rebooted, and deleted my profile. I can't reproduce this bug at the moment.