Download it now!
Bug 75309 - FILEOPEN: Legend position lost when importing/exporting MS .docx charts
Summary: FILEOPEN: Legend position lost when importing/exporting MS .docx charts
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart 75054
  Show dependency treegraph
 
Reported: 2014-02-21 09:48 UTC by Luke
Modified: 2014-12-06 12:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple .docx chart showing issue chart legend position (17.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-21 09:48 UTC, Luke
Details
Simple .odt chart showing issue chart legend position export (17.67 KB, application/vnd.oasis.opendocument.text)
2014-02-21 09:54 UTC, Luke
Details
Simple .docx chart showing result of Writer export (4.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-21 09:57 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-02-21 09:48:25 UTC
Created attachment 94492 [details]
Simple .docx chart showing issue chart legend position

Steps to reproduce

Importing:
1. Create a chart in Word2007/skydrive
2. Manually move the chart’s legend anywhere (without using the default positions, top, bot, left right)
3. Save the .docx file
4. Open with LibreOffice Writer 4.2 or newer

Note: The legend is centered and all position data is lost
 
Exporting:
1. Create a chart in LO Writer
2. Move the chart’s legend anywhere
3. Save as .docx
4. Open with Word2007/skydrive

Note: The legend is centered and all position data is lost
Comment 1 Luke 2014-02-21 09:54:46 UTC
Created attachment 94493 [details]
Simple .odt chart showing issue chart legend position export
Comment 2 Luke 2014-02-21 09:57:27 UTC
Created attachment 94494 [details]
Simple .docx chart showing result of Writer export

Notice how the legend position data is lost when opened in Word or Writer.
Comment 3 ign_christian 2014-06-28 10:35:55 UTC
Hi Luke..

I think this report is too general, different type of chart could produce different result. And this contains 2 main bugs: export & import, usually it's separated. 

It's better if you could give step by step procedure to create particular chart. Anyway, perhaps it's been reported before? Looks like many bugs regarding chart legend.
Comment 4 Luke 2014-06-28 21:03:40 UTC
@ign_christian
Are you having trouble reproducing this bug with the attachment 94493 [details]? I just tested with 4.4 and it's still reproducible. 

What part of my instructions can't you follow or are not clear? Every chart type and chart data that I've tried has yields this bug. The key to triggering this bug is moving the legend without using the defaults in the dialog box(top, left, right, bot). How much more specific do you need?

It's true that someone needs to isolate the cause of this bug, but that's beyond what I'm capable of.
Comment 5 Luke 2014-08-10 18:02:41 UTC
Creating Separate reports: Bug 82423 and Bug 82425