Download it now!
Bug 82423 - FILEOPEN: Legend position lost when importing MS .docx charts
Summary: FILEOPEN: Legend position lost when importing MS .docx charts
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks: 75054
  Show dependency treegraph
 
Reported: 2014-08-10 17:56 UTC by Luke
Modified: 2015-12-17 04:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Viewed in Word 2013 (85.33 KB, application/pdf)
2014-08-10 19:38 UTC, Joel Madero
Details
Viewed in Writer 4.3.0.4 (15.15 KB, application/pdf)
2014-08-10 19:38 UTC, Joel Madero
Details
Result from LO 4.2.6.2, 4.2.4.2, 4.3.1.1 (8.84 KB, application/pdf)
2014-08-11 02:24 UTC, ign_christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-08-10 17:56:35 UTC
Steps to reproduce

Importing:
1. Create a chart in Word2007/skydrive
2. Manually move the chart’s legend anywhere (without using the default positions, top, bot, left right)
3. Save the .docx file
4. Open with LibreOffice Writer 4.2 or newer

Note: The legend is centered and all position data is lost. attachment 94492 [details] illustrates this issue.
Comment 1 Joel Madero 2014-08-10 19:37:34 UTC
Confirmed:
Windows 8.1 & Bodhi 2.x
LibreOffice 4.3.0.4

Attaching what we see in Microsoft Office 2013 vs. LibreOffice 4.3.0.4

Prioritizing:
Normal - can prevent high quality/professional work
Medium - seems fine unless we can confirm this as a regression

@Markus - interested in this one? There is another one related to exporting and the legend isn't opening in the right position in Windows. Probably related
Comment 2 Joel Madero 2014-08-10 19:38:07 UTC
Created attachment 104391 [details]
Viewed in Word 2013
Comment 3 Joel Madero 2014-08-10 19:38:28 UTC
Created attachment 104392 [details]
Viewed in Writer 4.3.0.4
Comment 4 ign_christian 2014-08-11 02:24:36 UTC
Created attachment 104399 [details]
Result from LO 4.2.6.2, 4.2.4.2, 4.3.1.1

LO 4.2.6.2 and 4.3.1.1 has slightly better result. At least series sequence is in correct order & shown all.

Also same result in 4.2.4.2. Seems only 4.3.0.4 that has incorrect order of series.

Not a regression, chart not shown at all in LO 4.1.6.2. So it's an improvement :)
Comment 5 Markus Mohrhard 2015-04-25 13:10:33 UTC
Seems to be much improved. We now import all properties and just can't handle the non-overlay flag which is tracked in another bug report.

I'm closing this one as WFM.
Comment 6 Robinson Tryon (qubit) 2015-12-17 04:36:19 UTC
Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]