Download it now!
Bug 75054 - FILEOPEN: MS .docx Fails to import chart properly
Summary: FILEOPEN: MS .docx Fails to import chart properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on: 75309 75316 75317 82423 82425
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-02-16 13:53 UTC by Luke
Modified: 2015-12-15 11:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Word/Writer comparison of attachment 94136 (265.80 KB, image/jpeg)
2014-02-16 15:32 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-02-16 13:53:37 UTC
+++ This bug was initially created as a clone of Bug #67339 +++

This bug was tested LibreOffice v4.3 running in windows 7. It appears that LibreOffice loses formatting when importing MS .docx files with charts. I have attached an example.

Steps to reproduce the bug:
1. download attachment 94136 [details]
2. Open Demo-Hayden-Management-v2-chart-test2.docx document in writer 
3. Open attached Demo-Hayden-Management-v2-chart-test2.docx document in Word2007/skydrive
4. Compare the documents. 

Please note:
A) Title axis is not vertically (270 deg) aligned
B) Legend is not placed at the bottom of the chart
C) First data label of 2nd column (250) is displayed on the bottom
Comment 1 Luke 2014-02-16 15:32:41 UTC
Created attachment 94164 [details]
Word/Writer comparison of attachment 94136 [details]
Comment 2 Jorendc 2014-02-17 09:12:16 UTC
Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

This'd be also reproducible using 4.2.0.4, so marking as such.
Comment 3 Luke 2014-02-21 11:37:06 UTC
Since there are 3 separate bugs here, I broke this report into 3 new ones:
A) Bug 75316 
B) Bug 75309
C) Bug 75317 

For all 3 bugs I have created simpler test cases, using .xlsx files, except for B) which only occurs on the .docx importer.

QA, feel free to either close this report, or keep it open as a meta tracker. It may be useful to use this report's attachment 94136 [details] as a testcase to confirm that import bugs are fixed in both the .xlsx and .docx importer. This will ensure cases like B) to not occur again.
Comment 4 tommy27 2014-02-21 11:49:25 UTC
I think we could keep it open as a meta-bug. added dependancies.
Comment 5 Luke 2015-05-13 07:02:21 UTC
Thanks to everyone's hard work, the only remaining import/export issue with this complex chart is a minor layout glitch. There is no need to track that here. 

Closing this as Resolved. Great work team!
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:51:45 UTC
Migrating Whiteboard tags to Keywords: (filter:docx)
[NinjaEdit]