Bug 75807 - Calc: Formatting-Toolbar: Borderstyle-icon does not remember last borderstyle
Summary: Calc: Formatting-Toolbar: Borderstyle-icon does not remember last borderstyle
Status: RESOLVED DUPLICATE of bug 58349
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2014-03-05 16:52 UTC by a07cd040897db54e103c
Modified: 2015-12-16 22:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A screenshot of the border-style icon. (8.95 KB, image/png)
2014-03-05 16:52 UTC, a07cd040897db54e103c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a07cd040897db54e103c 2014-03-05 16:52:49 UTC
Created attachment 95176 [details]
A screenshot of the border-style icon.

The borderstyle-icon inside the "formatting" toolbar is separated into two clickable areas. First, the icon itself and second the arrow area on the right, which should display all available borderstyles in a submenu (see attached screenshot with the labeled areas). 

Intuitively one would expect, that, if a certain style is selected by clicking the arrow (marked as "2" in the screenshot), this borderstyle is remembered - and that this remembered style can be re-applied to selected cells by clicking the icon (marked as "1" in the screenshot) itself.

Currently LO does *not* remember the last used borderstyle and both areas behave the same way - they both open the submenu displaying all available styles. There is no functional difference between the two areas.

May be this bug applies to other icons (all?).
Comment 1 Joel Madero 2014-03-07 03:20:48 UTC
Indeed - I would call this an enhancement request since it seems to work as it was designed (but it should be changed)

Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Tue Feb 25 19:58:48 2014 +0100 
Platform: Ubuntu Linux 13.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
High - this would make the border styles button behave the same as every other similar button (highlight, font color, background color) which seems to be ideal.

Whiteboard Status - ProposedEasyHack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Maxim Monastirsky 2014-10-21 20:04:06 UTC

*** This bug has been marked as a duplicate of bug 58349 ***
Comment 3 Robinson Tryon (qubit) 2015-12-16 22:31:18 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]