Bug Hunting Session
Bug 76238 - EDITING: Australian dictionary spellchecker does not work
Summary: EDITING: Australian dictionary spellchecker does not work
Status: RESOLVED DUPLICATE of bug 75734
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 81569 81921 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-16 20:11 UTC by ofperkins83
Modified: 2015-07-06 22:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ofperkins83 2014-03-16 20:11:05 UTC
Problem description: Having updated to LibreOffice 4.0.1 on Fedora, I noticed that when I try to spell check a document with the English (Australia) dictionary, the spell check appears to function but doesn't do anything. If I were to check a document, it would always say that there are no errors, but when I manually check the document, there are clear spelling errors. 

Steps to reproduce:
1. Open new Writer document and change language to English (Australia)
2. Type something with an obvious spelling error in it
3. Run spellcheck

Current behavior: The spellcheck will return no errors. If necessary it will show "continue from top" message, but no errors will be found. (Auto spellcheck also finds no errors.)

Expected behavior: The spellcheck should find the errors in the text and make correction suggestions. 

              
Operating System: Fedora
Version: 4.1.0.4 release
Comment 1 Thomas Hackert 2014-04-13 16:09:43 UTC
Hello ofperkins83, *,
I cannot confirm your observation with LO Version: 4.1.6.1 Build-ID: a59ce81388f477fc89db57f0c27f222f31884eb (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) with Germanophone lang- as well as helppack) nor with LO Version: 4.3.0.0.alpha0+
Build ID: b7c7bd3de0fdadaf5e4769e0759d68ad17fb7bd0 TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-04-10_02:05:19 with installed en_US lang- as well as helppack under Debian Testing i686 ... :(

But as I only have learned British English in the past: Would you be so kind to attach a test document to this bug, please? And/or test it with a newer version than 4.1.0.4, please?

I have tested it this way:
1. "Tools – Language – For all Text – More..."
2. Selected "English (Australia)" at the dropdowmn menu "Western" below the header"Default language for document"
3. Closed the dialog
4. Entered a short German (my mother tongue) sentence and also the sentence "For colourful people you should use a color without a hidden meaning. (Maybe a really horrible sentence ... ;) )

I get "color" marked as wrong here. Could you confirm, that it is wrong in Australian English?

BTW: Is your version the one, which is provided with Fedora? If so, I think it is better to report a bug to their bugtracker and to their version of LO ... ;)

Sorry for the inconvenience
Thomas.
Comment 2 fthain 2014-05-21 03:22:08 UTC
(In reply to comment #1)
> Hello ofperkins83, *,
> I cannot confirm your observation...

I can confirm the bug. The latest stable Mac OS X build is affected:
Version: 4.1.6.2
Build ID: 40ff705089...

> 
> But as I only have learned British English in the past: Would you be so kind
> to attach a test document to this bug, please?

You can reproduce the problem by creating a new document and typing some garbage. The spell checker can find no problem and it always reports "Spell check complete."

The spell checker behaves exactly the same when you change the document language to "None" as when you change it to "English (Australian)".

> I get "color" marked as wrong here. Could you confirm, that it is wrong in
> Australian English?

Australian English is the same as British English (ignoring idioms). "Color" is the U.S. spelling. In Australia and the U.K. the spelling is "colour".

So one workaround is to switch the default language to English (U.K.) in settings. But changing the default may not help for documents already saved with language "English (Australian)".
Comment 3 tommy27 2014-05-22 18:25:07 UTC
has situation improved in 4.2.x?
Comment 4 fthain 2014-05-26 07:41:39 UTC
(In reply to comment #3)
> has situation improved in 4.2.x?

We had to abandon 4.2 due to interoperability issues with Microsoft Office.

I can't speak for the original reporter of this bug on Fedora, but I think in my case this is partly user error.

I did some more research (that is, I actually RTFM) and the problem is that no dictionary is present for the default language, i.e. English (Australia).

By reading the manual, I discovered that a peculiar tick symbol having the letters ABC would indicate the presence of a dictionary. This appears to be a user interface failure. I doubt that any readily understood symbol conveys "no dictionary present" so why not just put the words there instead?

I tried to install an English (Australian) dictionary using the Tools -> Language -> More Dictionaries Online command. No additional English dictionaries were available from extensions.libreoffice.org for 4.1.

So we will keep using the English (UK) language default as a workaround.
Comment 5 ofperkins83 2014-06-15 23:32:53 UTC
(In reply to comment #4)
> (In reply to comment #3)
> I can't speak for the original reporter of this bug on Fedora, but I think
> in my case this is partly user error.
> 
> I did some more research (that is, I actually RTFM) and the problem is that
> no dictionary is present for the default language, i.e. English (Australia).
> 
> By reading the manual, I discovered that a peculiar tick symbol having the
> letters ABC would indicate the presence of a dictionary. This appears to be
> a user interface failure. I doubt that any readily understood symbol conveys
> "no dictionary present" so why not just put the words there instead?

This is absolutely right. I did not realise that the appropriate dictionary was not installed. I found the appropriate language package on the Fedora repos (I don't remember what it was called) and was able to install it. The spellcheck worked well after that. But I do agree - at the very least, when the spellcheck is run with a language that has no spellcheck dictionary, I think it should return and say "no dictionary installed" rather than just "spellcheck complete".
Comment 6 Robinson Tryon (qubit) 2015-01-02 06:07:03 UTC
*** Bug 81921 has been marked as a duplicate of this bug. ***
Comment 7 Jean-Baptiste Faure 2015-01-05 05:47:27 UTC
*** Bug 81569 has been marked as a duplicate of this bug. ***
Comment 8 Joel Madero 2015-07-04 15:29:32 UTC
Per last comments I am closing this as WFM.

UX could probably discuss how to improve language support for writing aids (making it easier to know what is installed and how to install). That being said, this seems like user error :)
Comment 9 fthain 2015-07-04 23:40:21 UTC
(In reply to Joel Madero from comment #8)

> Per last comments I am closing this as WFM.

Works For Me? So it somehow works for you that the same issue has been
reported more than four times, in this bugzilla alone?

>
> UX could probably discuss how to improve language support for writing
> aids (making it easier to know what is installed and how to install).

Then why not re-assign the bug accordingly so that it can be fixed.

> That being said, this seems like user error :)

And closing this bug is clearly a developer error

Obviously there is a UX issue here. If you don't intend to fix that,
then close with bug with "WONTFIX".
Comment 10 Joel Madero 2015-07-05 00:36:27 UTC
Okay without getting into an argument - please don't change status' if you don't know what they represent. REOPENED is wrong. Setting to NEW just because I don't have the time or energy to do anything else.

From my understanding someone has said they got it to fix (by installing the right dictionaries according to documentation which is readily available). The separate issue (the UX issue) is a DIFFERENT issue that *should* be reported separately.

That being said - I'm removing myself from cc.
Comment 11 Bryan Quigley 2015-07-06 22:01:22 UTC
There is already a bug on the bad UI -

*** This bug has been marked as a duplicate of bug 75734 ***