Bug Hunting Session
Bug 76266 - [PIVOTABLE][FILEOPEN][FUNCTION]: Opening .xlsx file with Pivot table displays the wrong Data Field Function
Summary: [PIVOTABLE][FILEOPEN][FUNCTION]: Opening .xlsx file with Pivot table displays...
Status: RESOLVED DUPLICATE of bug 74370
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-17 13:19 UTC by Gergely Rácz
Modified: 2015-01-24 14:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Pivot data field function is wrongly displayed (12.95 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-03-17 13:19 UTC, Gergely Rácz
Details
New file from scratch that can't be opened. (7.53 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-03-18 00:11 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gergely Rácz 2014-03-17 13:19:08 UTC
Created attachment 95936 [details]
Pivot data field function is wrongly displayed

Steps to reproduce

1. Create  4x4 table with text in it (or use the uploaded file).
2. Create a Pivot table on a new sheet (put 1 field in “Columns”, “Rows” and “Values”, make sure that the function in the “Value” field is set to “Count”)
3. Save file in xlsx format.
4. Open the file with Calc.

Results:
The data fields are empty because the pivot table uses “Sum” instead of “Count”.

Expected results:
It should display the data fields correctly (in this case “Count” function).

Facts:
This issue only works if you have only “Count” function in your Pivot table (I have used with several functions in the same time and the datas were perfectly displayed)

The problem does not show up If you save the .xlsx file in .odt (i.e: MS Office 2013) and open the .odt file with LibreOffice.
Comment 1 m.a.riosv 2014-03-18 00:11:09 UTC
Created attachment 95974 [details]
New file from scratch that can't be opened.


I can't open sample file with, LibreOffice hangs:
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
Version: 4.2.1.1 Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Version: 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
Version: 4.2.3.1 Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13
Version: 4.2.4.0.0+ Build ID: b5b9da46ceae23b25e963087d00b0ae5b4785c93
   TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-03-13_23:32:39


I can't reproduce the issue with:
Version: 4.1.6.0.0+ Build ID: 0b772a163b2536fc55aa3b4de925119e33af769
Version: 4.3.0.0.alpha0+ Build ID: 12ae7672f285da1d4c730315e8db23b3396b71cc
  TinderBox: Win-x86@39, Branch:master, Time: 2014-03-14_00:18:00

With 4.2.2.1:
Recreating the pivot table in a new spreadsheet and saving as xlsx, again I can not able to open this new file.
Comment 2 Kevin Suo 2014-03-22 09:42:41 UTC

*** This bug has been marked as a duplicate of bug 74370 ***