Bug Hunting Session
Bug 74370 - Pivot table COUNT field imported as SUM field from xlsx
Summary: Pivot table COUNT field imported as SUM field from xlsx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 76266 (view as bug list)
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2014-02-02 12:17 UTC by Andras Timar
Modified: 2018-07-26 08:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Pivot table and chart not imported from xlsx (27.81 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-02-02 12:17 UTC, Andras Timar
Details
PDF shows the file open with MSO 2010 (207.34 KB, application/x-msdownload)
2014-03-10 10:22 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2014-02-02 12:17:18 UTC
Created attachment 93215 [details]
Pivot table and chart not imported from xlsx
Comment 1 Kevin Suo 2014-03-10 09:34:16 UTC
Comment on attachment 93215 [details]
Pivot table and chart not imported from xlsx

Corrected MIME type.
Comment 2 Kevin Suo 2014-03-10 10:17:03 UTC
Tested with LO 4.1.5.4:

1. Pivot table is imported, but NOT imported properly.

LO is showing "SUM - Gyártó" field, which result in empty results because there are only TEXT values in Gyártó. When unzip the xlsx file I found the following in pivotTables\pivotTable1.xml:

<dataField name="Darab / Gyártó" fld="1" subtotal="count" baseField="0" baseItem="0" />

When open with MSO 2010 it shows correctly "count" field, rather than "sum" field.

2. Chart is imported, but it's an empty chart. (so no problem with chart import, chart is empty because Pivot table "sum" field is empty)

3. When I creat a fresh xlsx file with MSO 2010, input some data and insert a pivot table with COUNT dataField, then I can reopen it correctly with LO 4.1.5.4. My UI language is zh_CN, so maybe it's because of locale issue? "Gyártó" is Hungarian.

4. When "save as" xlsx again, the pivot table become a normal table, which is the same issue as in "Bug 58691 - PIVOTTABLE: export to Excel 2007/2010 breaks functionality".
Comment 3 Kevin Suo 2014-03-10 10:19:27 UTC
Changing status to NEW,

and chaning Title
from: FILEOPEN: Pivot table and chart not imported from xlsx
to: FILEOPEN: Pivot table COUNT field imported as SUM field from xlsx

If you disagree, feel free to change it back.
Comment 4 Kevin Suo 2014-03-10 10:22:10 UTC
Created attachment 95495 [details]
PDF shows the file open with MSO 2010
Comment 5 Kevin Suo 2014-03-22 09:42:41 UTC
*** Bug 76266 has been marked as a duplicate of this bug. ***
Comment 6 Joel Madero 2015-05-02 15:41:32 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-06-20 13:15:18 UTC
It seems to be much better now, but it has a Total result for some reason and it makes the chart totally different from the MSO2010 PDF.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 8 QA Administrators 2016-09-20 10:10:38 UTC Comment hidden (obsolete)
Comment 9 János Néhrer 2016-09-21 03:09:07 UTC
Comment 7 still applies: The Total row appears in chart as a 50% slice of the pie.

Win 8.1 x86-64
Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
Comment 10 Julien Nabet 2018-07-25 10:13:48 UTC
On pc Debian x86-64 with LO Debian package 6.0.6.1, I don't reproduce this.
When editing layout, I can see "Compter - Gyártó" ("Compter" is French for "to count")
Can we close this one?
Comment 11 Xisco Faulí 2018-07-26 08:51:58 UTC
(In reply to Julien Nabet from comment #10)
> On pc Debian x86-64 with LO Debian package 6.0.6.1, I don't reproduce this.
> When editing layout, I can see "Compter - Gyártó" ("Compter" is French for
> "to count")
> Can we close this one?

Confirmed in

Version: 6.2.0.0.alpha0+
Build ID: dcbb65f2a4a3ee70ccd4896d7a5e975dbd9e6509
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

Closing as RESOLVED WORKSFORME