Bug Hunting Session
Bug 58691 - PIVOTTABLE: export to Excel 2007/2010 breaks functionality
Summary: PIVOTTABLE: export to Excel 2007/2010 breaks functionality
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 67024 74876 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2012-12-23 19:36 UTC by paulchen
Modified: 2014-12-06 12:18 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Pivottable (22.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-23 19:36 UTC, paulchen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulchen 2012-12-23 19:36:13 UTC
Created attachment 72042 [details]
LO Pivottable

I created a pivottable with LO4.000b2. It works with some (less severe) problems: 1. bad performance with larger data tables (in a pivot table with 450 lines x 230 columns it takes up to 25 sec. to update after using the filter buttons), 
2. column filter buttons become nonfunctional when they exceed the rectangular cell range of the pivot table (try to use the filter button "Datum" in the attached "Pivottable_Test.ods").

However, when saving this document as Excel 2007/2010 (XLSX), and reopening, all pivottable functionality is lost: the table is still there, but without filter buttons and all the other logic behind. A showstopper! This exported file also shows the fat cell borders mentioned in #58356.

In my opinion, the Pivottable seems to need a good amount of bugfixing and a more efficient code for being usable in everyday work. So, please don't add new features until the existing don't work.
Comment 1 m.a.riosv 2012-12-24 01:42:34 UTC
Thanks for reporting @paulchen.

Confirmed, columns filter and save/load xlsx, issues.
Wintx64Ultimate
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)

Curious, changing the Data subtotal on a column field to automatic, makes the column filter again available for both columns (Datum & Probenummer).
Comment 2 Petr Mladek 2013-01-07 15:13:00 UTC
The pivot table functionality is lost when exporting into XLSX also with LO-3.6 and 3.5. So, it is not a regression => can't block the release => lowering the severity a bit.

Note that the OOXML import/export filters are work in progress. It is being improved in every LO release.

Kohei, Muthu, Noel, could you please have a look? I am not sure who of you works on the XLSX import/export.
Comment 3 Kevin Suo 2014-03-10 09:42:14 UTC
Changing platform to all because I also reproduce this in Linux (Ubuntu 13.10 and Fedora 20)
Comment 4 Kevin Suo 2014-03-10 10:29:01 UTC
*** Bug 67024 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Suo 2014-03-15 00:49:14 UTC
*** Bug 74876 has been marked as a duplicate of this bug. ***
Comment 6 Björn Michaelsen 2014-07-12 20:13:02 UTC
MABs should be priority highest.
Comment 7 Kohei Yoshida 2014-09-04 07:45:27 UTC
The master branch should do a better job on this.  Still not perfect (and probably never will be due to incompatibilities between Excel and Calc's pivot tables), but it's better than nothing.
Comment 8 tommy27 2014-12-03 01:56:40 UTC
@paulchen
please retest with LibO 4.3.4 or 4.4.0.0 alpha and tell if the issue persists.
Comment 9 Kevin Suo 2014-12-03 03:09:40 UTC
Actually there are 3 different issues in this bug report:

1."Bad performance with larger data tables"

This issue is resolved because of the pivot table dialog change in version 4.3, see:
https://wiki.documentfoundation.org/ReleaseNotes/4.3#Pivot_Table_layout_improvement

The corrosponding bug report is bug 77927.

2. "Column filter buttons become nonfunctional when they exceed the rectangular cell range of the pivot table"

This is still reproducible in version 4.4.0 beta 1.
This is the same issue as described in bug 86932.

3. "when saving this document as Excel 2007/2010 (XLSX), and reopening, all pivottable functionality is lost"

This is still reproducible in version 4.4.0 beta 1.
This is the same issue as described in bug 78614.


So, I believe it is safe to close this bug, and keep tracking the still reproducible bug 86932 and bug 78614 instead.
Comment 10 Kevin Suo 2014-12-03 03:29:12 UTC
@tommy27: I suggest to close this bug, and add bug 78614 to MAB4.3.
Comment 11 tommy27 2014-12-05 22:49:39 UTC
ok. did it.
Comment 12 Jean-Baptiste Faure 2014-12-06 11:37:18 UTC
What does mean Resolved *Moved* here?

Best regards. JBF
Comment 13 tommy27 2014-12-06 12:18:50 UTC
I was uncertain how to label this since it has been splitted in 3 different reports.

my interpretation of the MOVED status is that we "move" the discussion about the present generic bug (3 issues into one) to the other 3 specific bug reports.

If I'm wrong please correct me.