Bug 76513 - FILEOPEN DOCX: positioning of drawing objects - lines grouped together with a shape (Comment 11)
Summary: FILEOPEN DOCX: positioning of drawing objects - lines grouped together with a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks: DOCX-Objects DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2014-03-23 15:48 UTC by Afrim Hoxha
Modified: 2022-02-07 11:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This document opens very differently in word and writer. (2.43 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-23 15:48 UTC, Afrim Hoxha
Details
Faulty import of lines (27.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-04-02 16:22 UTC, Regina Henschel
Details
Correct import with only two lines (26.39 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-04-02 16:23 UTC, Regina Henschel
Details
The minimized example in LO 7.1 (247.16 KB, image/png)
2022-01-11 14:58 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Afrim Hoxha 2014-03-23 15:48:40 UTC
Created attachment 96245 [details]
This document opens very differently in word and writer.

In a complex document with formulas and custom drawing elements such as electronic schematics, graphs etc, the formulas are shown correctly and identical in office 2010 and libreoffice writer 4.2.2.1, while the drawing elements are spread throughout the document, and thouse who have same positioning are oriented bad (such as lines, freehand and straight ones). Also dash-dot lines in word 2010 are shown as full lines in writer. When saved in .odt format from word 2010 and opened in writer, the shapes are shown correctly although some bad shaping occurs. The same document in docx format opened in Kingsoft Office, opens correctly, almost exactly as word 2010. I know that you don't have control over docx, but the specs are open and I believe you can do better than Kingsoft.
Comment 1 Thomas van der Meulen [retired] 2014-03-23 16:48:17 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.3.0.0.alpha0+
Build ID: 1a67b7cc3d5dc3dcd0de0e247f638c33d57dea1b
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-03-23_05:59:09
OS: Mac osx 10.9.2

I have compared it with Microsoft word 2007 on Windows 7 and the drawings are very off yes.
Comment 2 Joel Madero 2015-05-02 15:41:49 UTC Comment hidden (obsolete)
Comment 3 Alexandr 2015-05-04 15:04:43 UTC
Reproducible with LibreOffice 4.3.3 and 5.0.0.0 alpha1 on Debian.
Comment 4 Robinson Tryon (qubit) 2015-12-13 12:18:23 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-12-10 16:39:16 UTC Comment hidden (obsolete)
Comment 6 Cor Nouws 2017-12-29 11:26:05 UTC
@afrohoxha@gmail.com Looking at the attachment, I have the idea that things improved over time. But I have no PDF/image with your situation.
Could you please have a look. Maybe cut one or two parts of the document, that clearly show an issue. Makes it easier to reproduce and ultimately to repair too.
Thanks - Cor
Comment 7 Cor Nouws 2019-05-23 13:22:45 UTC
(In reply to Cor Nouws from comment #6)
> @afrohoxha@gmail.com Looking at the attachment, I have the idea that things
> improved over time. But I have no PDF/image with your situation.
> Could you please have a look. Maybe cut one or two parts of the document,
> that clearly show an issue. Makes it easier to reproduce and ultimately to
> repair too.
> Thanks - Cor
Is there any pdf and a clear description available of one, two (three..) main issues in rendering? That really makes sense for developers and QA people to (possibly) work on improving.
If not, I propose to close this issue.
Comment 8 QA Administrators 2019-11-20 03:51:28 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2019-11-23 17:17:19 UTC
Putting it back to NEW.
The document hangs at import time due to bug 125460
Comment 10 NISZ LibreOffice Team 2020-09-08 11:14:32 UTC
Mostly DML grouped shapes and MS Equation Editor formula in this one.
Comment 11 Regina Henschel 2021-04-02 16:22:35 UTC
Created attachment 170920 [details]
Faulty import of lines

The problem happens with simple lines, which will become LineShape in LO, if they are grouped together with a shape, that will become a CustomShape in LO. In that case the lines are not properly scaled and positioned.
Comment 12 Regina Henschel 2021-04-02 16:23:42 UTC
Created attachment 170921 [details]
Correct import with only two lines

The import is correct, if the group contains only the lines.
Comment 13 Gabor Kelemen (allotropia) 2022-01-11 14:58:38 UTC
Created attachment 177462 [details]
The minimized example in LO 7.1

attachment 170920 [details] from comment 11 started to look correctly in 7.1 after:

https://git.libreoffice.org/core/+/b393336817a64f8703607d3f6de37d0b6498d49c

author	Xisco Fauli <xiscofauli@libreoffice.org>	Thu Mar 18 00:48:49 2021 +0100
committer	Xisco Fauli <xiscofauli@libreoffice.org>	Thu Mar 18 13:35:55 2021 +0100

tdf#118693: no need to use convertMm100ToTwip() for line shapes anymore

Still the original document might be a good source of "improvement opportunities", so let's keep this open for a while.
Comment 14 Timur 2022-02-04 16:05:59 UTC
This bug only makes sense if a single defined issue. So I rename per Comment 11.

As for original DOCX attachment 96245 [details], it's 54 pages in MSO and cannot be used as a sample.
Comment 15 Timur 2022-02-04 16:07:18 UTC Comment hidden (obsolete)
Comment 16 Timur 2022-02-04 16:09:31 UTC Comment hidden (obsolete)
Comment 17 Timur 2022-02-07 10:48:37 UTC
I retested and I mark Fixed. 
attachment 177462 [details] minimized example looks OK.

I see a problem in original attachment 96245 [details] at page 18.
In Fig. 2.5 graphs (d), (e), (f) don't display text. But it shows up upon any change in document. Saving only that page in MSO to old or new format makes it immediately visible in LO. So I will not report. 

Another small difference at page 21 and 22 and 25 and 35, I will not report. 

Notable bug is at page 34, text in diagram is not seen. Also happens if page extracted in MSO. I'll report and See Also. 

Worst seem pages 38-40 and the position of Fig.3.13 up to Fig.3.16. But it's about wrongly manually created document with enters.