Bug 76708 - Formatting: Borders toolbar button does not work
Summary: Formatting: Borders toolbar button does not work
Status: RESOLVED DUPLICATE of bug 73159
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-27 20:24 UTC by Ian Stronach
Modified: 2014-03-31 10:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of panel opened when the Borders toolbar button is clicked (51.51 KB, image/bmp)
2014-03-27 20:24 UTC, Ian Stronach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Stronach 2014-03-27 20:24:25 UTC
Created attachment 96483 [details]
Screenshot of panel opened when the Borders toolbar button is clicked

Borders button on toolbars does not work properly - instead of a panel from which to select the required borders, a small empty blue panel appears with only a "close" button - see attachment
Comment 1 A (Andy) 2014-03-28 18:59:28 UTC
Could you please give more information about the different single steps to reproduce this issue.
Comment 2 Ian Stronach 2014-03-28 20:48:26 UTC
Issue occurs when Borders toolbar button is clicked in Writer at any point after opening Writer document, even after opening new document.
Have removed the Borders toolbar button and then reinstated it - issue still arises.
This issue arises only on Windows Vista PC, recently upgraded to v4.1.5.3.

I have tried to reproduce the problem on a Windows 7 PC, also recently upgraded to v4.1.5.3, but on Windows 7 install the Borders toolbar button does not appear to be available at all.
Comment 3 A (Andy) 2014-03-28 21:11:09 UTC
For me not reproducible with LO 4.2.2.1 (Win 8.1).

I have to admit that I don't have a border toolbar.  Please correct my comment if the following steps how I tried to reproduce it are not correct.

Steps Done:
1. Open WRITER
2. Go to TABLE -> INSERT -> TABLE
3. Put the cursor inside the table
4. Go to the toolbar at the bottom and look for the button "Borders, add lines; SHIFT to add and remove" and open it

Remark: I tried it also when generating a new Border toolbar (VIEW -> TOOLBARS -> CUSTOMIZE -> tab TOOLBARS)

Result: For me everything looks fine.


@Ian: Please correct me if there is maybe a misunderstanding from my side.
Comment 4 Ian Stronach 2014-03-28 22:35:53 UTC
This is not a problem with borders in tables - I have just checked and the table borders can be set either from the table menu, or by using the borders button on the table toolbar.  Also borders can be set okay from the paragraph context menu item.  The problem is only with the Borders button on the general toolbars (eg for putting a line between paragraphs) - which does not seem to be available at all in Win 7, and has this issue in Win Vista:
1 Open Writer
2 Create new Text Document
3 Click on Borders button on the toolbar - this was there by default in my Win Vista LibreOffice install, but can be added/removed either by using the right-click "Visible Buttons" context menu item when moused over the toolbar, or via the View/Toolbars/Customise menu (but not by either means in Win 7 install)
4 "empty" blue panel appears as originally described.
Comment 5 A (Andy) 2014-03-29 07:51:40 UTC
@Ian: Thanks for your reply.  I don't have this Border button.  

Maybe somebody else can help?  Can anybody else with MS Vista check this issue?
Comment 7 manj_k 2014-03-29 12:11:14 UTC
Added Zolnai Tamás to CC List.
Comment 8 Tamás Zolnai 2014-03-31 10:05:44 UTC

*** This bug has been marked as a duplicate of bug 73159 ***