Download it now!
Bug 73159 - UI: clicking the 'Add Border' button leads to a void menu/window
Summary: UI: clicking the 'Add Border' button leads to a void menu/window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:4.3.0 target:4.2.3 target:4.1.6
Keywords:
: 72878 76708 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-30 16:01 UTC by jaygrey
Modified: 2014-05-06 20:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jaygrey 2013-12-30 16:01:35 UTC
In 'Writer' the 'Borders' button, when added to the suitable panel in the User Interface, actually doesn't work at all.

WHAT HAPPENS: write any line of text, then try to add to it a border by using the 'Borders' button instead of going directly into the 'Format > Paragraph > Borders' menu. The result is a void window, containing just the two buttons 'OK' and 'Cancel' without any other 'sign of life', so to speak.

VERSION: as far as I can see, with every version higher than 4.0.x. Right now I've observed it again in the most recent release 4.1.4 (but I had observed it before in the 4.1.3 and in the 4.0.x with x < 6).

OS: ALL, I suspect.

For sure: Linux -> openSUSE 12.x / 13.1 with i386 and x86_64 architectures
          Windows -> XP 32 / Vista 32

Thank you
Comment 1 Julien Nabet 2013-12-30 18:58:09 UTC
On pc Debian x86-64 with 4.1.3 Debian package, I can reproduce this.
Since it was also present in 4.0.X (as indicated in the description), I update the version to the last one of 4.0.X version.

Also,
- with 4.2 sources updated some days ago, there's no "Borders" entry to add, just twice "Bottom" (one with icon, the other without).

- with 4.3 sources updated today, there's no "Borders" entry to add and 1 option "Bottom"

Caolán: might be interested in this one. I don't know if this part has been converted with new UI (I didn't find it on cgit but perhaps missed it). If needed, I can open other trackers.
Comment 2 Commit Notification 2014-02-27 07:34:10 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f73ffb91b85422067274fafc0d411aef8a6e6abb

fdo#73159 Make back border dialog work again



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2014-02-27 09:19:51 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e661e6cb6f9e7c45bbd97c4dc8c489a7af952d60&h=libreoffice-4-2

fdo#73159 Make border dialog work again


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-02-27 09:24:22 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=97197e881d609404288eaa903fa7db2c3b0c70b6&h=libreoffice-4-1

fdo#73159 Make border dialog work again


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Tamás Zolnai 2014-03-31 10:05:44 UTC
*** Bug 76708 has been marked as a duplicate of this bug. ***
Comment 6 manj_k 2014-05-06 20:57:09 UTC
*** Bug 72878 has been marked as a duplicate of this bug. ***