Download it now!
Bug 76751 - FILESAVE: docx rendered differently after (save, reopen)
Summary: FILESAVE: docx rendered differently after (save, reopen)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-28 17:48 UTC by Terrence Enger
Modified: 2015-08-08 01:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
.pdf exported from orignal file (77.23 KB, application/pdf)
2014-03-28 18:13 UTC, Terrence Enger
Details
.pdf exported after (SaveAs, reopen) (75.41 KB, application/pdf)
2014-03-28 18:14 UTC, Terrence Enger
Details
PDF exported using Word 2013 (813.05 KB, application/pdf)
2014-05-09 21:36 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2014-03-28 17:48:48 UTC
STR:

(1) Downlowad the attachment to bug 76074, file
    2118263146_Optimized.docx.

(2) Open 2118263146_Optimized.docx in LiberOffice.

    Program action observed:
      - The Writer window opens to the first page.  A text box
        containing "Prep 2 A.L - Final Revision 2013" is about half
        way down the page and right of centre.
      - The status bar at the bottom of thw Writer window shows "Page
        0 of 7 <separator> 1836 words, 110666 characters <separator>
        First Page" and so forth.

(3) Save the file as, let us say, /tmp/d1.docx.

(4) Close the Writer window.

(5) Open /tmp/d1.docx.

    Program action expected: The Writer window should look as
    described in step (2).

    Program action observed:
      - First page starts with heading "1. Fill in the gaps with the
        correct word." followed by a numbered list starting "1. You've
        ....... ...... ... her feelings with your impolite comments.".
      - Status bar shows "Page 0 of 6 <separator> 1870 words, 11831
        characters <separator> First Page" and so forth.
      - The second page (status bar: "Page 1 2/6") has the text box
        originally described in step (2); test is wrapping around both
        sides of the box."

Note that the files from "Export to PDF" match the screen rendering as
far as I have looked.  I shall attach .pdf files exported at steps (2)
and (5).


These observations are based on commit 8931ab3, as fetched 2014-03-23,
configured:
    --enable-option-checking=fatal
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src
built and running on debian-wheezy 64-bit.


Notes to triager:

(*) Bug 75208 "FORMATTING: Lots of formatting problems in complex
    .docx document" sounds similar.  This one differs in that it
    complains about problems introduced at a specific stage of
    processing with LibreOffice.  Feel free to close this bug as a
    DUP.

(*) LibreOffice 3.5.4.2, delivered with debian-wheezy, also shows
    changes across (saveAs, close, reopen); but the original display
    is different and the changes are different.  I tend to think that
    this report does not qualify as a regression.
Comment 1 Terrence Enger 2014-03-28 18:13:00 UTC
Created attachment 96563 [details]
.pdf exported from orignal file
Comment 2 Terrence Enger 2014-03-28 18:14:44 UTC
Created attachment 96564 [details]
.pdf exported after (SaveAs, reopen)
Comment 3 Terrence Enger 2014-03-28 18:17:46 UTC
@Rohit,

Is it the case that your attachment to bug 076074, file
2118263146_Optimized.docx, was produced by MS Word?  Can you attach a
.pdf showing how MS Word renders the document?

Thanks,
Terry.
Comment 4 Jorendc 2014-05-09 21:35:53 UTC
Tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: e9b2787c2ece4c8260fbac6359257e1829c917d4
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-09_06:36:37

(In reply to comment #0) 
> (5) Open /tmp/d1.docx.
> 
>     Program action expected: The Writer window should look as
>     described in step (2).
> 
>     Program action observed:
>       - First page starts with heading "1. Fill in the gaps with the
>         correct word." followed by a numbered list starting "1. You've
>         ....... ...... ... her feelings with your impolite comments.".

Reproducible

>       - Status bar shows "Page 0 of 6 <separator> 1870 words, 11831
>         characters <separator> First Page" and so forth.

Looks fixed to me. Status bar displays Page 0/7 | 1836 words, 11666 characters. In Word 2013 the document also has 7 pages. 

>       - The second page (status bar: "Page 1 2/6") has the text box
>         originally described in step (2); test is wrapping around both
>         sides of the box."

Reproducible

Kind regards,
Joren
Comment 5 Jorendc 2014-05-09 21:36:12 UTC
Created attachment 98779 [details]
PDF exported using Word 2013
Comment 6 Terrence Enger 2014-05-09 23:26:09 UTC
Thank you, jornend.

Upon reopening the file, my debug build of commit f585323 still shows
changed info in the status bar, as I described in step (5).  Of
course, a different platform and the debug build give lots of room for
differences.

It is reassuring that the first rendering by LibreOffice is close to
the rendering by MS Word.  I do notice that in the page heading the
words "ENGLISHSHEET" is swapped left-for-right with the lighthouse
logo.  This is small potatoes compared to moving the text box from the
first page to the second.
Comment 7 Terrence Enger 2015-08-08 01:46:01 UTC
The problem is gone with daily dbgutil bibisect version 2915-08-07 ...
    Version: 5.1.0.0.alpha1+
    Build ID: 09a9234c021ad98c5adeb493b5814e97b92ee912
    Locale: en-CA (en_CA.UTF-8)

I am setting bug status RESOLVED WORKSFORME.