Download it now!
Bug 76813 (Thumbs) - FILESAVE: File saved in undesired manner
Summary: FILESAVE: File saved in undesired manner
Status: RESOLVED DUPLICATE of bug 78818
Alias: Thumbs
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.1 rc
Hardware: Other Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-31 02:12 UTC by Hoa Moc Lan
Modified: 2014-05-27 12:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
One html file and two docx files saved by different LibreOffice versions (66.77 KB, application/zip)
2014-03-31 02:12 UTC, Hoa Moc Lan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hoa Moc Lan 2014-03-31 02:12:01 UTC
Created attachment 96634 [details]
One html file and two docx files saved by different LibreOffice versions

Problem description: Attached are two documents I have saved using LibreOffice. I have copied the contents from an html file (Black Viper’s Windows 8.1 Service Configurations).

Steps to reproduce:
1. Untitled1.docx has been created using LibreOffice V.4.2.0.4.
2. Untitled2.docx has been created using LibreOffice V.4.2.3.2.
3. ....

Current behavior:In my opinion, LibreOffice V.4.2.3.2 maybe a backstep as compared to LibreOffice V.4.2.0.4.

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.3.1 rc
Comment 1 cee@ceyer 2014-05-23 22:16:18 UTC
Using Linux Mint 13 Cinnamon and LibreOffice 3.5.7.2 (100% Linux machine) A friend sent me a CD with a password protected file written in Microsoft Word. The file on the CD was indeed password protected (I opened the file with LibreOffice Writer and tested it). I saved the CD file to my hard drive in odf format. Next I opened the file on my hard drive with LibreOffice Writer and all security was gone. I could type text or edit graphics at will.

My question is How could this happen? This is a very important issue as the file is a professional document that represent years of research and is copyrited.

Does it have something to do with saving a word file to odf format? Thank you for your help

Please note: I copied a password protected Microsoft Excel file from my laptop (Windows 7 machine) to my Linux hard drive. I opened the excel file using LibreOffice Calc and it was still password protected. I saved the file to odf format and it remained password protected. I have only seen this (Password protection removed) happen with writer.

Thank you
Comment 2 Yousuf Philips (jay) (retired) 2014-05-27 12:21:53 UTC
The initial bug report is a duplicate of 78818.

Regarding comment 1, please attempt the same issue with a currently supported version of LibreOffice like 4.1.6 or 4.2.4 and if you have the same issue, please create a new bug report for it, so we can look into the issue further. I have attempted the same thing of opening an encrypted .docx from word 2010 in LibreOffice 4.2.4 and when you decide to save the file as an .odt, it will prompt you to set a password.

*** This bug has been marked as a duplicate of bug 78818 ***