Download it now!
Bug 78818 - EDITING: Formatted content from a web browser is pasted unformatted by default
Summary: EDITING: Formatted content from a web browser is pasted unformatted by default
Status: RESOLVED DUPLICATE of bug 78801
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: Thumbs (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-17 09:59 UTC by domike
Modified: 2014-05-27 20:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description domike 2014-05-17 09:59:48 UTC
Steps to reproduce:
1. Open a web page in web browser, copy some content
2. Paste into Writer (without Paste special)

Current behavior:
Text is unformatted and images are not pasted.

Expected behavior:
Text formatting and images are preserved.


This can be worked around via Paste special, however this should not be the default.


Operating System: Windows 8
Version: 4.2.3.3 release
Last worked in: 4.2.2.1 release
Comment 1 domike 2014-05-17 10:05:55 UTC
Does not happen on:

Win 8 + LibreOffice 4.1.5.3
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Win 8 + X-LibreOffice 4.2.2.1 ( https://it.libreoffice.org/download/portatile/ )
Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

Happens on:

Win 8 + X-LibreOffice 4.2.3.3
Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0
Comment 2 domike 2014-05-18 11:24:32 UTC
Does not happen on:

Ubuntu 13.10 + LibreOffice 4.1.2.3
Build ID: 410m0(Build:3)

Ubuntu 12.04 + LibreOffice 4.2.2



Happens on:

Ubuntu 14.04 + LibreOffice 4.2.3.3
Build ID: 420m0(Build:3)

Ubuntu 13.10 + LibreOffice 4.2.4.2 ( https://launchpad.net/~libreoffice/+archive/libreoffice-4-2 )
Build ID: 420m0(Build:2)

Ubuntu 12.04 + LibreOffice 4.2.3
Comment 3 Yousuf Philips (jay) (retired) 2014-05-26 00:23:44 UTC
Confirmed on Linux Mint. Shows correctly in 4.0.6.2, but not in 4.1.6.2, 4.2.4.2, and 4.3 beta 1.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-27 12:21:53 UTC
*** Bug 76813 has been marked as a duplicate of this bug. ***
Comment 5 manj_k 2014-05-27 13:04:56 UTC
See also: Bug 78801 - Copying Text + Image from Website - Image Skipped
Comment 6 Michael Stahl (CIB) 2014-05-27 20:18:35 UTC
regression from:

commit 91a55de7be6a23685a875517495c1af67f3a8b60
Author:     Andrzej Hunt <andrzej.hunt@collabora.com>
AuthorDate: Fri Feb 7 18:18:42 2014 +0000
Commit:     Caolán McNamara <caolanm@redhat.com>
CommitDate: Sat Mar 1 07:26:14 2014 -0600

    fdo#52547 SOT: Prefer embedding image data to embedding linked image.
Comment 7 Michael Stahl (CIB) 2014-05-27 20:22:26 UTC
ah there's another bug about this

*** This bug has been marked as a duplicate of bug 78801 ***