Download it now!
Bug 76938 - FILESAVE: SVG files not compressed anymore in ODT
Summary: FILESAVE: SVG files not compressed anymore in ODT
Status: RESOLVED DUPLICATE of bug 71622
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 76936 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-02 09:26 UTC by Côme Desplats
Modified: 2015-12-15 10:55 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Document with SVG saved with LibreOffice 4.2 (202.62 KB, application/vnd.oasis.opendocument.text)
2014-04-02 09:26 UTC, Côme Desplats
Details
Document with SVG saved with LibreOffice 4.1 (24.82 KB, application/vnd.oasis.opendocument.text)
2014-04-02 09:27 UTC, Côme Desplats
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Côme Desplats 2014-04-02 09:26:16 UTC
Created attachment 96768 [details]
Document with SVG saved with LibreOffice 4.2

The SVG files are not compressed in ODT since LibreOffice 4.2. Documents containing SVG files are significantly bigger than with previous versions.

It seems that the method Store is used in the Picture directory instead of the method Deflate. It makes sense for PNG files, but not for SVG

Steps to reproduce:
1. Insert SVG file in your document
2. Save Document

Current behavior:
The document size is significantly bigger than it should.

Expected behavior:
SVG files should be compressed with Deflate method.
Operating System: Windows 8
Version: 4.2.2.1 release
Last worked in: 4.1.5.3 release
Comment 1 Côme Desplats 2014-04-02 09:27:05 UTC
Created attachment 96770 [details]
Document with SVG saved with LibreOffice 4.1
Comment 2 sophie 2014-04-02 12:16:49 UTC
*** Bug 76936 has been marked as a duplicate of this bug. ***
Comment 3 Andras Timar 2014-04-24 19:43:03 UTC

*** This bug has been marked as a duplicate of bug 71622 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:55:03 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]