Download it now!
Bug 77044 - FILEOPEN : Incorrect docX import (frames border)
Summary: FILEOPEN : Incorrect docX import (frames border)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2014-04-04 08:24 UTC by jmgigandet
Modified: 2019-02-28 20:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
frames in .docx file are not properly rendered in Writer (10.63 KB, application/msword)
2014-04-04 08:24 UTC, jmgigandet
Details
LibO 4.3beta vs ms word 2007 (41.97 KB, image/jpeg)
2014-05-26 00:42 UTC, Yousuf Philips (jay) (retired)
Details
LibO 4.3 beta vs 4.2.4 (58.57 KB, image/png)
2014-05-26 00:47 UTC, Yousuf Philips (jay) (retired)
Details
Bug still present on 5.4.3.2 (174.56 KB, image/png)
2017-12-11 07:07 UTC, jmgigandet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jmgigandet 2014-04-04 08:24:01 UTC
Created attachment 96890 [details]
frames in .docx file are not properly rendered in Writer

Import of MS DocX documents with frames is not correct.
Writer adds a border where there's none in MS Word.
Saving the same document as .doc in MS Word, and importing it in Writer is ok.
Comment 1 Yousuf Philips (jay) (retired) 2014-05-26 00:39:25 UTC
Well opening up the file in word 2007 has it as a textbox and not a frame, though LibO shows it as a frame.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-26 00:42:09 UTC
Created attachment 99816 [details]
LibO 4.3beta vs ms word 2007
Comment 3 Yousuf Philips (jay) (retired) 2014-05-26 00:46:19 UTC
Tested the LibO rendering on the latest releases of 3.6 - 4.2 and 4.3 beta, with 4.3 being a regression of the so-called frame's location.
Comment 4 Yousuf Philips (jay) (retired) 2014-05-26 00:47:29 UTC
Created attachment 99817 [details]
LibO 4.3 beta vs 4.2.4
Comment 5 Yousuf Philips (jay) (retired) 2014-05-27 15:40:48 UTC
my reported LibO shape to frame bug 79289.
Comment 6 Joel Madero 2014-06-02 22:29:22 UTC
Removed bibisectrequest and regression as the regression seems to be different than the original report
Comment 7 QA Administrators 2015-06-08 14:42:10 UTC Comment hidden (obsolete)
Comment 8 jmgigandet 2015-06-08 14:57:20 UTC
Tested on 4.4.3.2 (Os X 10.9 and Win 7 Pro 64).
Still the same issue.
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:32:49 UTC Comment hidden (obsolete)
Comment 10 Joel Madero 2016-01-01 21:34:40 UTC
Again removing bibisectRequest - please don't add it again to this bug. I explained why I removed it.

This bug pertains to the frame around the text box - the position of the box is a separate issue which should be reported separately. Please don't conflate issues as it just makes them hard to track and even harder to find a developer to tackle the issue.
Comment 11 QA Administrators 2017-12-10 16:41:30 UTC Comment hidden (obsolete)
Comment 12 jmgigandet 2017-12-11 07:06:40 UTC
Bug still present in 5.4.3.2 (see attachment) on MacOSX 11 and Windows 7 X64.
Comment 13 jmgigandet 2017-12-11 07:07:39 UTC
Created attachment 138359 [details]
Bug still present on 5.4.3.2
Comment 14 QA Administrators 2018-12-12 03:42:57 UTC Comment hidden (obsolete)
Comment 15 jmgigandet 2018-12-12 06:52:46 UTC
Bug still present in 6.1.3.2 (Win 7 Pro X64)