Bug 77682 - LibreOffice comments should have ATK_ROLE_COMMENT
Summary: LibreOffice comments should have ATK_ROLE_COMMENT
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Jacobo Aragunde Pérez
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2014-04-19 22:17 UTC by Joanmarie Diggs
Modified: 2014-05-07 15:05 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
screenshot (88.40 KB, image/png)
2014-04-19 22:17 UTC, Joanmarie Diggs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joanmarie Diggs 2014-04-19 22:17:29 UTC
Created attachment 97625 [details]
screenshot

Steps to reproduce:
1. Create a Writer document and insert a comment
2. Launch Accerciser and explore the accessible hierarchy

Expected results: The comment would be exposed with ROLE_COMMENT.

Actual results: The comment is exposed as ROLE_SCROLL_PANE. (See attached screenshot.)

If it were me, I'd just change the role of the scroll-pane object. At least in my mind, the "comment" being pointed to is the entire yellow post-it-note-looking thing (incuding the author, date, and actions; not merely the question it contains. Besides, the fact that this object is a scrollbar-less scroll pane is of no interest to Orca or its users. :) So unless there's a good reason not to touch the role of the scroll-pane, I'd be most appreciative if that were the fix.

Thanks in advance!
Comment 1 Jacobo Aragunde Pérez 2014-04-25 09:34:35 UTC
Already fixed in master (would be part of 4.3), due to this commit:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e031c8ae1ac046fcf165213d80e83311d80a71f5

Shall we backport it?
Comment 2 Jacobo Aragunde Pérez 2014-05-07 08:28:43 UTC
Backported to 4.2 branch: https://gerrit.libreoffice.org/#/c/9267/
Comment 3 Jacobo Aragunde Pérez 2014-05-07 08:32:42 UTC
(In reply to comment #0)
> ... So
> unless there's a good reason not to touch the role of the scroll-pane, I'd
> be most appreciative if that were the fix.
> 

There was no good reason, in fact the internal UNO role for that element is a "comment" too and it's just being translated to ATK's scroll-pane, maybe because ATK comment role didn't exist at that time.
Comment 4 Jacobo Aragunde Pérez 2014-05-07 15:05:14 UTC
Pushed to 4.2 branch, will be available in 4.2.5 :)

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67dab7c4b851573747e41def560e26dacdb8ceac&h=libreoffice-4-2